user-desktop icon shows transparent desktop instead of Unity's wallpaper

Bug #862040 reported by Jeremy Bicha on 2011-09-29
44
This bug affects 7 people
Affects Status Importance Assigned to Milestone
ubuntu-mono (Ubuntu)
High
Paul Sladen
Oneiric
High
Paul Sladen

Bug Description

With ubuntu-mono 0.0.36, the user-desktop icon as seen in the Alt-Tab switcher and in the file browser is now black instead of the Unity-themed version from 0.0.34 and earlier.

ProblemType: Bug
DistroRelease: Ubuntu 11.10
Package: ubuntu-mono 0.0.36
ProcVersionSignature: Ubuntu 3.0.0-12.19-generic 3.0.4
Uname: Linux 3.0.0-12-generic x86_64
ApportVersion: 1.23-0ubuntu2
Architecture: amd64
Date: Thu Sep 29 01:25:53 2011
PackageArchitecture: all
SourcePackage: ubuntu-mono
UpgradeStatus: No upgrade log present (probably fresh install)

Jeremy Bicha (jbicha) wrote :
Adolfo Jayme (fitojb) wrote :

One question: Why daniplanas’ icons [1] hasn’t been accepted?

[1] https://bugs.launchpad.net/ubuntu/+source/humanity-icon-theme/+bug/838256/comments/16

Changed in ubuntu-mono (Ubuntu):
status: New → Confirmed
Paul Sladen (sladen) wrote :

This is appearing in the Alt-tab switcher too?

Please can you post the output of:

  dpkg -l ubuntu-mono

and:

  dpkg -L ubuntu-mono | grep desktop | rev | cut -d/ -f1 | rev | sort | uniq -c

(Fitoschido: the point of filing this bug report is to *separate out issues*. Daniel's spent a good deal of time, and several rounds of iteration. At the time, an icon that was closer to the design specification was available, and so got used).

Jeremy Bicha (jbicha) wrote :

I think it's actually transparent, not black.

$ dpkg -l ubuntu-mono
Desired=Unknown/Install/Remove/Purge/Hold
| Status=Not/Inst/Conf-files/Unpacked/halF-conf/Half-inst/trig-aWait/Trig-pend
|/ Err?=(none)/Reinst-required (Status,Err: uppercase=bad)
||/ Name Version Description
+++-==============-==============-============================================
ii ubuntu-mono 0.0.36 Ubuntu Mono Icon theme

$ dpkg -L ubuntu-mono | grep desktop | rev | cut -d/ -f1 | rev | sort | uniq -c
     14 desktop.png
      3 preferences-desktop-accessibility.svg
      2 preferences-desktop-keyboard.svg
      2 preferences-desktop-locale.svg
     14 user-desktop.png

Jeremy Bicha (jbicha) wrote :

I have this bug on both computers I use; it persists through reboots and is fixed by reverting to .34

Adolfo Jayme (fitojb) on 2011-09-29
summary: - user-desktop icon shows black desktop instead of Unity's wallpaper
+ user-desktop icon shows transparent desktop instead of Unity's wallpaper
Paul Sladen (sladen) wrote :

It's a mismatch between the buildd, and doing a local build. I've managed to reproduce it using with a pbuild-buildd setup locally.

The background texture (from ubuntu-wallpapers) is not being picked up when rendering to PNGs.

Changed in ubuntu-mono (Ubuntu):
assignee: nobody → Paul Sladen (sladen)
importance: Undecided → High
milestone: none → ubuntu-11.10
Paul Sladen (sladen) on 2011-09-29
Changed in ubuntu-mono (Ubuntu Oneiric):
status: Confirmed → In Progress
Paul Sladen (sladen) wrote :

I thought this might be related to 'warty-final' being a .jpg named as a .png. But having added the code to work around that, it doesn't appear to be the case and there is still a difference between what the buildd environment produces and what gets built locally.

Onto Plan C. Just add the PNGs rasters that *do* get successfully built locally, and copy these in at the end of debian/rules::install.

tags: added: rls-mgr-o-tracking
Paul Sladen (sladen) on 2011-09-29
Changed in ubuntu-mono (Ubuntu Oneiric):
status: In Progress → Fix Committed
Paul Sladen (sladen) wrote :

Setting to New so that it hits Ubuntu Release.

Changed in ubuntu-mono (Ubuntu Oneiric):
status: Fix Committed → New
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubuntu-mono - 0.0.37

---------------
ubuntu-mono (0.0.37) oneiric; urgency=low

  [Paul Sladen]
  * Pre-caching: buildd build fails to pick up underlying raster wallpaper
    from 'ubuntu-wallpapers', leaving the icon empty unless highlighted.
    Work-around by just including the .pngs that *do* get successfully
    build locally and copying these in during debian/rules::install
    (LP: #862040)
 -- Paul Sladen <email address hidden> Thu, 29 Sep 2011 21:08:51 +0100

Changed in ubuntu-mono (Ubuntu Oneiric):
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers