user-desktop and desktop icons slow the desktop a lot

Bug #856475 reported by Sebastien Bacher on 2011-09-22
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
The Ubuntu Boot Speed Project
Undecided
Unassigned
ubuntu-mono
New
Undecided
Unassigned
ubuntu-mono (Ubuntu)
High
Paul Sladen
Oneiric
High
Paul Sladen

Bug Description

Those icons are svg which have a reference to the background image, it leads nautilus to read the image for each variant of this icon it leads on session start and induce a several seconds delay to the desktop start

Sebastien Bacher (seb128) wrote :

nautilus seems to load the background image 9 times on start (it's probably doing it for each variant) and it creates over 3 seconds of cpu pick for nautilus on an atom cpu

Changed in ubuntu-mono (Ubuntu):
importance: Undecided → High
Changed in ubuntu-mono (Ubuntu Oneiric):
assignee: nobody → Paul Sladen (sladen)
milestone: none → ubuntu-11.10-beta-2
Martin Pitt (pitti) on 2011-09-22
Changed in ubuntu-mono (Ubuntu Oneiric):
milestone: ubuntu-11.10-beta-2 → ubuntu-11.10
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubuntu-mono - 0.0.35

---------------
ubuntu-mono (0.0.35) oneiric; urgency=low

  [Paul Sladen]
  * Replace/provide 'input-keyboard' (LP: #827426)
  * Pre-cache 'user-desktop' to PNGs for speed (LP: #856475)
 -- Paul Sladen <email address hidden> Wed, 28 Sep 2011 02:32:49 +0100

Changed in ubuntu-mono (Ubuntu Oneiric):
status: New → Fix Released
Martin Pitt (pitti) on 2011-09-28
Changed in ubuntu-boot-speed:
status: New → Fix Released
Jeremy Bicha (jbicha) wrote :

This doesn't work. ubuntu-mono 0.0.36 shows just black for the desktop background part of the user-desktop icon (as seen in Nautilus or in the Alt-Tab switcher). Reverting to 0.0.34 fixes this.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers