Indicators: no printing icon

Bug #840151 reported by Paul Sladen on 2011-09-03
44
This bug affects 7 people
Affects Status Importance Assigned to Milestone
ubuntu-mono (Ubuntu)
Undecided
Daniel Planas Armangue

Bug Description

When printing, a printing icon appears appears in the top bar. This icon does not match the rest of the indicators, and so needs drawing.

The icon presently used appears to be a dimmed version of:

  /usr/share/icons/Humanity/devices/24/printer.svg

<https://wiki.ubuntu.com/Printing#menu>: "When you have jobs printing on any printer, the title of the menu should be a slowly animated printer icon. Otherwise, the title should be a static printer icon with a clock emblem when printing is queued; or a static printer icon with a green checkmark emblem when printing is finished."

Related branches

Paul Sladen (sladen) wrote :

Needs Daniel/Rosie to draw one in 22-pixel size if it's going to stick around.

I create printer icons missing, for radiance and ambiance, for fix this bug, only copy de files on your usr/share/icons/
hope you like.

a little preview

icons pack

Changed in ubuntu-mono (Ubuntu):
assignee: nobody → Daniel Planas Armangue (daniplanas.a)

I create a 2nd version,

- paper is thiner
-text is in the bottom part of paper, (text apears after print :)

hope you like

printer icons version 2 proposal

Changed in ubuntu-mono (Ubuntu):
status: New → Confirmed
Changed in ayatana-design:
status: New → Confirmed
Changed in ubuntu-mono (Ubuntu):
status: Confirmed → In Progress
Changed in ayatana-design:
status: Confirmed → In Progress

not only is this the bug i am currently refferring to but the icon displays under the old system tray "whitelist" argument instead of being a full fledged indicator

John Lea (johnlea) on 2011-10-18
Changed in ayatana-design:
status: In Progress → New

The attachment "printer icons.tar" of this bug report has been identified as being a patch. The ubuntu-reviewers team has been subscribed to the bug report so that they can review the patch. In the event that this is in fact not a patch you can resolve this situation by removing the tag 'patch' from the bug report and editing the attachment so that it is not flagged as a patch. Additionally, if you are member of the ubuntu-sponsors please also unsubscribe the team from this bug report.

[This is an automated message performed by a Launchpad user owned by Brian Murray. Please contact him regarding any issues with the action taken in this bug report.]

tags: added: patch
Dmitry Shachnev (mitya57) wrote :

@Nathanel: See bug 588200 for that (it's waiting for design team decision).

I left Ubuntu 7 months ago... The design team is too slow for such minor
fixes.

On Thu, Dec 29, 2011 at 2:47 AM, Dmitry Shachnev <email address hidden> wrote:

> @Nathanel: See bug 588200 for that (it's waiting for design team
> decision).
>
> --
> You received this bug notification because you are subscribed to a
> duplicate bug report (552927).
> https://bugs.launchpad.net/bugs/840151
>
> Title:
> Indicators: no printing icon
>
> Status in Ayatana Design:
> New
> Status in “ubuntu-mono” package in Ubuntu:
> In Progress
>
> Bug description:
> When printing, a printing icon appears appears in the top bar. This
> icon does not match the rest of the indicators, and so needs drawing.
>
> The icon presently used appears to be a dimmed version of:
>
> /usr/share/icons/Humanity/devices/24/printer.svg
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/ayatana-design/+bug/840151/+subscriptions
>

--
*TND*esigns | Graphic & Industrial Design Solutions Inc.

Étudiant finissant EDIN 2012 | Université de Montréal

Senior student INDS 2012 | University of Montreal

<email address hidden>

514 . 583 . 7386

no longer affects: ayatana-design
description: updated
Paul Sladen (sladen) wrote :

Daniplanas: I'm happy to merge them (Lars is ready with 'indicator-printer' too and has requested). Please could you sign the Copyright Licence Agreement:

  http://www.canonical.com/contributors

so that we have permission is distribute under the same terms as the rest of the existing of Ubuntu Mono icon set.

Paul Sladen (sladen) wrote :

Update: I've had two replies from Dani confirming that the icons can be used, but I'm still waiting on a signed contributor licence agreement in order to be able to merge them under the same CC-BY-SA licence as the rest of the icon set.

Benjamin (nailartcenter) on 2012-02-24
Changed in ubuntu-mono (Ubuntu):
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers