UIFe: ⌨ Use DejaVu Sans U+2328 KEYBOARD for indicator-keyboard

Bug #827426 reported by Paul Sladen
36
This bug affects 6 people
Affects Status Importance Assigned to Milestone
Ayatana Design
High
Paul Sladen
ubuntu-mono (Ubuntu)
Undecided
Paul Sladen

Bug Description

Mark Shuttleworth noticed that the indicator-keyboard menu icon is quite noisy and doesn't fit with the rest of the Ubuntu Monochrome symbolic icon theme. The current icon appears to be:

  /usr/share/icons/Humanity/devices/24/input-keyboard.svg (rescaled to 22px)

Ideally this could be replaced by something (very) similar to: DejaVu Sans U+2328 KEYBOARD ("⌨") or perhaps:

  /usr/share/icons/HighContrastLargePrintInverse/48x48/devices/input-keyboard.png

Note that this is a stop-gap indicator-solution. In the long-run, the 'indicator-keyboard' specification uses a series icons representing the /currently active layout/, rather than a generic "keyboard" icon:

  https://wiki.ubuntu.com/KeyboardSettings#Use_cases

See also (semi-related):

  bug #620331 ("Keyboard menu title needlessly has both icon and label")

Paul Sladen (sladen)
Changed in ubuntu-mono (Ubuntu):
milestone: none → ubuntu-11.10
Revision history for this message
Paul Sladen (sladen) wrote :

Otto will look at this, and push it to Daniel if required.

Changed in ubuntu-mono (Ubuntu):
assignee: nobody → Otto Greenslade (otto-chaotic)
Revision history for this message
Ted Gould (ted) wrote :

Another screenshot showing the icon that is wrong

Paul Sladen (sladen)
Changed in ayatana-design:
importance: Undecided → High
assignee: nobody → Xi Zhu (xi.zhu)
Changed in ubuntu-mono (Ubuntu):
assignee: Otto Greenslade (otto-chaotic) → Paul Sladen (sladen)
Changed in ayatana-design:
status: New → Triaged
Revision history for this message
Paul Sladen (sladen) wrote :

Rosie/Otto: can you come up with some ideas for this, probably fairly close to the DejaVu Sans glyph that Mark has mentioned.

Here's a bi-level rendering of it at about the size we need. Possibly you could save a couple of pixels and drop one row of keys.

Paul Sladen (sladen)
description: updated
Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in ubuntu-mono (Ubuntu):
status: New → Confirmed
Paul Sladen (sladen)
description: updated
Revision history for this message
Xi Zhu (xi.zhu) wrote :

keyboard icon mono light

Revision history for this message
Xi Zhu (xi.zhu) wrote :

keyboard icon mono dark

Revision history for this message
Xi Zhu (xi.zhu) wrote :

keyboard icon for the dash, it needs a 6px, 20% opacity of 100% to 0% #ffffff outer glow

Revision history for this message
Paul Sladen (sladen) wrote :

Is the attached concept any use? It's got a little less detail, but still retains the large spacebar and enter keys to get some overall weight balance, so attempting to match the omnipresent Mail and Battery icons—currently none of the other icons feature 1x1 pixel dots.

In the PDF, there is a pixel-aligned vector on top, and a raster output of the result below, although it may prove hard to view at 1:1 into a PDF viewer.

Revision history for this message
pablomme (pablomme) wrote :

What would be the problem with going straight to the "in the long run" solution? There's an icon set here https://bugs.launchpad.net/ayatana-ubuntu/+bug/628015/comments/9 where each icon is a key-shaped background with the ISO code letters from the layout. This can be used with the current oneiric as explained in the above link, and works just fine. This icon set should ideally be changed in two ways:
- Adjust colour to current oneiric theme
- Make letters transparent so that the icon does not become entirely white when the unity dash opens
Surely the process of generating the icons can be automated to do all 246 of them for both ambiance and radiance in no time.

I suppose that this problem (i.e. bug #620331, bug #628015) hasn't been addressed because there are additional requirements (distinguish multiple layouts per ISO code? identify input method?) that make the ISO code icons a stop-gap solution... but they are nonetheless closer to the design than the stop-gap solution proposed here of only adjusting the keyboard icon to the theme.

Revision history for this message
Dmitry Shachnev (mitya57) wrote :

Will this fix bug 853184 ("Keyboard indicator displayed incorrectly in Dash mode") too?

Revision history for this message
Paul Sladen (sladen) wrote :

pablomme: we're a long way past Feature Freeze and User Interface Freeze. Replacing a keyboard with a keyboard doesn't really affect documentation at this stage, but reprogramming the operation of the keyboard indicator at this stage is quite a large amount of code to be changing at T-3 weeks to release.

Dmitry: maybe. bug #853184 looks like a transparency issue. I hadn't seen it with the keyboard icon before, but I can see it with indicator-weather (a white-on-orange icon that goes to pure white).

Revision history for this message
Paul Sladen (sladen) wrote :

Status update: Rosie and Otto are going to work on a keyboard icon that's a tided up version of the simpler icon in comment #8, and we'll try to ship that when ready.

Revision history for this message
pablomme (pablomme) wrote :

@Paul: I understand your argument about UI freeze and documentation, but regarding the amount of coding needed, it is zero; there already exists a gsettings key that toggles the behaviour I've described (which I've been using for 3 releases now): org.gnome.libgnomekbd.indicator.show-flags.

Bug #853184 comes about due to the fix to bug #828862, by which no polychromatic icons will display correctly in dash mode - but transparencies are still correctly represented. Changing the keyboard icon to any of the variants proposed here, whether icon or Unicode character, or using the show-flags feature with icons satisfying the requirements I described in comment #9, will not encounter this problem.

Revision history for this message
pablomme (pablomme) wrote :

Instead of just describing what the new icons should look like, I've modified the ones I linked to in comment #9 to match oneiric's theme and add transparency. Attached. To try them, untar the archive in ~/.icons and run

dconf write /org/gnome/libgnomekbd/indicator/show-flags true

I will also attach the script and data I used to generate these flags and a screenshot of what this looks like in oneiric, both in normal mode and when the dash is open.

Revision history for this message
pablomme (pablomme) wrote :
Revision history for this message
pablomme (pablomme) wrote :
Revision history for this message
Paul Sladen (sladen) wrote :

pablomme: beautiful. Hopefully they can be landed in about three weeks time (as soon as P opens, if not before).

Revision history for this message
Paul Sladen (sladen) wrote :

Upload (proposed) replaces one 22px keyboard icon with another, simpler, 22px keyboard icon; neither of which are displayed in the default desktop views (one must enable iBus, or enable multiple keyboard layouts first).

Textual documentation such as "click the keyboard icon" should remain unaffected. If there are screenshots covering the keyboard menus/iBus then these could be updated. The attached side-by-side comparison hopefully shows the level of impact.

summary: - Request: ⌨ Use DejaVu Sans U+2328 KEYBOARD for indicator-keyboard
+ UIFe: ⌨ Use DejaVu Sans U+2328 KEYBOARD for indicator-keyboard
Changed in ubuntu-mono (Ubuntu):
status: Confirmed → Fix Committed
Changed in ayatana-design:
status: Triaged → Fix Released
assignee: Xi Zhu (xi.zhu) → Paul Sladen (sladen)
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubuntu-mono - 0.0.35

---------------
ubuntu-mono (0.0.35) oneiric; urgency=low

  [Paul Sladen]
  * Replace/provide 'input-keyboard' (LP: #827426)
  * Pre-cache 'user-desktop' to PNGs for speed (LP: #856475)
 -- Paul Sladen <email address hidden> Wed, 28 Sep 2011 02:32:49 +0100

Changed in ubuntu-mono (Ubuntu):
status: Fix Committed → Fix Released
Revision history for this message
Alkis Georgopoulos (alkisg) wrote : Re: [Bug 827426] Re: Request:⌨Use DejaVu Sans U+2328 KEYBOARD for indicator-keyboard

Στις 28-09-2011, ημέρα Τετ, και ώρα 04:44 +0000, ο/η Paul Sladen έγραψε:
> Upload (proposed) replaces one 22px keyboard icon with another,
> simpler, 22px keyboard icon; neither of which are displayed in the
> default desktop views (one must enable iBus, or enable multiple
> keyboard layouts first).

When I select Greek locale in Ubiquity, I do get the keyboard icon in my
default desktop view.

And IMHO that new keyboard icon which wasn't there on previous versions
is just consuming vital panel space which is where applications main
menus are displayed. I don't need the icon to realize that [En]/[El] is
where I have to click to switch keyboard layouts.

Gnome classic had two panels and never used such an icon; Unity has only
one (overloaded) panel. Please don't waste the space. I think it would
be much better if the keyboard icon was completely removed.

Revision history for this message
Paul Sladen (sladen) wrote :

Alkis: In the top of the bug, the ultimate plan is linked, which I think is rougly what you're after:

  https://wiki.ubuntu.com/KeyboardSettings#Use_cases

However, we're 30 hours from hard freeze so right now the priority is to make *what we have* look better: all that this has done is to replace any existing keyboard icons that were there with a keyboard icon of roughly the same size but larger buttons and more in keeping with the rest of the Ubuntu Mono top bar icon theme.

As pablomme notes in comment #14. The behaviour of having a single [El]/[En] indicator can be *tested* with:

  dconf write /org/gnome/libgnomekbd/indicator/show-flags true

Revision history for this message
Jeremy Bicha (jbicha) wrote :

The recent ubuntu-mono update caused a regression in the keyboard icon used in System Settings: bug 862027

Revision history for this message
Alkis Georgopoulos (alkisg) wrote : Re: [Bug 827426] Re: UIFe:⌨Use DejaVu Sans U+2328 KEYBOARD for indicator-keyboard

It's too late in the release cycle to change anything, but I'm
mentioning this in case this problem persists to Precise too.

1. Up to Natty we had: [Text]
2. In Oneiric we have: [kbd icon] [Text]
3. Precise might have: [flag icon]

What I'm saying is that there was no point to introduce the space -
consuming [2] just for Oneiric. It wasn't there before; it won't be
there in the future.
We could keep [1], and switch to [3] when it's ready.

Support for displaying flag icons has been there for years,
but no flags are shipped.
So if [3] isn't planned for Precise, please revert back to [1].

Revision history for this message
Marco Trevisan (Treviño) (3v1n0) wrote :

@jbicha yes, and also in ccsm. I guess that we should have only changed the icon for the g-s-d keyboard indicator and not changing the icon for the rest!

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Related blueprints