icon for weather-clear (day only) is missing

Bug #748861 reported by Felix Lawrence on 2011-04-03
318
This bug affects 60 people
Affects Status Importance Assigned to Milestone
ubuntu-mono (Ubuntu)
Medium
Unassigned
Oneiric
Low
Unassigned
Precise
Low
Unassigned

Bug Description

Binary package hint: ubuntu-mono

ubuntu-mono-dark and ubuntu-mono-light both have lots of icons for weather conditions. Although there are many weather-clear-night icons, there is no weather-clear icon for daytime.

So when it's sunny, the gnome clock applet and indicator-weather display icons from gnome-hicolor. Could the set please be completed with this one last icon?

== Regression details ==
Discovered in version: Natty (ubuntu-mono 0.0.30)
Last known good version: Maverick (ubuntu-mono: probably 0.0.22?)

Related branches

Changed in ubuntu-mono (Ubuntu):
status: New → Confirmed
Oliver Horn (oliverhorn) on 2011-04-28
tags: added: clear indicator natty sun sunshine weather
tags: removed: clear indicator natty sun sunshine weather
Christoph Buchner (bilderbuchi) wrote :

I just made an icon (light and dark), based on weather-few-clouds.svg (see attachment). Please feel free to add them to the rest.

Christoph Buchner (bilderbuchi) wrote :

and the second one

Changed in ubuntu-mono (Ubuntu):
status: Confirmed → In Progress
Cullen Maglothin (cullendm) wrote :

I found these in the default Ubuntu setup. Are they not right?

Cullen Maglothin (cullendm) wrote :

Here is the other.

Felix Lawrence (felix-lawrence) wrote :

Cullen: where were they?! On all installs I've seen, /usr/share/icons/ubuntu-mono-dark/status/16/ contains all the weather icons but is missing weather-clear.svg . Some machines fall back to the Humanity icons, but most I've seen fall back to the gnome icons.

Christoph Buchner (bilderbuchi) wrote :

I can confirm Felix' observation - they're not there on my systems, either... (although it was puzzling to me why someone would make an icon set and leave out a clear-day icon)

Cullen Maglothin (cullendm) wrote :

They were right in the folder you specified. There are actually three different ones. weather-clear.svg, sunny.svg, and something like stock-weather-clear.svg

Panagiotis Skintzos (ph7) wrote :

Cullen, have you installed any external theme or icon package?
These names do not exist in the source of ubuntu-mono (0.0.30)

Jacopo Moronato (jmoronat) wrote :

weather-clear icons are missing in ubuntu-mono package in Natty. However, I can find them in Maverick package.

Panagiotis Skintzos (ph7) wrote :

Christoph, your icons look very nice, thanks!

Cullen Maglothin (cullendm) wrote :

Ahh! I see what happened. I am running a very early alpha of Ubuntu and that is why I still have it. I have been using my Cr-48 as my main computer so my Ubuntu install has remained quite out of date. Those icons I uploaded where the official ones from 10.10 I guess. Is there an actual reason for the loss of those icons between spins?

description: updated
tags: added: regression-update
description: updated
tags: added: natty

I have identified the revision where the icons were removed:
http://bazaar.launchpad.net/~ubuntu-branches/ubuntu/natty/ubuntu-mono/natty/revision/20

Changed in ubuntu-mono (Ubuntu):
status: In Progress → Confirmed

So what's the proper procedure now? This bug has identified a regression, easily fixed as far as i can see - reintroduce the icons if nothing speaks against that. I have subscribed the authors of the regressing revision for now, hope that's correct.

Daniel Fore (danrabbit) wrote :

These icons were intentionally removed from the ubuntu mono set. They don't appear in Unity and including them causes problems with other applications because of improper naming.

if they are to be re-implemented, they should use the -symbolic namespace to ensure they don't show up in improper locations. Either way, this is a problem with a non-default setup and I would encourage third party application developers to ship those icons with their application rather then re-add them to ubuntu-mono.

This problem also affects the GNOME clock applet, which is installed by default in Ubuntu 11.04.

Two questions for context - so we don't cause problems with other apps:
1) What problems did weather-clear.svg cause, that the other weather-* icons didn't?
2) If Ubuntu does not ship the full set of weather icons used by the GNOME clock applet, why do they ship any weather icons at all? Are they shipped for some other weather program that never shows the sun?

Daniel Fore (danrabbit) wrote :

The icon set shouldn't contain any of those items. It's my understanding that some people have those icons as a remnant of an upgrade. The main problem is that those icons are only supplied in panel sizes and any application attempting to use them anywhere else in the interface ends up with stretched monochrome icons instead of the full color ones as intended.

As I said, they shouldn't be shipped at all. If you branch lp:ubuntu-mono you won't find those icons.

> If you branch lp:ubuntu-mono you won't find those icons.
I just did a checkout of the tip of lp:ubuntu-mono, and all weather icons (except weather-clear.svg) are still present: ubuntu-mono-*/status/16/weather-*.svg .
Furthermore, there are also duplicates present: ubuntu-mono-*/status/16/stock_weather-*.svg

> any application attempting to use them anywhere else in the interface ends up with stretched monochrome icons

I didn't think that status/16/ icons were treated as scalable by the system?

If we ship our own set of icons and install them into ubuntu-mono-*, do we avoid overriding hicolor at large sizes by placing the mono icons in ubuntu-mono-*/apps/16/ ?

Or in the meantime, before the other weather icons are removed (presumably in Oneiric), could we get weather-clear.svg re-installed by an Ubuntu update? This would help both users of weather-indicator and users of the default-installed GNOME clock applet.

On my clean-install 11.04 system, the icons (except for weather-clear) are also there, just as Felix observes.

Panagiotis Skintzos (ph7) wrote :

>
> The icon set shouldn't contain any of those items.

It take it that by "those items" you mean all weather icons?

> As I said, they shouldn't be shipped at all. If you branch lp:ubuntu-
> mono you won't find those icons.
>
Here's the contradiction. I take it that by "those icons" you mean the
weather-clear ones?
Because all the other weather icons exist in the branch.

It's my understanding
> that some people have those icons as a remnant of an upgrade. The main
> problem is that those icons are only supplied in panel sizes and any
> application attempting to use them anywhere else in the interface ends
> up with stretched monochrome icons instead of the full color ones as
> intended.
>
I don't get it. What is the special thing about the weather (or
weather-clear) icons?
Isn't your statement above valid for all mono icons?

The point is, that ubuntu-mono has an incomplete set of weather icons, yes?
If it should not contain any weather icon, ok, we'll ship them in a separate
package.
But including some and excluding others does not make sense.

So could anyone knowledgeable comment about why this (incomplete set of weather icons) is the current status, and what the proper way to move forward is? Daniel?

We need it fixed in oneiric

I agree (especially since it's easy). Daniel, do you have any input on this, since it was shown that your assertion in comment #16 that the icons are not in the lp branch is wrong?

Sheldon Taylor (sheldont22) wrote :

Oneiric has the same issue everyone has described, and it's damn ugly. ubuntu-mono seems to be the only set that doesn't have their own sunny icon. Makes no sense. This seems like a simple fix.

I copied the weather-clear.svg and stock_weather-sunny.svg from Humanity-Dark to ubuntu-mono-dark in root, but that hasn't seemed to work.

Does anyone know where the orange sun icon is located? Could that .svg just be replaced with a monochrome sun image?

you can get it over strace ;)

so you can't probably :/

I get it! :-D
I just replace the icon and it works.
The icon to replace is in /usr/share/Humanity-Dark/status/48

Changed in ubuntu-mono (Ubuntu):
status: Confirmed → Fix Committed
Pavlo Verba (pavlo.s.verba) wrote :

When this fix is going to be released to the public and shipped via updates? It is almost 2012 and still can be noticed in Oneiric.

By the way, those of us who simply cannot wait to see clean monochrome panel can use dirty fix described here: http://askubuntu.com/questions/67837/why-is-there-no-clear-day-weather-icon-in-the-ubuntu-mono-icons-set

felgutico, what is the reason you set this bug to Fix Committed? Have you actually fixed this bug and committed the changes to ubuntu-mono? I suspect not, so I set back to confirmed. If I'm mistaken, please correct.

Changed in ubuntu-mono (Ubuntu):
status: Fix Committed → Confirmed
tags: added: bitesize
Ted Gould (ted) on 2012-01-21
Changed in ubuntu-mono (Ubuntu):
assignee: nobody → Paul Sladen (sladen)
Changed in ubuntu-mono (Ubuntu Precise):
importance: Undecided → Medium
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in ubuntu-mono (Ubuntu Oneiric):
status: New → Confirmed

So, what is needed here? I already attached ready-made icons in #1 and #2 nearly a year ago, you should only have to drop them into the corect folder here, right? Paul (the assigned)?

Rainer Rohde (rainer-rohde) wrote :

As unbelievable as this sounds, this issue still persists in the current Quantal (12.10!) Alpha 2 release.... So, when exactly will this be addressed?

tags: added: quantal
bwat47 (bwat47) wrote :

Yeah, same issue in precise and quantal, will this ever be fixed?

Matthew Paul Thomas (mpt) wrote :

The bug will be fixed when someone packages a fix for it. The icon theme is currently unmaintained, but but anyone is welcome to submit a package fix that the Desktop team could upload.

Changed in ubuntu-mono (Ubuntu):
assignee: Paul Sladen (sladen) → nobody
Changed in ubuntu-mono (Ubuntu Precise):
assignee: Paul Sladen (sladen) → nobody

Hi, I've tried to submit a package fix. If I did something incorrect, please let me know how to fix it!

Rainer Rohde (rainer-rohde) wrote :

That's going on for years, and years it seems.... Considering the overall quality of Ubuntu, this is so out of character... :)

Pavlo Verba (pavlo.s.verba) wrote :

You have got to be freaking kidding me — with all due respect, but you guys are deciding on how to fix this for a year and a half now. And a fix was made available at the askubuntu.com [1] almost a year ago! Are we going to have to manually re-apply this fix after every major update now?

Please, see the link below, the given version of the icon is surely better than no mono icon at all.

[1] http://askubuntu.com/questions/67837/why-is-there-no-clear-day-weather-icon-in-the-ubuntu-mono-icons-set

Sebastien Bacher (seb128) wrote :

Thanks for the work, I'm going to upload those icons to raring, we can backport to precise later if the feedback is good. Closing the oneiric part, we will not backport to old non LTS releases

Changed in ubuntu-mono (Ubuntu Oneiric):
status: Confirmed → Won't Fix
Changed in ubuntu-mono (Ubuntu Precise):
importance: Medium → Low
Changed in ubuntu-mono (Ubuntu Oneiric):
importance: Undecided → Low
Changed in ubuntu-mono (Ubuntu):
status: Confirmed → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubuntu-mono - 0.0.50

---------------
ubuntu-mono (0.0.50) raring; urgency=low

  * Add missing weather icons for sunny days (LP: #748861)
 -- Felix Lawrence <email address hidden> Tue, 27 Nov 2012 16:01:00 +0100

Changed in ubuntu-mono (Ubuntu):
status: Fix Committed → Fix Released
Rainer Rohde (rainer-rohde) wrote :

Perfect. Thank you. I just stepped up to 13.04 and this fix is a nice, albeit long overdue, surprise. Looks nice.

todaioan (alan-ar06) on 2012-12-23
Changed in ubuntu-mono (Ubuntu Precise):
status: Confirmed → Fix Committed
HansBKK (hansbkk) wrote :

I'm still seeing this in my full-updated 12.04 (actually elementary "Luna" but seen as Precise to the PPAs)

I've worked around this by moving all the weather-* icons to the /usr/share/icons/gnome tree, and renaming the weather.* icons I come across in different icon theme sets.

If I've done something wrong let me know, hard to believe the promised backport hasn't happened two years later on an LTS issue.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers