Battery level should deplete to the right

Bug #546477 reported by Mark Shuttleworth on 2010-03-24
26
This bug affects 2 people
Affects Status Importance Assigned to Milestone
notify-osd-icons (Ubuntu)
Medium
Daniel Fore
ubuntu-mono (Ubuntu)
Medium
Daniel Fore

Bug Description

Binary package hint: ubuntu-mono

The low-battery indicator currently puts the last juice on the left of the battery. It should be on the right.

John King (solar95king) on 2010-03-25
Changed in ubuntu-mono (Ubuntu):
status: New → Confirmed
Changed in ubuntu-mono (Ubuntu):
status: Confirmed → Triaged
importance: Undecided → Wishlist
John King (solar95king) wrote :

Based on practical use, this would be a good change to make.

tags: added: lucid usability
Vish (vish) wrote :

This bug has been fixed in ubuntu-mono (0.0.12)

Changed in ubuntu-mono (Ubuntu):
status: Triaged → Fix Released

This was a bad call on my part. Apologies, but please revert. The
"positive" terminal (the bump) should be on the right, but the "last
juice" should be on the left.

Mark

Charlie Kravetz (charlie-tca) wrote :

Setting back to triaged, since we now need to revert the change.

Changed in ubuntu-mono (Ubuntu):
status: Fix Released → Triaged
Daniel Fore (danrabbit) on 2010-04-07
Changed in ubuntu-mono (Ubuntu):
assignee: nobody → Daniel Fore (daniel-p-fore)
Vish (vish) on 2010-04-07
Changed in ubuntu-mono (Ubuntu):
status: Triaged → In Progress
Kenneth Wimer (kwwii) on 2010-04-07
Changed in ubuntu-mono (Ubuntu):
importance: Wishlist → Medium
Kenneth Wimer (kwwii) wrote :

This will be reverted in the next update to the ubuntu-mono theme bundled with other bug fixes

Kenneth Wimer (kwwii) on 2010-04-07
Changed in notify-osd-icons (Ubuntu):
status: New → In Progress
importance: Undecided → Medium
assignee: nobody → Daniel Fore (daniel-p-fore)
Kenneth Wimer (kwwii) wrote :

As well as the need changes to the notify-osd icons

Daniel Fore (danrabbit) on 2010-04-08
Changed in notify-osd-icons (Ubuntu):
status: In Progress → Fix Committed
Changed in ubuntu-mono (Ubuntu):
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubuntu-mono - 0.0.16

---------------
ubuntu-mono (0.0.16) lucid; urgency=low

  * Battery icons to fix LP: #546477
  * Correcting naming bug in light variant
  * Adding properly sized wifi icons so correct apparent panel spacing bug
  * Fixing naming error in light variant for restart icon
  * Adding running app indicator to light theme
 -- Kenneth Wimer <email address hidden> Mon, 12 Apr 2010 16:24:39 +0100

Changed in ubuntu-mono (Ubuntu):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package notify-osd-icons - 0.6

---------------
notify-osd-icons (0.6) lucid; urgency=low

  * Battery icons to fix LP: #546477
  * Wifi icons to match the versions used in the panel (updated to fix a bug in the panel spacing)
 -- Kenneth Wimer <email address hidden> Mon, 12 Apr 2010 16:32:59 +0100

Changed in notify-osd-icons (Ubuntu):
status: Fix Committed → Fix Released
Conscious User (conscioususer) wrote :

Mark, could you explain the reason for the reversion? In Bug #549620, Martin Meredith made some good points in the description which I feel will be coming back with this reversion.

Mark Shuttleworth (sabdfl) wrote :

My initial feeling was that it should deplete to the right. We had a
fairly heated discussion about it amongst the design team, and I
eventually decided it should deplete to the right.

After that was uploaded, however, it looked wrong. All of the other
items on the menu "read from left to right". And so I figure it was a
bad call and asked for it to be reverted.

Reading Martin's comments, I think that folks will ultimately be
prejudiced one way or the other based on the way their phone or other
favorite gadget handles this. We did a quick review and found that there
isn't much consistency between vendors. So we're going to be right for
some, wrong for others.

Therefor, let's ground the decision on the basis that we expect the eye
to scan left to right. Items that show an increase (in battery, volume,
signal strength) should show that either vertically, or from left to right.

Mark

Vish (vish) wrote :

IMO, Martin Meredith isnt right here. In the phones the battery is usually the right most icon. Obviously the base is towards to edge. While in the panel the gpm icon isnt in the right corner.
Or if it is in the left corner the base is to the left , The base always depends position of the icon.

Conscious User (conscioususer) wrote :

After realizing that the volume indicator and the wireless bars have always depleted to the left, I now tend to agree with the reversion.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers