[SRU] Fix size of input-keyboard.svg to prevent IBus indicator from random blinking in GNOME Shell

Bug #1034872 reported by Bangsheng Tang on 2012-08-09
26
This bug affects 3 people
Affects Status Importance Assigned to Milestone
ubuntu-mono (Ubuntu)
Undecided
Unassigned

Bug Description

In Ubuntu 12.04 with Gnome Shell.

ibus is one of the most popular input method frameworks used in CJK environments. while switching from CJK inputing to English, the icon in the status area blinks a few times(enlarging, shrinking, etc.)

This is caused by a flawed icon file, /usr/share/icons/ubuntu-mono-dark/status/22/input-keyboard.svg

the one shipped with Ubuntu 12.04 has the problem that the size is 22x23, after modifying it to 22x22, the problem gets solved. I have attached my modified version of input-keyboard.svg

Thank you for taking the time to report this bug and helping to make Ubuntu better. It seems that your bug report is not filed about a specific source package though, rather it is just filed against Ubuntu in general. It is important that bug reports be filed about source packages so that people interested in the package can find the bugs about it. You can find some hints about determining what package your bug might be about at https://wiki.ubuntu.com/Bugs/FindRightPackage. You might also ask for help in the #ubuntu-bugs irc channel on Freenode.

To change the source package that this bug is filed about visit https://bugs.launchpad.net/ubuntu/+bug/1034872/+editstatus and add the package name in the text box next to the word Package.

[This is an automated message. I apologize if it reached you inappropriately; please just reply to this message indicating so.]

tags: added: bot-comment
description: updated
affects: ubuntu → ubuntu-mono (Ubuntu)

The attachment "my modified icon" of this bug report has been identified as being a patch. The ubuntu-reviewers team has been subscribed to the bug report so that they can review the patch. In the event that this is in fact not a patch you can resolve this situation by removing the tag 'patch' from the bug report and editing the attachment so that it is not flagged as a patch. Additionally, if you are member of the ubuntu-reviewers team please also unsubscribe the team from this bug report.

[This is an automated message performed by a Launchpad user owned by Brian Murray. Please contact him regarding any issues with the action taken in this bug report.]

tags: added: patch

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in ubuntu-mono (Ubuntu):
status: New → Confirmed
Ma Hsiao-chun (mahsiaochun) wrote :

Hi, I can confirm what the reporter said.
Exactly same here.

Same issue applies to "ubuntu-mono-light" icon theme, see the attachment for a modified icon.

tags: added: precise
summary: - ibus icon blinks in status bar as switching among different input
- methods
+ [SRU] Fix size of input-keyboard.svg to prevent IBus indicator from
+ random blinking in GNOME Shell
Dmitry Shachnev (mitya57) wrote :

Is the issue fixed in Saucy? If no, that needs to be done first. Please submit a merge proposal against lp:ubuntu-themes.

Jeremy Bicha (jbicha) wrote :

This has now been fixed in Saucy by removing the input-keyboard icon since it was unneeded and caused an issue in gnome-control-center.

Iain Lane (laney) on 2013-10-10
Changed in ubuntu-mono (Ubuntu):
status: Confirmed → Won't Fix
status: Won't Fix → Fix Released
Ma Hsiao-chun (mahsiaochun) wrote :

Have you fixed it for Ubuntu 12.04?

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers