on livecd xdg-open failed with: /usr/bin/xdg-open: 364: /usr/bin/xdg-open: gnome-open: not found

Bug #893056 reported by Jean-Baptiste Lallement on 2011-11-21
18
This bug affects 6 people
Affects Status Importance Assigned to Milestone
ubuntu-meta (Ubuntu)
High
Martin Pitt
Precise
High
Martin Pitt

Bug Description

Ubuntu Desktop 20111121

TEST CASE
1. Open a terminal and run the following command
$ xdg-open 'http://www.ubuntu.com/'

EXPECTED RESULT
The page 'http://www.ubuntu.com' opens in a browser

WHAT HAPPENS
The command fails with error:
/usr/bin/xdg-open: 364: /usr/bin/xdg-open: gnome-open: not found

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: xdg-utils 1.1.0~rc1-2ubuntu6
ProcVersionSignature: Ubuntu 3.1.0-2.3-generic 3.1.0
Uname: Linux 3.1.0-2-generic x86_64
ApportVersion: 1.26-0ubuntu1
Architecture: amd64
CasperVersion: 1.290
Date: Mon Nov 21 10:51:25 2011
Dependencies:

LiveMediaBuild: Ubuntu 12.04 LTS "Precise Pangolin" - Alpha amd64 (20111121)
PackageArchitecture: all
ProcEnviron:
 PATH=(custom, no user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: xdg-utils
UpgradeStatus: No upgrade log present (probably fresh install)

Changed in xdg-utils (Ubuntu Precise):
importance: Undecided → High
assignee: nobody → Canonical Desktop Team (canonical-desktop-team)
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in xdg-utils (Ubuntu):
status: New → Confirmed
Martin Pitt (pitti) wrote :

We lost gvfs-bin on the daily images.

affects: xdg-utils (Ubuntu Precise) → ubuntu-meta (Ubuntu Precise)
Changed in ubuntu-meta (Ubuntu Precise):
assignee: Canonical Desktop Team (canonical-desktop-team) → Martin Pitt (pitti)
status: Confirmed → In Progress
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubuntu-meta - 1.250

---------------
ubuntu-meta (1.250) precise; urgency=low

  * Refreshed dependencies
  * Added gvfs-bin to desktop (LP: #893056)
 -- Martin Pitt <email address hidden> Wed, 23 Nov 2011 17:17:57 +0100

Changed in ubuntu-meta (Ubuntu Precise):
status: In Progress → Fix Released
Dan Muresan (danmbox) wrote :

Bug #893835 was incorrectly (in my opinion) marked as a duplicate of this. The problem in that case is that ubuntu-bug fails if the system-wide $BROWSER no longer exists. People in that situation cannot report bugs anymore.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers