Add Ubuntu One packages back to default install and CD

Bug #856405 reported by dobey on 2011-09-22
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
ubuntu-meta (Ubuntu)
High
Martin Pitt
Oneiric
High
Martin Pitt

Bug Description

The following packages need to be added back to the default install seed for the ubuntu-desktop CD in order for Ubuntu One to work properly in Oneiric:

banshee-extension-ubuntuonemusicstore
libsyncdaemon-1.0-1
libubuntuone-1.0-1
libubuntuone1.0-cil
python-ubuntuone-client
python-ubuntuone-control-panel
python-ubuntuone-storageprotocol
ubuntuone-client
ubuntuone-client-gnome
ubuntuone-control-panel
ubuntuone-control-panel-gtk
ubuntuone-couch

(ubuntuone-couch does not pull in desktopcouch/couchdb, it is REST API library for talking to server only.)

description: updated
Changed in ubuntu-meta (Ubuntu):
importance: Undecided → High
milestone: none → ubuntu-11.10-beta-2
tags: added: u1-oneiric
Martin Pitt (pitti) wrote :

I made the necessary seed changes to http://bazaar.launchpad.net/~ubuntu-core-dev/ubuntu-seeds/ubuntu.oneiric/revision/1926:

This puts back banshee-extension-ubuntuonemusicstore, ubuntuone-control-panel-gtk, and ubuntuone-client-gnome. (I. e. what we used to have in natty and before).

tags: added: rls-mgr-o-tracking
Martin Pitt (pitti) wrote :

Will wait with u-meta refresh for an official release ack. I feel too biased to decide about this myself as I have been pushing for this myself for quite some time.

The regression potential is low for this. A lot of people (including myself) have these packages installed all the time anyway, and the ubuntuone-installer would install these very packages for you, so we need to have them working either way. Upgraders won't notice a difference, as we had these packages installed in natty and before as well (the seeds changed that in r1915).

Martin Pitt (pitti) on 2011-09-22
Changed in ubuntu-meta (Ubuntu Oneiric):
status: New → Fix Committed
assignee: nobody → Martin Pitt (pitti)
Kate Stewart (kate.stewart) wrote :

Given the regression potential is low, there is precedent already in Natty, there will not need to be any applications dropped from the CD to include these; I am ok with these being added back to the Ubuntu images (CD, DVD, alternate, pre-installed).

Would like it prioritized that we test upgrades extensively once these land, to double check for side effects as soon as possible.

If the change can't be done in next two days, we probably need to reassess though.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubuntu-meta - 1.243

---------------
ubuntu-meta (1.243) oneiric; urgency=low

  * Refreshed dependencies
  * Put back ubuntuone packages (LP: #856405):
    - Added banshee-extension-ubuntuonemusicstore to desktop-recommends
    - Added ubuntuone-client-gnome to desktop-recommends
    - Added ubuntuone-control-panel-gtk to desktop-recommends
    - Removed ubuntuone-installer from desktop-recommends
      (Note: will still be on the image due to reverse recommends of
      deja-dup).
 -- Martin Pitt <email address hidden> Thu, 22 Sep 2011 17:10:01 +0200

Changed in ubuntu-meta (Ubuntu Oneiric):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers