ubuntu-desktop shouldn't depends from gwibber

Bug #846031 reported by balo on 2011-09-09
82
This bug affects 18 people
Affects Status Importance Assigned to Milestone
ubuntu-meta (Ubuntu)
Wishlist
Micah Gersten

Bug Description

In oneiric i can't remove gwibber packages because it wants to remove ubuntu-desktop package too.
ubuntu-desktop package shouldn't depends from gwibber (and gwibber-services).

Changed in ubuntu-meta (Ubuntu):
status: New → Confirmed

seems the last update fixed this issue.
somebody could confirm it?

Alex Popovskiy (alex-popovskiy) wrote :

I cannot confirm that, it still trying to delete ubuntu-desktop. And I can see ubuntu-desktop still have gwibber in its dependency list.

Alistair Buxton (a-j-buxton) wrote :

Same as of today.

As of Oneiric release it is still set to 'depends'.

Matthias Niess (mniess) wrote :

Is there a reason for this? Is this going to be fixed. Many people don't like gwibber, but like having ubuntu-desktop installed.

Alexander Heuer (evilphish) wrote :

Considering this a bug here as well. How can a desktop environment depend on a social network client? Gwibber is one of the first things I delete on every installation because I just don't need it so why should I have it installed?

Micah Gersten (micahg) wrote :

Got confirmation from kenvandine on IRC that there's no reason this can't be a recommends, made the seed change, pending meta upload

Changed in ubuntu-meta (Ubuntu):
assignee: nobody → Micah Gersten (micahg)
importance: Undecided → Wishlist
status: Confirmed → In Progress
Martin Pitt (pitti) on 2012-02-16
Changed in ubuntu-meta (Ubuntu):
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubuntu-meta - 1.260

---------------
ubuntu-meta (1.260) precise; urgency=low

  * Refreshed dependencies
  * Added activity-log-manager-control-center to desktop-recommends
  * Added printer-driver-foo2zjs to desktop-recommends
  * Added printer-driver-min12xxw to desktop-recommends
  * Added printer-driver-pnm2ppa to desktop
  * Added printer-driver-ptouch to desktop-recommends
  * Added printer-driver-pxljr to desktop-recommends
  * Added printer-driver-sag-gdi to desktop-recommends
  * Added printer-driver-splix to desktop-recommends
  * Removed foo2zjs from desktop-recommends
  * Removed min12xxw from desktop-recommends
  * Removed pnm2ppa from desktop
  * Removed ptouch-driver from desktop-recommends
  * Removed pxljr from desktop-recommends
  * Removed rastertosag-gdi from desktop-recommends
  * Removed splix from desktop-recommends
  * Moved gwibber to desktop-recommends (LP: #846031)
 -- Martin Pitt <email address hidden> Thu, 16 Feb 2012 07:28:49 +0100

Changed in ubuntu-meta (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers