at-spi2-core not installed during upgrade from Natty

Bug #828105 reported by Jean-Baptiste Lallement on 2011-08-17
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
ubuntu-meta (Ubuntu)
High
Canonical Desktop Team
Oneiric
High
Canonical Desktop Team

Bug Description

at-spi2-core is not installed during upgrade from Natty to Oneiric, resulting in a non working a11y stack after upgrade.

TEST CASE:
1. Install Natty and applies latest updates
2. Upgrade to Oneiric:
  $ update-manager -cd
3. Reboot
4. Verify that at-spi2-core is installed
  $ dpkg-query -W at-spi2-core

Result:
No package found matching at-spi2-core

Results:

ProblemType: Bug
DistroRelease: Ubuntu 11.10
Package: at-spi2-core (not installed)
ProcVersionSignature: Ubuntu 3.0.0-8.11-generic 3.0.1
Uname: Linux 3.0.0-8-generic i686
Architecture: i386
Date: Wed Aug 17 17:17:08 2011
InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Release i386 (20110427.1)
ProcEnviron:
 LANG=fr_FR.UTF-8
 SHELL=/bin/bash
SourcePackage: at-spi2-core
UpgradeStatus: Upgraded to oneiric on 2011-08-17 (0 days ago)

Jean-Baptiste Lallement (jibel) wrote :

upgrade logs

tags: added: natty2oneiric
Changed in at-spi2-core (Ubuntu Oneiric):
importance: Undecided → High
assignee: nobody → Canonical Desktop Team (canonical-desktop-team)
tags: added: a11y
Martin Pitt (pitti) wrote :

at-spi2-core is already a recommends of ubuntu-desktop, so it ought to be installed during dist-upgrade or with update-manager:

Package: at-spi2-core
Task: ubuntu-desktop, edubuntu-desktop

I can't find any reference to at-spi2-core in the attached upgrade logs, though. Michael, can you see anything in these logs why the new recommends don't get installed during the upgrade?

affects: at-spi2-core (Ubuntu Oneiric) → update-manager (Ubuntu Oneiric)
Martin Pitt (pitti) wrote :

I think a likely reason is that at-spi2-core has a Conflicts: at-spi, and during update it might not want to remove a package to satisfy a new recommends? So I think we actually need a hard dependency in the meta package here.

affects: update-manager (Ubuntu Oneiric) → ubuntu-meta (Ubuntu Oneiric)
Changed in ubuntu-meta (Ubuntu Oneiric):
status: New → Confirmed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubuntu-meta - 1.240

---------------
ubuntu-meta (1.240) oneiric; urgency=low

  * Refreshed dependencies
  * Removed gnome-user-guide from desktop-recommends
  * Moved at-spi2-core to desktop (LP: #828105)
  * Moved libatk-adaptor to desktop
 -- Martin Pitt <email address hidden> Thu, 18 Aug 2011 06:36:35 +0200

Changed in ubuntu-meta (Ubuntu Oneiric):
status: Confirmed → Fix Released
tags: added: testcase
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers