Change default Korean font to ttf-nanum

Bug #792471 reported by Keechang Kim on 2011-06-03
36
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Fontconfig
Fix Released
Wishlist
fontconfig (Ubuntu)
Undecided
Gunnar Hjalmarsson
language-selector (Ubuntu)
Undecided
Unassigned
openjdk-6 (Ubuntu)
Undecided
Unassigned
ubuntu-meta (Ubuntu)
Undecided
Unassigned

Bug Description

This report affects ubuntu-desktop, language-support-fonts-ko and language-selector-common.
Since Sep. 2007, ttf-unfonts-core has been a suggested package of ubuntu-desktop. In a default install, Unfonts are set as the default Korean font.
A superior quality Korean font (ttf-nanum) became available as from late 2010 under OFL. In May 2011, Google ChromeOS adopted ttf-nanum as the default Korean font. After an extensive discussion in the Ubuntu Korean LoCo Mailing list since last year, a consensus has now been reached that it is time to migrate to ttf-nanum as the default Korean font in Ubuntu.
To achieve this, (1) ttf-unfonts-core (7.4Mb package size) must be replaced with ttf-nanum (7.5Mb package size) as the suggested package of ubuntu-desktop (2) language-support-fonts-ko should now include ttf-unfonts-core and ttf-nanum-coding (3) appropriate changes need to be made in some of the configurations files shipped with language-selector-common and fontconfig-config (proposed patches are attached herewith).

Bundo (kang-bundo) wrote :

I am Korean Locoterm owner bundo
I will be very pleased to see them improved

Bundo (kang-bundo) wrote :

I am Korean Locoterm owner bundo
I'll be very pleased if the above points were improved

tags: added: patch
Seowon Jung (jswlinux) wrote :

Default korean fonts on Ubuntu need to be replaced seriously I think. Many Korean font designers and linux related developers have dedicated for applying better korean fonts for linux users, not ms-windows user. So, now all the time and effort they put into developing the font-work there is finally paying off.
I believe that Korean language is not a minor language, and these fonts will be so much helpful for korean ubuntu and other distros linux users in this universe.

Gunnar Hjalmarsson (gunnarhj) wrote :

Thanks for your help to make Ubuntu better by filing this bug report.

As regards Korean fonts, I wonder if you noticed bug 715742 and bug 716872, both of which were fixed in Natty. Do those changes make a difference to the suggested changes in this report?

Keechang Kim (keechang) wrote :

#715742 dealt with 29-language-selector-ko-kr.conf which was included in language-selector package. As reported by @jincreator, the file was obsolete and it is properly removed.
#726872 was about Guseul font (included in ttf-alee package). However, reference to this font should now be removed from 69-language-selector-ko-kr.conf because this is a kind of "fantasy font" inappropriate for ordinary use. #726872 also touched upon monospace font issues affecting Korean. This problem can now be satisfactorily resolved thanks to ttf-nanum-coding which is a good quality Korean monospace font.

(further improvements to these suggested patches are currently being discussed in the ubuntu-ko mailing list and will shortly be uploaded here)

Keechang Kim (keechang) wrote :

Attached herewith are the following files with in-line comments.

30-cjk-aliases.conf (in language-selector)
40-nonlatin.conf (in fontconfig)
65-nonlatin.conf (in fontconfig)
69-language-selector-ko-kr.conf (in language-selector)

The lengthy comments I added are only for discussion purpose and should be removed if and when these proposed changes are committed as fixes.

Keechang Kim (keechang) wrote :

69-language-selector-ko-kr.conf is tidied up (reflecting the discussion in the Korean Ubuntu Users Mailing list).

Keechang Kim (keechang) wrote :

Java font configuration should also be modified if and when ttf-nanum becomes the default Korean font.

 /etc/java-6-openjdk/fontconfig.properties should perhaps be changed as shown in the attached file.

Keechang Kim (keechang) wrote :

It appears that Mac OS 10.7 (Lion) also adopts Nanum font for Korean typeface. http://x86osx.com/bbs/data/freeboard/1308944167/nanumgothic.jpg

Changed in fontconfig (Ubuntu):
status: New → Confirmed
Changed in language-selector (Ubuntu):
status: New → Confirmed
Changed in language-support-fonts-ko (Ubuntu):
status: New → Confirmed
Changed in openjdk-6 (Ubuntu):
status: New → Confirmed
Changed in ubuntu-meta (Ubuntu):
status: New → Confirmed

Created attachment 52946
patch to add Nanum Korean fonts

at 2008, new free Korean font, Nanum came with OFL license(free license).
And, Nanum family fonts are having much better quility than Un family's.
As the result, Mac OS 10.7(codename Lion) and ChromeOS decide to include Nanum fonts.
So, I suggest to use Nanum instead of Un.

Nanum has several Korean fonts, iincluding sans, serif, and monospace.
NanumGothic is Korean sans-serif font, NanumMyeongjo is Korean serif font, and NanumGothic is Korean monospace font.

I attach patch file.
Also I add some more comment(<!-- hangul (ko) -->) and change priority at monosapce in 65-nonlatin.conf.

*** Bug 45335 has been marked as a duplicate of this bug. ***

Martin Pitt (pitti) wrote :

ubuntu-desktop depends on fonts-nanum now.

Changed in ubuntu-meta (Ubuntu):
status: Confirmed → Fix Released
no longer affects: language-support-fonts-ko (Ubuntu)
Martin Pitt (pitti) wrote :

language-selector has been switched a while ago, too:

$ grep ^fn:ko /usr/share/language-selector/data/pkg_depends
fn:ko::fonts-nanum
fn:ko::fonts-nanum-coding
fn:ko::fonts-nanum-extra
fn:ko::ttf-alee

Changed in language-selector (Ubuntu):
status: Confirmed → Fix Released
no longer affects: fontconfig (Ubuntu)
Keechang Kim (keechang) wrote :

Wonderful news!

30-cjk-aliases.conf (which is now included in language-selector-common) should be updated (replaced) as per "Modified configuration files" provided here as "Bug attachments".

65-nonlatin.conf (which is now included in fontconfig-conf) should also be updated as proposed here.

Even if these changes are not made, as long as users have not installed ttf-unfonts, they will have fonts-nanum as their default Korean font, which is perhaps ok. But if these changes are not made, when users install ttf-unfonts as 'additional' fonts, they will have they 'preferred font' changed into ttf-unfonts, which will be an unpleasant, unintended surprise for quite a few users.

Suggesting changes in 65-nonlatin.conf due to a migration to fonts-nanum. More info in the Ubuntu bug report https://launchpad.net/bugs/792471

Created attachment 56594
Changes in 65-nonlatin.conf

Gunnar Hjalmarsson (gunnarhj) wrote :

Hi Keechang,
I have prepared your proposed changes to 30-cjk-aliases.conf and 65-nonlatin.conf for uploading.

Changed in fontconfig (Ubuntu):
assignee: nobody → Gunnar Hjalmarsson (gunnarhj)
status: New → In Progress
Changed in fontconfig:
importance: Unknown → Medium
status: Unknown → Confirmed

*** Bug 45613 has been marked as a duplicate of this bug. ***

Martin Pitt (pitti) wrote :

fonts-nanum already ships its own fontconfig snippet in /etc/fonts/conf.d/90-fonts-nanum.conf. Why is it also necessary to modify fontconfig itself?

Changed in fontconfig:
importance: Medium → Wishlist
Keechang Kim (keechang) wrote :

90-fonts-nanum.conf and 30-cjk-aliases.conf, for example, have somewhat different instructions. One can, of course, remove altogether the lines concerning Korean fonts from 30-cjk-aliases.conf and then it would be ok with 90-fonts-nanum.conf alone. With the current instructions contained in 30-cjk-aliases.conf, however, ttf-unfont will be regarded as the preferred font for certain missing fonts.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package fontconfig - 2.8.0-3ubuntu3

---------------
fontconfig (2.8.0-3ubuntu3) precise; urgency=low

  * debian/patches/01_fonts_nanum.patch:
    Changes due to Korean migration to fonts-nanum (LP: #792471).
 -- Gunnar Hjalmarsson <email address hidden> Wed, 08 Feb 2012 06:57:12 +0100

Changed in fontconfig (Ubuntu):
status: In Progress → Fix Released

Created attachment 56872
add Nanum fonts, fix Baekmuk missing, fix monospace priority

There is a small syntax error in the patch:

+ <family>Baekmuk Gulim</family <!-- hangul (ko) -->
should be
+ <family>Baekmuk Gulim</family> <!-- hangul (ko) -->

Martin Pitt (pitti) wrote :

I uploaded a new fontconfig with this typo fixed.

Created attachment 56971
add Nanum fonts, fix Baekmuk missing, fix monospace priority

Ah, thanks Felix!

Jinkyu Yi (jincreator) wrote :

Thanks for your fast update, Pitt!

Fixed in 8c58dc27.

Changed in fontconfig:
status: Confirmed → Fix Released
Matthias Klose (doko) wrote :

which ubuntu (and debian) releases do have the new font as the default?

Changed in openjdk-6 (Ubuntu):
status: Confirmed → Incomplete
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package openjdk-6 - 6b24-1.11.1-3ubuntu1

---------------
openjdk-6 (6b24-1.11.1-3ubuntu1) precise; urgency=low

  * Regenerate the control file.

openjdk-6 (6b24-1.11.1-3) unstable; urgency=low

  * Use NanumMyeongjo as the preferred korean font. LP: #792471.
    Closes: #655167.
  * Fix java path in jexec for multiarch builds.
  * Fix crash in java.net.NetworkInterface.getNetworkInterfaces() when
    ifr_ifindex exceeds 255. LP: #925218. S7078386.
  * Remove javaws and pluginappletviewer alternatives on upgrade from
    squeeze. Closes: #660604.
  * Use IPAfont as the preferred japanesse font. Closes: #646054.
  * Build using gcj on alpha and armel. Closes: #655750.
  * Drop build dependency on libxp-dev. Closes: #623667.

openjdk-6 (6b24-1.11.1-2ubuntu2) precise; urgency=low

  * Make sure that the nss.cfg doesn't mention any library path.
    LP: #939361, #939419.
  * Disable the accessibility wrapper, doesn't work yet. LP: #935296.
  * ARM: Inline math functions, where asm instructions exist (taken from
    the trunk).
 -- Matthias Klose <email address hidden> Mon, 27 Feb 2012 12:45:54 +0100

Changed in openjdk-6 (Ubuntu):
status: Incomplete → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.