removing ntpdate removes ubuntu-minimal

Bug #777879 reported by gerti on 2011-05-05
18
This bug affects 3 people
Affects Status Importance Assigned to Milestone
ubuntu-meta (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: synaptic

Ubuntu 11.4. Synaptic, preparing to remove ntpdate, tells that it will remove Ubuntu-minimal too.
This really doesn't seems smart to do (;-))
Its not possible to remove the check-mark for/un-mark Ubuntu-minimal.
(The reason, I want to remove ntpdate, is, that it says, under ntp, that ntpdate is not necessary.)

ProblemType: Bug
DistroRelease: Ubuntu 11.04
Package: synaptic 0.75.1ubuntu2
ProcVersionSignature: Ubuntu 2.6.38-8.42-generic 2.6.38.2
Uname: Linux 2.6.38-8-generic i686
Architecture: i386
Date: Thu May 5 16:01:14 2011
ExecutablePath: /usr/sbin/synaptic
ProcEnviron:
 LANGUAGE=en_US:en
 PATH=(custom, no user)
 LANG=en_DK.UTF-8
 LC_MESSAGES=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: synaptic
UpgradeStatus: No upgrade log present (probably fresh install)

gerti (gerti) wrote :
Robert Roth (evfool) wrote :

Ubuntu-minimal is a meta-package, consisting of a list of packages required for a minimal ubuntu install, and if you remove any of these, ubuntu-minimal will also be removed. So ntpdate is required (the computer will work without it, however you might experience some unexpected behavior, e.g. upgrading to the next release might fail), the description says that it's optional only if the ntp package is installed.
---
Ubuntu Bug Squad volunteer triager
http://wiki.ubuntu.com/BugSquad

Ben Shadwick (benshadwick) wrote :

I have ntp installed (on purpose), but cannot uninstall ntpdate without losing ubuntu-minimal. What should I do?

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in synaptic (Ubuntu):
status: New → Confirmed
affects: synaptic (Ubuntu) → ubuntu-meta (Ubuntu)
Changed in ubuntu-meta (Ubuntu):
status: Confirmed → New
Alex (normadize) wrote :

Bug still present in 14.04 ... has it been fixed in 15+?

Ben Shadwick (benshadwick) wrote :

@Alex check the bug report that this is marked as a duplicate of.

Apparently ntpdate has been replaced with systemd-timesyncd and removed as an ubuntu-minimal dependency.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers