xfsprogs,jfsutils missing from install / live CD, can not use XFS,jfs during installation

Bug #568024 reported by Michael Lueck on 2010-04-21
22
This bug affects 3 people
Affects Status Importance Assigned to Milestone
ubuntu-meta (Ubuntu)
High
Colin Watson
Lucid
High
Colin Watson

Bug Description

Binary package hint: ubiquity

Recent daily builds of Lucid have errored trying to format partitions as xfs. Today we tracked that problem down to the absence of mkfs.xfs which in turn indicated that package xfsprogs is missing on the install / LiveCD.

Indeed "dpkg -l | grep xfs" only returns x11-xfs-utils and not xfsprogs

Please get xfsprogs back in the install / LiveCD image and let me know when I should download another daily to re-test this problem.

Thanks!

Steve Beattie (sbeattie) wrote :

Confirming, and jfsutils are also missing from the live images.

Changed in ubiquity (Ubuntu):
status: New → Confirmed
importance: Undecided → Critical
summary: - xfsprogs missing from install / live CD, can not use XFS during
- installation
+ xfsprogs,jfsutils missing from install / live CD, can not use XFS,jfs
+ during installation
Changed in ubiquity (Ubuntu Lucid):
importance: Critical → High
Colin Watson (cjwatson) wrote :

Seed fixes committed; the first daily after RC (unless we respin, which seems unlikely for this bug?) should include these packages again.

revno: 1702
fixes bug(s): https://launchpad.net/bugs/568024
committer: Colin Watson <email address hidden>
branch nick: ubuntu.lucid
timestamp: Wed 2010-04-21 21:45:23 +0100
message:
  add Task-Seeds field to clue the archive into including the contents of live-common in the live task (LP: #568024)

revno: 781
fixes bug(s): https://launchpad.net/bugs/568024
committer: Colin Watson <email address hidden>
branch nick: edubuntu.lucid
timestamp: Wed 2010-04-21 21:45:41 +0100
message:
  add Task-Seeds field to clue the archive into including the contents of live-common in the dvd-live task (LP: #568024)

affects: ubiquity (Ubuntu Lucid) → ubuntu-meta (Ubuntu Lucid)
Changed in ubuntu-meta (Ubuntu Lucid):
assignee: nobody → Colin Watson (cjwatson)
status: Confirmed → Fix Released
Michael Lueck (mlueck) wrote :

>>the first daily after RC should include these packages again.

What does that mean? Should the packages be in tomorrow's daily?

Colin Watson (cjwatson) wrote :

Daily builds are disabled while we prepare the release candidate, which is due out tomorrow all being well. At some point soon after that, daily builds will be re-enabled.

tags: added: iso-testing
Michael Lueck (mlueck) wrote :

Thanks for the explanation Colin.

So did this fix make it into the RC release then since it does not sound like it is done yet?

It's done (in that there's nothing more we need to do except for
respinning the CDs), but the RC images had already been built and were
well into testing by the time we saw your bug so this fix won't be in
the RC.

Michael Lueck (mlueck) wrote :

Completely understood now. Thank you for your explanations of what goes on behind the curtain! :-)

Michael Lueck (mlueck) wrote :

Being the impatient type, I used my 20100419.1 LiveCD, added the Lucid package of xfsprogs, and the installation went through beautifully. Now on to other testing.

Michael Lueck (mlueck) wrote :

Fix confirmed for the xfs filesystem with the 20100426.1 iso build.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers