Meta packages should not depend on any app that appears in the application menu

Bug #48465 reported by W. Adam Doherty on 2006-06-05
18
Affects Status Importance Assigned to Milestone
ubuntu-meta (Ubuntu)
Wishlist
Unassigned

Bug Description

Only recommend all apps that appear in the menu, so that they can be removed and replaced by the user without the need to remove the ubuntu-desktop package at all.

The following bug report is a good use case:

Binary package hint: gnome-app-install

The Add/Remove menu feature is a great one. Very simple to use, very non-geek friendly. Unfortunately there exists a problem of remove items.

The example I give is this:

Trying AisleRiot Solitare I find that I don't like it, but BlackJack is great. I decide I want to remove AisleRiot Solitare but I am presented with a dialog stating the application cannot remove "gnome-games", and that I must move to the advanced software manager to remove gnome-games.

But I don't want to remove gnome-games, I want to remove AisleRiot Solitare

Switching to the advanced software manager (synaptic); from a non-technical users view I would find this interface confusing and overwhelming. All I want to do is remove AisleRiot Solitare.

Given that gnome-app-install is labeled "Add/Remove" would it not better serve users to be able to remove any applications listed, just as simply as it is to add them?

If other packages depend on things that the app you want to remove depends on, then gnome-app-install should know this and leave the dependencies alone so far as is required for the other applications to continue to work unimpeded.

Yeah this makes sense. Thanks for the spotting this since this is obviously a bug.

Changed in gnome-app-install:
status: Unconfirmed → Confirmed
Sebastian Heinlein (glatzor) wrote :

The problem is that Solitare and the other gnome games are packaged in only one package. Two options: file a bug against gnome-games that every game should be self contained in its own package or we intrduce the concept of "software collections" to gnome-app-install.

If you want to remove the gnome-games, you will get the following message:

"Solitare is part of the software collection gnome-games

You can only remove the whole collection that also contains the following applications:
Mines
FreeCell

[Cancel] [Remove Collection]"

Changed in gnome-app-install:
assignee: nobody → glatzor
Sebastian Heinlein (glatzor) wrote :

To make it clear: gnome-games is not a dependency of solitare - it is the name of the package.

Another case are meta packages. Since we plan to install recommended packages by default in edgy we can hopefully get rid of meta packages that block apps at all, e.g. evolution is blocked by ubuntu-desktop.

description: updated
Changed in gnome-app-install:
assignee: glatzor → nobody
Jerome S. Gotangco (jsgotangco) wrote :

That sounds like a good idea. Synaptic doesn't list the games contained in gnome-games but rather the whole package itself then describe what the package contains. I doubt if upstream will be open to splitting up the gnome-games package since they are considered essential for every release.

Note: there's also the gnome-games-data package which contains the data files.

Changed in gnome-games (Ubuntu):
status: New → Invalid
Mathew Hodson (mathew-hodson) wrote :

This is fixed at least since trusty. ubuntu-desktop does not depend on gnome-games, and aisleriot can be uninstalled without removing ubuntu-desktop or other games.

Changed in ubuntu-meta (Ubuntu):
status: Confirmed → Fix Released
no longer affects: gnome-games (Ubuntu)
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers