Dove install will fail without network access

Bug #457536 reported by Paul Larson on 2009-10-21
12
This bug affects 1 person
Affects Status Importance Assigned to Milestone
linux-mvl-dove (Ubuntu)
Medium
Unassigned
Karmic
Undecided
Unassigned
ubuntu-meta (Ubuntu)
High
Steve Langasek
Karmic
High
Steve Langasek

Bug Description

Binary package hint: ubiquity

Installing on Dove with 100MB /boot (ext2) and the rest, other than swap, was ext4. Manual partitioning. I didn't get the error until towards the end of the install.

ProblemType: Crash
Architecture: armel
Date: Wed Oct 21 12:38:33 2009
DistroRelease: Ubuntu 9.10
ExecutablePath: /usr/lib/ubiquity/bin/ubiquity
InterpreterPath: /usr/bin/python2.6
LiveMediaBuild: Ubuntu 9.10 "Karmic Koala" - Release Candidate armel+dove (20091021.1)
Package: ubiquity 2.0.2
ProcCmdline: /usr/bin/python /usr/lib/ubiquity/bin/ubiquity gtk_ui
ProcCwd: /home/ubuntu
ProcEnviron: Error: [Errno 13] Permission denied: '/proc/2922/environ'
ProcVersionSignature: Ubuntu 2.6.31-208.16-dove
PythonArgs: ['/usr/lib/ubiquity/bin/ubiquity', 'gtk_ui']
SourcePackage: ubiquity
Title: ubiquity crashed with InstallStepError in configure_bootloader()
Uname: Linux 2.6.31-208-dove armv7l
UserGroups:

Paul Larson (pwlars) wrote :
visibility: private → public
Paul Larson (pwlars) wrote :

Michael, any chance this could be related to the recent changes?

Changed in ubiquity (Ubuntu):
assignee: nobody → Michael Casadevall (mcasadevall)
tags: removed: need-duplicate-check
Paul Larson (pwlars) wrote :

Just talked to Michael on IRC about this:
Oct 21 17:38:31 ubuntu ubiquity: Err http://ports.ubuntu.com karmic/main uboot-mkimage 0.4
Oct 21 17:38:31 ubuntu ubiquity: Could not resolve 'ports.ubuntu.com'
Oct 21 17:38:31 ubuntu ubiquity: Failed to fetch http://ports.ubuntu.com/ubuntu-ports/pool/main/u/uboot-mkimage/uboot-mkimage_0.4_armel.deb Could not resolve 'ports.ubuntu.com

This image will fail to install without network access. I had seen it succeed when I retried, but that's because I connected to the network to file this bug. Bumping the importance up to critical.

summary: - ubiquity crashed with InstallStepError in configure_bootloader()
+ Dove install will fail without network access
affects: ubiquity (Ubuntu) → ubuntu-meta (Ubuntu)
Changed in ubuntu-meta (Ubuntu):
importance: Undecided → Critical
status: New → Triaged
Changed in ubuntu-meta (Ubuntu Karmic):
milestone: none → ubuntu-9.10
Steve Langasek (vorlon) wrote :

Have committed a change to the platform/d-i-requirements seed for this; will upload a fix to the queue for acceptance after RC.

For lucid, this should be fixed in the recommends of the dove kernel image packages, the way it's done for all the other per-architecture bootloader packages.

Changed in ubuntu-meta (Ubuntu Karmic):
assignee: Michael Casadevall (mcasadevall) → Steve Langasek (vorlon)
status: Triaged → Fix Committed
Steve Langasek (vorlon) on 2009-10-22
Changed in linux-mvl-dove (Ubuntu Karmic):
status: New → Won't Fix
Changed in linux-mvl-dove (Ubuntu):
importance: Undecided → Medium
status: New → Triaged
Steve Langasek (vorlon) wrote :

Oops, that's a bit inaccurate; a) d-i-requirements doesn't affect live images anyway, b) no ubuntu-meta upload is needed for changes to ship-live (where I've now properly seeded this). So this will be picked up automatically on the next image reroll for dove.

Changed in ubuntu-meta (Ubuntu Karmic):
status: Fix Committed → Fix Released
Loïc Minier (lool) on 2009-10-22
Changed in ubuntu-meta (Ubuntu Karmic):
importance: Critical → High
Paul Larson (pwlars) wrote :

Confirmed this is fixed now

Changed in linux-mvl-dove (Ubuntu):
status: Triaged → Won't Fix
Steve Langasek (vorlon) wrote :

No, it's been fixed in the wrong place as a workaround. This needs to be added to the linux package for karmic.

Changed in linux-mvl-dove (Ubuntu):
status: Won't Fix → Triaged
tags: added: iso-testing
tags: added: karmic
Eric Miao (eric.y.miao) wrote :

What happened to this bug? The symptom and log suggested that this is most likely a same bug as 537007, which was not fixed until ubiquity 2.2.9.

Paul Larson (pwlars) wrote :

from comment #4:
>...
>For lucid, this should be fixed in the recommends of the dove kernel image packages, the way it's done
>for all the other per-architecture bootloader packages.

Was that ever done?

Steve Langasek (vorlon) wrote :

No, it has not been done.

tags: added: dove
Steve Langasek (vorlon) wrote :

package not in natty.

Changed in linux-mvl-dove (Ubuntu):
status: Triaged → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers