Dove squashfses end up with imx51 kernel headers

Bug #427199 reported by Michael Casadevall on 2009-09-10
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
linux-mvl-dove (Ubuntu)
High
Brad Figg
Karmic
High
Brad Figg
livecd-rootfs (Ubuntu)
High
Colin Watson
Karmic
High
Colin Watson
ubuntu-meta (Ubuntu)
High
Loïc Minier
Karmic
High
Loïc Minier

Bug Description

Binary package hint: livecd-rootfs

When building dove images, germinate/livecd-rootfs ends up installing linux-headers-imx51 instead of the dove images. Futher investigation is required to determine why.

tags: added: armel
Changed in livecd-rootfs (Ubuntu):
importance: Undecided → High
status: New → Confirmed
Changed in livecd-rootfs (Ubuntu Karmic):
milestone: none → karmic-alpha-6
Colin Watson (cjwatson) wrote :

There's no way to do this entirely properly, because tasks aren't subarchitecture-specific. However, I've made this seed change:

revno: 1386
committer: Colin Watson <email address hidden>
branch nick: platform.karmic
timestamp: Mon 2009-09-14 15:45:02 +0100
message:
  add (linux-headers-dove) [armel] to desktop-common (LP: #427199)

If this isn't sufficient and it really is critical to remove linux-headers-imx51 from the dove images, then please let me know and explain why (beyond just "it's ugly").

Changed in livecd-rootfs (Ubuntu Karmic):
assignee: nobody → Colin Watson (cjwatson)
status: Confirmed → Fix Released
Changed in livecd-rootfs (Ubuntu Karmic):
status: Fix Released → Confirmed
milestone: karmic-alpha-6 → ubuntu-9.10-beta
Loïc Minier (lool) wrote :

@Colin: Oliver and Michael reverted your change since it exposed a broken dependency of the headers packages (AIUI); there's no time for a kernel upload to fix this before A6 so they decided the easiest was to revert the fix for this bug to reapply it after A6, when the kernel will be fixed as well.

Changed in livecd-rootfs (Ubuntu Karmic):
status: Confirmed → Triaged
Colin Watson (cjwatson) on 2009-09-18
summary: - Dove squahfs's end up with imx51 kernel headers
+ Dove squashfses end up with imx51 kernel headers
Loïc Minier (lool) wrote :

Adding an ubuntu-meta ask as a reminder to apply cjwatson's changes when linux-mvl-dove is uploaded (Michael tells me this is fixed in git).

Changed in ubuntu-meta (Ubuntu Karmic):
assignee: nobody → Ubuntu armel porters (ubuntu-armel)
importance: Undecided → High
milestone: none → ubuntu-9.10-beta
status: New → Triaged
Changed in linux-mvl-dove (Ubuntu Karmic):
assignee: nobody → Brad Figg (brad-figg)
status: New → Fix Committed
importance: Undecided → High
milestone: none → ubuntu-9.10-beta
Steve Langasek (vorlon) wrote :

It would be consistent with other architectures' handling in desktop-common to install *both* headers packages on *both* images. Is there a reason that's not ok here?

I understood that the only reason that wasn't OK was because the imx51
headers were uninstallable for the time being. The fix I applied was
certainly to install both headers packages on both images.

Colin Watson (cjwatson) wrote :

... I think I mean "because the dove headers were uninstallable for the
time being".

Loïc Minier (lool) wrote :

Exactly; fix got uploaded end of last week but the packages were in NEW.

Loïc Minier (lool) wrote :

Since the change is actually in the seed (and -meta if one likes) and not in livecd-rootfs I'm wontfixing and unmilestoning this task.

Changed in ubuntu-meta (Ubuntu Karmic):
status: Triaged → In Progress
Changed in linux-mvl-dove (Ubuntu Karmic):
status: Fix Committed → Fix Released
Changed in ubuntu-meta (Ubuntu Karmic):
assignee: Ubuntu armel porters (ubuntu-armel) → Loïc Minier (lool)
Changed in livecd-rootfs (Ubuntu Karmic):
milestone: ubuntu-9.10-beta → none
status: Triaged → Won't Fix
Changed in livecd-rootfs (Ubuntu):
status: Triaged → Won't Fix
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubuntu-meta - 1.170

---------------
ubuntu-meta (1.170) karmic; urgency=low

  * Refreshed dependencies
  * Added linux-headers-dove to desktop-recommends [armel]; LP: #427199.
  * Bump up Standards-Version to 3.8.3; no change needed.
  * Add ${misc:Depends}.

 -- Loic Minier <email address hidden> Wed, 23 Sep 2009 10:39:20 +0200

Changed in ubuntu-meta (Ubuntu Karmic):
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers