Ship fewer screensavers by default

Bug #385850 reported by Wouter Stomp on 2009-06-11
44
This bug affects 6 people
Affects Status Importance Assigned to Milestone
One Hundred Papercuts
Low
Robert Ancell
gnome-screensaver (Ubuntu)
Wishlist
Unassigned
ubuntu-meta (Ubuntu)
Undecided
Martin Pitt
xscreensaver (Debian)
Fix Released
Unknown
xscreensaver (Ubuntu)
Wishlist
Martin Pitt

Bug Description

Binary package hint: ubuntu-desktop

In all places Ubuntu ships with a sensible set of default settings. There are 5 wallpapers, 9 themes, but actually more than 80 screensavers in the default installation! This is far too many. A selection of max about 10 of the best of them should be selected. All other can be split of to a screensavers-extra package for people that still want them. This will also save several mb's on the cd.

See also http://brainstorm.ubuntu.com/idea/4236/

Related branches

Tormod Volden (tormodvolden) wrote :

Many people actually love to see all the screensavers (running in Random), others have their favourites which they don't want to see go away. On Ubuntu 9.04 there are 3 packages shipping screensaver hacks (in addition to the ca 4 .desktop ones coming with "gnome-screensaver):
14 xscreensaver-data installed size 1.1 MB (of which hack binaries: 0.6)
43 xscreensaver-gl installed size 4.7 MB (hack binaries: 4.0)
19 rss-glx installed size 3.9 MB (hack binaries 3.4)
Of course, on the Desktop CD the root fs is compressed, so the CD size savings would be smaller. On the Alternate CD, the debs consumes 0.4, 1.9 and 3.0 MB respectively.

~5 MB is a considerable amount of space saved. While of course there are some people who like as much screensavers as possible, I think for the majority of people this is just overkill. Also see the linked brainstorm idea, which has more than 600 support votes...

fosk (oscarrdg) wrote :

It is not really very useful to have too many screensavers when you want to change it for the first time.
I remember trying many of them before deciding which one to use the first time i used ubuntu.

summary: - Ship less screensavers by default
+ Ship fewer screensavers by default
sighK (staxjp) wrote :

Everyone I know to have used this have sat there for hours playing with the different screensavers. They think they are cool.

In the first release of Ubuntu, we stripped out many, many screensavers,
to good effect. I'm +1 on a comprehensive review with the goal to cut
them down to the 20 most surprisingly wonderful ones. I'd back a *small*
group to make that determination.

Mark

Changed in hundredpapercuts:
status: New → Confirmed
Tormod Volden (tormodvolden) wrote :

The initial Ubuntu strip-out resulted in the splitting of xscreensaver-data vs data-extra and -gl vs -gl-extra. I have spent countless hours coordinating/merging the Ubuntu/Debian packages including incorporating this split upstream. Please work together with Debian so that we don't diverge too much again. It seems simple enough to move aside a bunch of hacks into the -extra packages. The best way I can come up with now is to make a package maintenance script that allow easy reconfiguration of the -extra split. Debian might like to keep more savers in -data/-gl, and only move the troublesome ones to -extra. http://wiki.debian.org/XScreensaver

The rss-glx savers selection has to be done differently. It is important to note that most of the GPU-lockup/crash savers are in this package. Furthermore, many of them put a high toll on CPU usage because the OpenGL features they use are not well implemented in the graphics drivers we are shipping. On my system, about half of the savers use more than 90% CPU. See https://wiki.ubuntu.com/X/Screensavers and please contribute your own measurements.

Unfortunately Gnome (gnome-screensaver) does not offer any mechanism for disabling/reenabling a selection of screensavers among the installed ones. See nightmare report http://bugzilla.gnome.org/show_bug.cgi?id=316654 or the more optimistic http://bugzilla.gnome.org/show_bug.cgi?id=316462.

Mat Tomaszewski (mat.t.) on 2009-06-12
Changed in hundredpapercuts:
importance: Undecided → Low
Daniele Napolitano (dnax88) wrote :

One solution is creating "Install more screensavers" button on screensaer dialog that install -extra packages.

Personally I prefer more HD backgrounds that screensavers, less and less used (screensaver concept is born with CRT display for real technical reasons). Its better use monitor power save that keep it active and 99% CPU active!

DavidGN (davidgn) wrote :

If / when the screensavers are evaluated, suggest running 'top' to view CPU usage - some of them max out the CPU, which is a bad thing for a computer that's sitting idle. More CPU = more power = more CO2.

Screensavers are a complete waste of space and just a legacy of the CRT era. Just one additional variable that can cause problems PC. I'd be happy if there was just 5 simple screensavers. As DavidCOG pointed out, its also a wastage of CPU and thus not very 'green'. Every little bit counts!

Lightbreeze (nedhoy-gmail) wrote :

Please consider Bug #390308 in you choice of screensavers to keep.

The bug suggests some screensavers will shorten battery life.

Changed in hundredpapercuts:
milestone: none → round-4
Michael Janos (spikeybadooks) wrote :

I think it would be a great idea to get rid of many of the screensavers. 10 seems like a good number but an issue is which screensavers do we choose? I think we should put a poll on Ubuntu.com asking users to choose 10 of the screensavers. The top 10 will end up in the next release.

Tormod Volden (tormodvolden) wrote :

The only papercut-size fix I can see would be to remove the "Recommends" on xscreensaver-{data,gl} and rss-glx from gnome-screensaver and thus only install the native gnome-screensaver modes on new installations. This will leave the "cosmos" and "personal image folder" slideshows, which are pretty (cosmos at least) and resource-friendly.

Any solution involving selections of the existing screensavers (and leaving the possibility for those interested to enable others) would be non-trivial. Of course that should not stop anyone from coming up with a technical solution and a patch.

Those packages can easily be split up into several packages of which only some are installed.

Added a gnome-screensaver task. Demoting its depends on rss-glx could be a good first step towards resolving this. Firstly, it would cut 19 savers. Secondly, as Tormod notes above, the savers in this package account for most of the GPU-lockup/crashes and many have high CPU usage...

Andrew, do you have a list of the screensavers to remove/keep? If you have
technical motivations for removing certain savers, please list them so we can
cut those first. Then we can evaluate the remaining savers on other terms.

Tormod Volden (tormodvolden) wrote :

David, some 3D screensavers work fine on some graphics cards or drivers and not on others. The easiest would be to not pull in the package by default. As I already said, deactivating selected hacks or splitting packages will be painful, and is out of the scope of "paper cuts".

@ David:

I'm reluctant to make suggestions about specific screensavers as it is essentially subjective, at least until there is a general agreement that we should cut the number down. I'd rather not get caught up in debating the aesthetic qualities of the different screensavers. The only technical motivations are based on Tormod's comments.

The screensavers included in the rss-glx package are: Biof, Busy Spheres, Colorfire (which I actually really like), Cyclone, Drempels, Euphoria, Feedback, Fieldlines, Flocks, Flux, Helios, Hufo's Smoke, Hufo's Tunnel, Hyperspace, Lattice, Lorenz Attractor, MatrixView, Plasma, Skyrocket, Solarwinds, SpirographX, and Sundancer2.

Dropping one of the three packages from the desktop seed would be the simplest way to cut the number down. That said, I'd be willing to do the work to split the packages if it's decided that we should make a go at it...

@ Tormod:

I was think about ways to perhaps split the xscreensaver packages with out having to create a diff between the Debian and Ubuntu packages. Attached is a patch against collab-maint/xscreensaver.git

It creates data.{Debian, Ubuntu}, data-extra.{Debian, Ubuntu}, gl.{Debian, Ubuntu}, and gl-extras.{Debian, Ubuntu} listing the hacks that belong in each package. It also creates a script called from debian/rules which determines if the package is being built on Debian or Ubuntu, and then installs the appropriate hacks to the appropriate package.

Currently it doesn't actually remove any hacks from the Ubuntu package. It just provides the infrastructure to do so in a more manageable fashion. It works, but could use some more effort. I just wanted to see if folks thought this was good direction before putting more time into it....

Tormod Volden (tormodvolden) wrote :

Andrew, thanks for the patch! That is a very constructive contribution. However, I would not keep separate files for Ubuntu and Debian. Already having just one file that defines which hacks go in and having the maintainer script generate the necessary packaging files is good enough. The real Ubuntu delta will then be just one-liners for each hack that is moved, which is perfectly OK. There will always be some small "branding" changes between Debian and Ubuntu anyway. The configuration file could alternatively be a table listing the "hack" and which package it goes to.

I won't have the possibility to review this or work on it myself for the next weeks, but I suggest you file a wishlist bug in Debian with your improvements so we can track it there, and keep my co-maintainers in the loop.

I agree that it is difficult to choose because it is so subjective. To try and move things along I've gone through and selected a variety of screensavers with a broad range of features, looks and speeds. My aim was to pick a selection that would cater for the needs of different types of users - fast, dreamy, relaxing, funny, fun, beautiful etc. Hopefully this way most users will find something that appeals on their first use of the feature.

Once I had selected them I realised quite a few were on your list of high-CPU usage, so I've removed them.... So my list is down to 12.

Ant spotlight - Fun, technical, interesting, young males may be drawn to this one.
Fiberlamp - Humourous but beautiful, easy to stare at while you're on the phone.
Floating Ubuntu - Good to include a branded one in the CD.
F-spot - Its important to provide users with the ability to get a more personal and customised screensaver based on their photographs. This will also be a screensaver anyone switching from another platform might expect and could make them feel reassured like not that much is changing.
Fuzz Flakes - Would appeal to younger females, an audience segment its important to court going forward.
GBlur - Including more fast-paced animations along with the slower, dreamier ones will add variety
GLCells - A less graphical screensaver, but still easily watchable without being too engaging or distracting
GLMatrix - To appeal to all our inner geeks and Matrix fans!
GL School - Fun and light, relaxing - a slower alternative to the GBlur. A nice one to include if we are removing some of the more dreamy ones like BioF and Colorfire
GLSlideshow - Beautiful images of space are always very popular. Good to include this if Cosmos is being removed. Interesting link to Mr. Shuttleworth too!
GLText - This is a bit of a classic and users switching may expect to find it (useful for leaving messages for yourself or for colleagues amusement at work!)
Hypertours - Primary colours and fast-movement make it engaging and fun.

I hope I haven't left any favourites out... my aim was to get a balanced mix that would appeal to a broad range of users.

Dave Stroud (bigdavesr) wrote :

The pictures screen saver is the only one I use.Would like to see it keept. The others I very seldom use. Would not miss any of them. I do use some once and a while. I have tried the f-spot and found it hard to set up.The pictures screen saver is easy to set up and does the same thing. I am having problems in karmic with the mouse it will not shut off screen saver. The only way I can shut it off is by the keyboard. It works that way but I prefer to use my mouse. Thank you

Attached is the updated patch I have submitted to debian. It is against collab-maint/xscreensaver.git, so it might not apply against the current Ubuntu package cleanly. I'll follow this up shortly with a debdiff against the karmic package which will also move some screensavers out of the default install based on Alejandra's suggestions above.

Changed in xscreensaver (Debian):
status: Unknown → New

Attached is a debdiff for xscreensaver cutting down the number of savers installed.

In order to actually cut it down to just the 12 listed above we'd need to remove gnome-screensaver's recommends on rss-glx. Also gnome-screensaver shouldn't install Cosmos, Picture Folder, and Floating Feet (note that only the desktop file shouldn't be installed as the actually binary is called by Floating Ubuntu as well). It might just be easier to keep these, but Cosmos does seem a bit redundant with GLSlideshow already show space pictures. There's also a question of Pictures Folder vs F-Spot. Personally, I don't use F-spot so it's useless to me, but for those that do use it might be nicer than Pictures Folder (although, I guess these would be completely redundant if Bug #127315 is fixed)... If someone from the DX Team would give me some marching orders on what they'd like to see happen with gnome-screensaver, I'd be happy to supply a patch.

ubuntu-desktop also seems to depend on rss-glx.

Also, just to be clear where all the screen savers are coming from, the F-Spot screensaver comes from f-spot and Floating Ubuntu comes from human-theme.

Tormod Volden included an updated version of the script in the Debian bug, consolidating all the config stuff to one file. I've converted the Ubuntu branch to use this. Please see the merge proposal:

https://code.edge.launchpad.net/~andrewsomething/xscreensaver/bug-385850/+merge/9960

Tormod Volden (tormodvolden) wrote :

There was one typo "gleidescopev" in the old patches. Refined, tested version for Debian has now been pushed to git.

Changed in gnome-screensaver (Ubuntu):
importance: Undecided → Wishlist
Changed in hundredpapercuts:
assignee: nobody → Robert Ancell (robert-ancell)
Vish (vish) wrote :

@ Alejandra Obregon , Andrew Starr-Bochicchio
You might want to revisit the list selected.
The latest kernels 31-7 and 31-8 have some major improvements in screensaver , and I notice several of the screensavers works better.
Radeon KMS support has been included.

The most drastic improvement i notice[in ATI cards] is the Atunnel. Maybe it could replace Ant Spotlight. Which is a bit boring.

Robert Ancell (robert-ancell) wrote :

Latest changes pushed into lp:~ubuntu-desktop/xscreensaver/ubuntu, could a main sponsor please release this?

Changed in gnome-screensaver (Ubuntu):
status: New → Triaged
Changed in xscreensaver (Ubuntu):
status: New → Triaged
Changed in gnome-screensaver (Ubuntu):
status: Triaged → New
Changed in xscreensaver (Ubuntu):
importance: Undecided → Wishlist
Robert Ancell (robert-ancell) wrote :

No change is required to ubuntu-meta as package names have not been changed

Changed in ubuntu-meta (Ubuntu):
status: New → Invalid
Robert Ancell (robert-ancell) wrote :

Needs Replaces fields as files have moved between packages.
Main is currently frozen which will delay this being uploaded.

Robert Ancell (robert-ancell) wrote :

Branch updated with replaces fields in debian/control

Andrew (and471) on 2009-09-05
Changed in hundredpapercuts:
status: Confirmed → In Progress
Changed in gnome-screensaver (Ubuntu):
status: New → In Progress
Changed in xscreensaver (Ubuntu):
status: Triaged → In Progress
Martin Pitt (pitti) wrote :

taking for sponsoring

Changed in xscreensaver (Ubuntu):
assignee: nobody → Martin Pitt (pitti)
Martin Pitt (pitti) wrote :

I don't see gnome-screensaver being discussed here, or having a patch/branch. Since this task is unassigned, "in progress" does not make much sense. Is there something to be done for gnome-screensaver here? I don't think so, since it just has three (cosmos, floating logo, personal slideshow). Please reopen if appropriate and add necessary changes.

Changed in gnome-screensaver (Ubuntu):
status: In Progress → Invalid

@ Martin

I have no idea why it was set in-progress, but please see comment #24. gnome-screensaver recommends rss-glx (ubuntu-desktop also seems to pull this in), and in order to really cut the number of installed screen savers down we should not install it by default.

Andrew Starr-Bochicchio [2009-09-09 9:41 -0000]:
> I have no idea why it was set in-progress, but please see comment #24.
> gnome-screensaver recommends rss-glx (ubuntu-desktop also seems to pull
> this in), and in order to really cut the number of installed screen
> savers down we should not install it by default.

Ah, I see. Robert, is that confirmed? That'd loose us quite a number
of screensavers. Fine for me, but I want to avoid misunderstandings.

Martin Pitt (pitti) wrote :

Reopening gnome-screensaver task for Robert to confirm.

D'oh, seems I forgot to upload xscreensaver yesterday. Doing now..

Changed in gnome-screensaver (Ubuntu):
assignee: nobody → Robert Ancell (robert-ancell)
status: Invalid → Incomplete
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package xscreensaver - 5.08-0ubuntu4

---------------
xscreensaver (5.08-0ubuntu4) karmic; urgency=low

  * Install fewer screensavers by default. (LP: #385850)
   - Move all screensavers except fiberlamp, fuzzyflakes,
     antspotlight, glblur, glcells, glmatrix, glschool,
     glslideshow, gltext, and hypertoru to the extra
     packages.
  * Add files split-hacks.sh and split-hacks.config in /debian
    inorder to simplfy moving screensavers between packages. Patch
    from Debian (Thanks to Tormod Volden):
    http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=539937
  * debian/control:
    - Make xscreensaver-data and xscreensaver-data-extra replace each other
      as files have moved between the two packages. The same is done for
      xscreensaver-gl and xscreensaver-gl-extra

 -- Andrew Starr-Bochicchio <email address hidden> Wed, 09 Sep 2009 10:59:31 +0200

Changed in xscreensaver (Ubuntu):
status: In Progress → Fix Released
Robert Ancell (robert-ancell) wrote :

rss-glx moved from gnome-screensaver recommends to suggests (as is the -extra packages). Ready for sponsorship.

Changed in gnome-screensaver (Ubuntu):
assignee: Robert Ancell (robert-ancell) → nobody
status: Incomplete → New
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-screensaver - 2.27.0-0ubuntu6

---------------
gnome-screensaver (2.27.0-0ubuntu6) karmic; urgency=low

  * debian/control.in:
    - Move rss-glx from recommends to suggests (LP: #385850)
    - Add xscreensaver-data-extra and screensaver-gl-extra to suggests

 -- Robert Ancell <email address hidden> Fri, 11 Sep 2009 11:00:55 +0200

Changed in gnome-screensaver (Ubuntu):
status: New → Fix Released
Vish (vish) on 2009-09-11
Changed in hundredpapercuts:
status: In Progress → Fix Released
Waldir Leoncio (wleoncio) wrote :

Is it true that screensavers are only important for saving CRT monitors?

Vish (vish) wrote :

Waldir Leoncio , nope ... if screensavers dont activate , even LCD's can get burn ins...

Changed in xscreensaver (Debian):
status: New → Fix Released

Reopening ubuntu-meta task and subscribing the release team for comment.

It was mistakenly closed before. rss-glx was demoted from recommends to suggests for gnome-screensaver, but ubuntu-desktop explicitly depends on it as well. So we need to drop it there as well.

Merge request here: https://code.edge.launchpad.net/~andrewsomething/ubuntu/karmic/ubuntu-meta/remove-rss-glx/+merge/13536

As this effects CD builds, it might be too late for this. But as it is only dropping a package, it isn't very invasive.

Changed in ubuntu-meta (Ubuntu):
status: Invalid → New
Martin Pitt (pitti) wrote :

Andrew, you are a hero. We were just discussing how we could claim back 2 MB from the CDs to fix the overflow!

Martin Pitt (pitti) wrote :

Seed change committed, rebuilding ubuntu-meta now.

Changed in ubuntu-meta (Ubuntu):
assignee: nobody → Martin Pitt (pitti)
status: New → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubuntu-meta - 1.175

---------------
ubuntu-meta (1.175) karmic; urgency=low

  * Refreshed dependencies
  * Removed rss-glx from desktop. (LP: #385850)

 -- Martin Pitt <email address hidden> Mon, 19 Oct 2009 10:23:09 +0200

Changed in ubuntu-meta (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.