gnome-user-share required to send files from nokia phones to PC via bluetooth

Bug #373889 reported by philipp beitz on 2009-05-08
44
This bug affects 6 people
Affects Status Importance Assigned to Milestone
ubuntu-meta (Ubuntu)
Undecided
Unassigned

Bug Description

Description: Ubuntu 9.10, 9.04
Release: 9.10, 9.04
Installed: 4.51-0ubuntu2

32-0ubuntu4.1 Kandidat: 4.32-0ubuntu4.1

Want to send files via Bluetooth to my PC. Was possible with Ubuntu Hardy. With Jaunty sending files via bluetooth to my PC is not possible. If i install 'gnome-bluetooth' and start 'gnome-obex-server' its possible again.

Devices tested:
Nokia 5800 Xpress Music
Nokia 6300
Nokia 5000
Nokia 6120 Classic

Ben Crisford (bencrisford) wrote :

Hey,

A little more information would be useful if thats ok.

What bluetooth device/devices are/have you tried sending files to your PC from?

If you have only tried it with one device, if you have another available, it would be useful information to know whether it was just with one device or not.

Cheers,
Ben

Changed in bluez (Ubuntu):
status: New → Incomplete
philipp beitz (philippbeitz) wrote :

I use my Nokia 5800 Express Music cell and an ordinary Bluetooth Stick. I can send Files from my cell to PC but with Hardy not with Jaunty (and Intrepid)

Also Tested with Nokia 6300. Not possible too.

If i start gnome-obex-server i can send files again.

Ben Crisford (bencrisford) wrote :

Ok, I hope you don't mind if I add those devices to the desription.

It would be great if you could do an 'lspci' and tell us the output for your bluetooth stick.

Thanks,
Ben ;)

description: updated
Ben Crisford (bencrisford) wrote :

I have just tried sending a picture from my Nokia 5000 to my PC (running jaunty also), this worked in intrepid, but it isn't working now.

I can connect PC> Laptop by 'Browsing files on device' successfully, but if I try sending the file from the phone, unsuccessful.

However, it worked with gnome-obex-server.

This could be a common problem with nokias. If anyone else has a nokia, it would be awesome if you could test it as well. I think we can afford to confirm this, but I would rather check with someone in the know that this is actually a bug.

Regards,
Ben

philipp beitz (philippbeitz) wrote :

lsusb

Bus 002 Device 003: ID 0a12:0001 Cambridge Silicon Radio, Ltd Bluetooth Dongle (HCI mode)

Thanks für updating description.

philipp beitz (philippbeitz) wrote :

i am also able to browse my mobile via bluetooth. sendings files to my PC via bluetooth is not possible.

Ben Crisford (bencrisford) wrote :

Ah ok :).

I am on #bluez (irc.freenode.net) currently waiting for a developer to confirm whether this is in fact a bug.

If it is I will confirm it, as 3 nokias with the same problem is definately reasonable grounds for confirmation in my opinion.

Ben

Ben Crisford (bencrisford) wrote :

I didn't get a reply from the bluez developers yet.

But I think we have dragged this bug report out long enough, so I will confirm it, after all it is a common problem across 3 nokia phones.

If anyone disagrees with me I encourage you to change the status back to 'New' or 'Incomplete', but I think this is worthy of confirmation. After all when a bluez developer does reply we can always change the status back, and it is the decision of a ubuntu-bug-controller whether to triage this or not.

Regards,
Ben

description: updated
Changed in bluez (Ubuntu):
status: Incomplete → Confirmed
philipp beitz (philippbeitz) wrote :

thanks :)

Michael Rooney (mrooney) on 2009-05-13
summary: - cant send files to my PC
+ can no longer send files from nokia phones to PC via bluetooth
tags: added: regression-release

You can add Nokia 6120 classic to the list.

I have the same problem in Hardy as well, though I'm not sure whether it's because of the phone model or because I haven't set bluetooth up correctly.

Ben Crisford (bencrisford) wrote :

Ok Irihapeti :).

I'll add that to the description if you don't mind.

And thanks for replying!

Cheers,
Ben

description: updated
Jane Atkinson (irihapeti) wrote :

Thanks Ben

The relevant line from lsusb is:

Bus 002 Device 002: ID 0a12:0001 Cambridge Silicon Radio, Ltd Bluetooth Dongle (HCI mode)

which is the same as the OP has.

Incidentally, if anyone can tell me what I need to get it working in Hardy, I'd be grateful. I'm ok about applying patches and recompiling if that's what it takes.

Irihapeti

Ben Crisford (bencrisford) wrote :

Bus 002 Device 002: ID 0a5c:2101 Broadcom Corp. A-Link BlueUsbA2 Bluetooth

There is my output by the way.

And Irihapeti: If you need to access files on your device, you can goto bluetooth> browse files on device successfully (for me at least).

Thanks :),
Ben

philipp beitz (philippbeitz) wrote :

This is the corect entry for Ubuntu Hardy. Why its not accesible in Intrepid and Jaunty ?

Jane Atkinson (irihapeti) wrote :

philipp:

Mine is already set up that way, and I still can't send files from the phone to the computer. The phone takes about half a second to decide that it can't do it.

Ben:

Thanks. I'd already discovered that I can browse the phone via bluetooth. Unfortunately, I can't copy files to it using Nautilus (but I can copy *from* the phone with Nautilus). If I use the usb cable, I can copy both ways, but only to the add-on memory card, not the phone's "C drive".

Irihapeti

Fredrik Wendt (fredrik-wendt) wrote :

I can confirm this too (the regression). My better half uses this quite a lot to save images of our kids and this regression is keeping us from updating her laptop to Jaunty (will try the workaround now though).
We use two sets of Bluetooth adapters (I only have access to one where I'm now) and SonyEricsson phone, primarily a W810i.
lsusb output:
  Bus 002 Device 002: ID 0a12:0001 Cambridge Silicon Radio, Ltd Bluetooth Dongle (HCI mode)

Jane Atkinson (irihapeti) wrote :

I now boot into NimbleX 2008 liveCD when I want to transfer files from my phone. It has a fully functioning bluetooth OOTB. Same kernel version as Hardy, I believe. I wonder what they've done differently from Ubuntu to get this to work.

Jane Atkinson (irihapeti) wrote :

Not sure if this is the right place to post this, but I'm finding I've still got the same problem with Karmic (today's image). My Nokia 6120c will not send files to the PC, though it works in the other direction. Same hardware as above.

Jane Atkinson (irihapeti) wrote :

Sorry, I spoke too soon! Installed Blueman, and all seems to work now.

philipp beitz (philippbeitz) wrote :

Now testing Karmic. The same problems resists...

philipp beitz (philippbeitz) wrote :
description: updated
y.zhao (y.zhao) wrote :

to philipp beitz :

have you tried this yet :

Onkar Shinde wrote on 2008-10-09:
Have you enabled 'Receive files over bluetooth' in System -> Preferences -> Personal File Sharing?
The bluetooth stack in intrepid beta was version 3.x. Now it is changed to 4.x as 3.x is not actively maintained upstream.
https://bugs.launchpad.net/ubuntu/+source/bluez-gnome/+bug/280403
-----------------
this solved my problem, as gnome-obex-server is no longer provided by gnome-bluetooth in Karmic.

philipp beitz (philippbeitz) wrote :

Hi Onkar

thanks for reply. Ok its working now. didnt know that you need

gnome-user-share

I dislike the function that you do bluetooth settings via personal file sharing. all bluetooth related settings should be accessible via preferences > bluetooth.

Alexander Sack (asac) wrote :

if this is required in the long run we should install it by default at some point.

summary: - can no longer send files from nokia phones to PC via bluetooth
+ gnome-user-share required to send files from nokia phones to PC via
+ bluetooth
affects: bluez (Ubuntu) → ubuntu-meta (Ubuntu)
Mantas Kriaučiūnas (mantas) wrote :

In Ubuntu 12.04 ubuntu-desktop recommends gnome-bluetooth and gnome-bluetooth recommends gnome-user-share
Maybe this bug can be marked as fixed?

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers