Downgrade "cups" to Recommends:

Bug #302272 reported by Daniel Richard G. on 2008-11-26
60
This bug affects 5 people
Affects Status Importance Assigned to Milestone
edubuntu-meta (Ubuntu)
Undecided
Unassigned
Declined for Lucid by Martin Pitt
kubuntu-meta (Ubuntu)
Low
Unassigned
Declined for Lucid by Martin Pitt
mythbuntu-meta (Ubuntu)
Undecided
Unassigned
Declined for Lucid by Martin Pitt
ubuntu-meta (Ubuntu)
High
Unassigned
Declined for Lucid by Martin Pitt
xubuntu-meta (Ubuntu)
High
Unassigned
Declined for Lucid by Martin Pitt

Bug Description

Binary package hint: ubuntu-desktop

When setting up Ubuntu desktop systems in a corporate/institutional setting that happens to have a central CUPS server and networked printing infrastructure, it is desirable not to have cupsd (and all its associated weight) installed on the desktops, and instead configure cups-client (via /etc/cups/client.conf) to talk directly to the central server.

Why? Ease of administration. The CUPS server is a fairly complex piece of software in its own right, and having one instance of it in a centrally-managed location is complicated enough without having basically the same piece of software running on every desktop. (This was made especially clear to me when I investigated how one sets the default print queue. There are potentially THREE places where this can be done: (1) on the client, in /etc/cups/lpoptions; (2) on the local CUPS server, via "lpadmin -d"; (3) on the central CUPS server. #1 and #3 are reasonable; #2 is just a headache waiting to happen.)

Please downgrade "cups" to a recommendation of the -desktop package, so that the latter can be installed (and retained) sans CUPS server.

Charlie Kravetz (charlie-tca) wrote :

Thanks for reporting this bug and any supporting documentation. Since this bug has enough information provided for a developer to begin work, I'm going to mark it as confirmed for Xubuntu and let them handle it from here. Thanks for taking the time to make Ubuntu better!

Changed in xubuntu-meta:
status: New → Confirmed
importance: Undecided → High
Charlie Kravetz (charlie-tca) wrote :

Thanks for reporting this bug and any supporting documentation. Since this bug has enough information provided for a developer to begin work, I'm going to mark it as confirmed for Ubuntu and let them handle it from here. Thanks for taking the time to make Ubuntu better!

Changed in ubuntu-meta:
importance: Undecided → High
status: New → Confirmed
Charlie Kravetz (charlie-tca) wrote :

Thanks for reporting this bug and any supporting documentation. Since this bug has enough information provided for a developer to begin work, I'm going to mark it as confirmed for Kubuntu and let them handle it from here. Thanks for taking the time to make Ubuntu better!

Changed in kubuntu-meta:
importance: Undecided → High
status: New → Confirmed
Daniel Richard G. (skunk) wrote :

"cups-driver-gutenprint" should also be downgraded to Recommends:, as it itself Depends: on "cups".

Hew McLachlan (hew) wrote :

Still a problem with ubuntu-meta 1.147 on Karmic.

Changed in xubuntu-meta (Ubuntu):
status: Confirmed → Triaged
Changed in xubuntu-meta (Ubuntu):
status: Triaged → Fix Committed
Changed in xubuntu-meta (Ubuntu):
status: Fix Committed → Fix Released
Daniel Richard G. (skunk) wrote :

I see that cups-driver-gutenprint has been moved to desktop-recommends-* in xubuntu-meta, but what about "cups" (the server component) itself? The whole point of this bug report is to get away from installing the server.

Daniel Richard G. (skunk) wrote :

This bug is not yet fixed in xubuntu-meta.

* cups-driver-gutenprint needs to be moved from desktop-hppa to desktop-recommends-hppa

* cups needs to be moved from desktop-* to desktop-recommends-*

At the same time, you may also want to update the obsolete hal-cups-utils entry in desktop-recommends-hppa.

Changed in xubuntu-meta (Ubuntu):
status: Fix Released → Confirmed

cups is in desktop-common and as such is common to all desktops. I've brought this up in #ubuntu-release on IRC so hopefully we'll have action on this after consensus is reached among all the flavors. I imagine no one will object.

Martin Pitt (pitti) wrote :

From the ubuntu desktop team's perspective this is okay for me.

It is indeed a common setup to just have cups-client installed and the server set in /etc/cups/client.conf.

Upstream usually does not recommend this spooler-less operation, but nevertheless it's possible and works.

Harald Sitter (apachelogger) wrote :

All good on Qt side of things (that includes KDE since that uses stock Qt printing magic nowadays),

Changed in mythbuntu-meta (Ubuntu):
status: New → Confirmed
Mario Limonciello (superm1) wrote :

cups isn't used in mythbuntu, marking invalid

Changed in mythbuntu-meta (Ubuntu):
status: Confirmed → Invalid
LaserJock (laserjock) wrote :

Edubuntu is based on Ubuntu and therefore does not depend on cups directly.

Changed in edubuntu-meta (Ubuntu):
status: New → Invalid
Harald Sitter (apachelogger) wrote :

Reducing importance of kubuntu-meta task, since this needs to be fixed in ubuntu-meta first and then merged into kubuntu-meta.

If someone could take action...? :)

Changed in kubuntu-meta (Ubuntu):
importance: High → Low
Daniel Richard G. (skunk) wrote :

cups is still in Depends: in {,k,x}ubuntu-desktop in current Lucid Beta1.

Let's get this one into the LTS, guys. Is there anyone else who needs to sign off on this change?

MarcRandolph (mrand) wrote :

Daniel, this looked simple enough, so I took a stab at it. Please look over the changes in my branch, and if they look complete, feel free to move the ticket to Fix Committed and on the branch, propose it for merging to where-ever it needs to go.

Daniel Richard G. (skunk) wrote :

#$%&@+*!

I double-checked the dependencies, and found a problem.

These three packages, part of desktop-amd64 et al., have Depends: requiring cups:

    foomatic-db
    foomatic-db-engine
    openprinting-ppds

These would have to be moved into Recommends: as well, or else there's no practical effect.

Is that doable, Marc? These appear to be printer drivers, not really useful without the cups server anyway, so I don't think it should be a problem.

MarcRandolph (mrand) wrote :

Daniel, as far as I can tell, you are correct - but that is coming from an unpaid volunteer and not someone experienced with cups, foomatic, or openprinting. I went ahead and updated my branch (and fixed the changes file), so please have a look now. Be my guest if you'd like to propose for merging. I also quickly checked for any other items within desktop that might depend on cups and didn't immedately see any.

Daniel Richard G. (skunk) wrote :

Marc, your changes check out fine on my end. (Good call, by the way, moving foomatic-filters to Recommends: as well.) ubuntu-desktop no longer has a direct nor indirect hard-dependency on cups.

Does anyone listening in on this bug have any objections to moving the Foomatic and OpenPrinting packages? Going once... going twice...

I'll go ahead and propose the merge if no one makes angry noises.

Daniel Richard G. (skunk) wrote :

Well, it appears the merge proposal was rejected because the change has to be made to a seed file, which is what supposedly what the lists in {,k,x}ubuntu-meta are generated from.

As far as I can tell, the necessary change is then to put parentheses (indicating recommendation) around cups, openprinting-ppds and foomatic-* in Lucid's desktop-common file:

    http://people.canonical.com/~ubuntu-archive/seeds/platform.lucid/desktop-common

Marc, do you have any idea how to go about this? I'm a little lost, since this isn't exactly a package that a bug can be filed against.

MarcRandolph (mrand) wrote :

Ok, I took another stab at this. We'll see if this is what they are looking for:
https://code.launchpad.net/~mrand/ubuntu-seeds/platform.lucid/+merge/22567

Daniel Richard G. (skunk) wrote :

Sweet deal, Marc, thanks for that. The maintainer's probably going to want a comment explaining why those packages are only recommended... but then, they'll probably want to rearrange some lines too (i.e. more subjective-type changes, probably better left to them).

Here's hoping....

Martin Pitt (pitti) wrote :

This is fine to merge early in maverick in any case. I'm not a big fan of seed changes that close to lucid's release, though.

Changed in ubuntu-meta (Ubuntu):
status: Confirmed → Triaged
Harald Sitter (apachelogger) wrote :

... Could someone take action? :P

tags: added: oneiric
Martin Pitt (pitti) wrote :

Updated in platform/desktop-common seeds, so all -meta packages should pick that up at the next time they get refreshed.

Changed in ubuntu-meta (Ubuntu):
status: Triaged → Fix Committed
Changed in kubuntu-meta (Ubuntu):
status: Confirmed → Fix Committed
Changed in edubuntu-meta (Ubuntu):
status: Invalid → Fix Committed
Changed in xubuntu-meta (Ubuntu):
status: Confirmed → Fix Committed
Daniel Richard G. (skunk) wrote :

Martin, thanks for committing this. I'll test this out ASAP.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package xubuntu-meta - 2.136

---------------
xubuntu-meta (2.136) oneiric; urgency=low

  * Refreshed dependencies
  * Added gthumb to desktop-recommends
  * Added pastebinit to desktop-recommends
  * Removed accountsservice from desktop
    - This is now recommended by liblightdm-gobject-1-0
  * Moved cups to desktop-recommends (LP: #302272)
  * Moved cups-bsd to desktop-recommends
  * Moved cups-client to desktop-recommends
 -- Micah Gersten <email address hidden> Wed, 10 Aug 2011 03:23:51 -0500

Changed in xubuntu-meta (Ubuntu):
status: Fix Committed → Fix Released
Daniel Richard G. (skunk) wrote :

I'm happy to report that "apt-get install [kx]?ubuntu-desktop cups-" now works on Oneiric! Thanks to everyone who made this happen.

The below four packages are still in Depends:, and are probably not useful in an installation lacking a local printer, but they have a smaller footprint:

    foomatic-db-compressed-ppds
    foomatic-filters
    openprinting-ppds
    pnm2ppa

(Of these, pnm2ppa is the most notable, since it asks debconf questions---which in turn are relevant only to users with certain models of HP printers.)

Changed in kubuntu-meta (Ubuntu):
status: Fix Committed → Fix Released
Martin Pitt (pitti) on 2012-02-23
Changed in ubuntu-meta (Ubuntu):
status: Fix Committed → Fix Released
Changed in edubuntu-meta (Ubuntu):
status: Fix Committed → Fix Released
gb38 (godfried-borremans) wrote :

 pnm2ppa is still in depends on Ubuntu 12.04 LTS precise

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Related blueprints