Intrepid: Alpha 3 aptitude not installed in base installation

Bug #252044 reported by cariboo on 2008-07-26
18
Affects Status Importance Assigned to Milestone
aptitude (Ubuntu)
Undecided
Colin Watson
Intrepid
Undecided
Colin Watson
ubuntu-meta (Ubuntu)
Medium
Colin Watson
Intrepid
Medium
Colin Watson

Bug Description

I tried to use aptitide to install totem-mozilla and and I was told thee was no such program. typing aptitude on the command line it stated that aptitude was not installed and to use apt-get to install it.

Related branches

totya (totya) wrote :

The aptitude package has been part of the base install till Hardy. I think aptitude is better and smarter front end for dpkg than apt-get. Pleas make aptitude a part of the base install!

totya (totya) wrote :

I forget to mention I encountered this on 8.10 Alpha 4

Benjamin Woods (woodsb02-gmail) wrote :

I have also encountered this on Intrepid Alpha 4. Aptitude seems superior to apt-get and has previously been included in Ubuntu base installations. I see no reason to remove it now.

It's yet another nail in the coffin of Ubuntu and "ease of use" I suppose.

I have been a long term Ubuntu user (since Warty), and I have never considered switching to another distribution. The decision to remove aptitude is certainly one way to antagonise people such as myself.

I beg you to reconsider this removal. It really can't use that much space on the CD, and it is the recommended package manager in Debian. Not having it in Intrepid would confuse people.

Harvey Muller (hlmuller) wrote :

Still missing as of the 20080829 amd64 desktop (Alpha 5).

I'm ok with it's removal from base, just be sure to document this on the final Intrepid Ibex information page either in the "New Features" or "Caveats" section. Otherwise you'll have many comments like the above.

There isn't a page available for Alpha 5 yet, you might begin to include that information for testers so they are aware of it. This is the Alpha 4 page:

    http://www.ubuntu.com/testing/intrepid/alpha4

Workaround:

    $ sudo apt-get install aptitude

Colin Watson (cjwatson) wrote :

I've subscribed Martin, who made this change.

revno: 1216
committer: Martin Pitt <email address hidden>
branch nick: platform.intrepid
timestamp: Thu 2008-07-17 11:03:14 +0100
message:
  move aptitude from minimal to supported-sysadmin; not needed by default, and pulls in lots of dependencies

"Not needed by default" is certainly accurate (it hasn't been used by the installer for some time). I haven't assessed its dependencies recently although it's perhaps worth noting that libxapian is now used by synaptic too. I think moving it out of minimal was the right decision (it's valuable for the system produced by debootstrap to be small rather than having lots of nice-to-have packages), but perhaps supported-sysadmin is too far out and we should revisit this.

Bruce, comments such as 'It's yet another nail in the coffin of Ubuntu and "ease of use" I suppose' aren't productive, and only serve to make developers less interested in looking at this bug. I'd appreciate it if you tried to avoid pouring vitriol into bug reports and concentrated on straightforward reasoning instead.

Changed in ubuntu-meta:
importance: Undecided → Medium
status: New → Confirmed
Colin Watson (cjwatson) wrote :

FWIW, since Bruce said he thought it couldn't take up all that much space, I make the space occupied by aptitude somewhere around 1.7MB. Not necessarily infeasible, although it does make it something of a target when we're stretched for an extra couple of megabytes (which is frequently).

Oliver Gerlich (ogerlich) wrote :

Colin: with 1.7MB you mean the space on the installation CD that aptitude uses up? Which packages did you include in that calculation? From my experience, aptitude pulls in stuff like its doc package (which IMHO should only be Suggested, not Recommended); and while libparse-debianchangelog-perl is really useful for aptitude, that package Recommends several other (large) packages which I didn't find necessary so far. If you want to save space, maybe these other packages could be removed first?

Personally, I'd appreciate to have aptitude kept in Ubuntu default installation in the future. It has much better conflict resolution ways than apt-get or Synaptic (also interactively, so the user can decide which Recommended/Suggested packages to install).

If this is added back into the default install, please do not have ubuntu-minimal depend on this, but perhaps a higher-level meta-package.

Fair enough. I'll try to restrain myself in future.

Colin Watson (cjwatson) wrote :

Opening a task on aptitude for the aptitude-doc recommendation.

Colin Watson (cjwatson) wrote :

Oliver: sorry, I forgot to include Recommends in that calculation.

Daniel: indeed so. ubuntu-standard seems appropriate, as mdz also said on -devel.

Colin Watson (cjwatson) wrote :

Fixed for the next ubuntu-meta upload:

revno: 1235
committer: Colin Watson <email address hidden>
branch nick: platform.intrepid
timestamp: Tue 2008-09-02 00:05:26 +0100
message:
  move aptitude back to standard, per mdz on ubuntu-devel (<20080901125407.GI10974@perseus>; LP: #252044)

Changed in ubuntu-meta:
assignee: nobody → kamion
status: Confirmed → Fix Committed
Changed in aptitude:
assignee: nobody → kamion
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package aptitude - 0.4.11.3-1ubuntu2

---------------
aptitude (0.4.11.3-1ubuntu2) intrepid; urgency=low

  * Drop aptitude-doc to Suggests (LP: #252044).

 -- Colin Watson <email address hidden> Tue, 02 Sep 2008 00:09:08 +0100

Changed in aptitude:
status: New → Fix Released

I apologise for my behaviour and thank you for your work.

Colin Watson (cjwatson) wrote :

ubuntu-meta (1.112) intrepid; urgency=low

  * Refreshed dependencies
  * Added aptitude to standard
  * Removed ttf-malayalam-fonts from desktop-recommends
  * Moved gnome-pilot-conduits to desktop-recommends
  * Moved tsclient to desktop-recommends

 -- Daniel Holbach <email address hidden> Tue, 02 Sep 2008 12:05:05 +0200

Changed in ubuntu-meta:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers