Remove diveintopython from default install

Bug #241920 reported by Greg A on 2008-06-21
10
Affects Status Importance Assigned to Milestone
ubuntu-meta (Ubuntu)
Wishlist
Martin Pitt
Intrepid
Wishlist
Martin Pitt

Bug Description

Most users will not need/want a book about python programming in the default install. As far as I can see there is nothing that depends on this that means it should be installed by default.

Related branches

Matthew Woerly (nattgew) wrote :

I agree with this totally. It's a fairly significant size. It should at least be linked from the Ubuntu menu somewhere, or otherwise made more accessible.

Changed in ubuntu-meta:
importance: Undecided → Wishlist
status: New → Confirmed
Dereck Wonnacott (dereck) wrote :

Could you please tell me where this ebook is located after installation? I'm not aware of it's presence.

Changed in ubuntu-meta:
assignee: nobody → dereck
status: Confirmed → Incomplete
Dereck Wonnacott (dereck) wrote :

Silly me, I found it in the package diveintopython ironically enough! It is pulled in as a depend of ubuntu-desktop.

I don't have any clue why however, seems like a waist of a little over 4 megabytes to me. :P

Changed in ubuntu-meta:
status: Incomplete → Triaged
Changed in ubuntu-meta:
assignee: dereck → nobody
Dereck Wonnacott (dereck) wrote :

To quote an e-mail from Mark on ubuntu-desktop@:

+1 to removing it. It's there because I very much wanted to promote Python as a ubiquitous scripting language across Ubuntu. Initially we included Python interfaces for as much of the system as we could. I think that has been eroded over time given the pressures of disk space and the focus on non-developer users to the point where D-I-P is unnecessary.

Changed in ubuntu-meta:
assignee: nobody → ubuntu-release
assignee: ubuntu-release → nobody
Dereck Wonnacott (dereck) wrote :

How cool it would be to have this applied. :)

In any case it is a trivial patch to remove diveintopython from the desktop-recommends seeds.

Colin Watson (cjwatson) wrote :

Note that ubuntu-meta is automatically generated from seeds and must not be patched directly.

Colin Watson (cjwatson) wrote :

(It's trivial either way of course, and I'll see if we can squeeze this into Intrepid; either way I'm happy to take care of the seed change.)

Martin Pitt (pitti) wrote :

Seeds updated. Will do ubuntu-meta rebuild ASAP.

Changed in ubuntu-meta:
assignee: nobody → pitti
status: Triaged → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubuntu-meta - 1.123

---------------
ubuntu-meta (1.123) intrepid; urgency=low

  * Refreshed dependencies
  * Removed diveintopython from desktop-recommends (LP: #241920)

 -- Martin Pitt <email address hidden> Fri, 24 Oct 2008 10:45:57 +0200

Changed in ubuntu-meta:
status: Fix Committed → Fix Released
Tina Russell (tinarussell) wrote :

I would like to say one more thing... whether or not it’s a 4MB monster like DIP, I hope we can have some kind of beginning Python document or tutorial in the help files. I really enjoyed the fact that, in the Ubuntu help browser, “writing your own programs” is listed under “advanced topics.” My hope would be that kids who are first trying out Ubuntu might be curious enough to play around with programming and it could change their lives (or at least give them a valuable skill). Also, people who wouldn’t know they like programming may find themselves more inclined to do simple projects (at least in Python).

Obviously, DIP meets neither goal since it’s already something for experienced programmers. But, if we could have some Python documentation there, showing you how to play with the interpreter and make your first program (and introducing functions, classes, loops, etc.), that would make me very happy. Internet references would be good, too, of course, but the documentation would have to contain enough so that a user in a remote village in Bangladesh could be on their way to being a Python pro before they can get to the nearest net café to learn more. That’s my 0.02 taka, anyway ;)

IT skill is so important to social mobility these days that I think this fits well into the idealistic nature of Ubuntu.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers