ubuntu-desktop recommends linux-headers-generic

Bug #235327 reported by lucatrv on 2008-05-27
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
ubuntu-meta (Ubuntu)
Wishlist
Unassigned

Bug Description

ubuntu-desktop should not recommend linux-headers-generic, since not everyone use that kernel.
For instance, since I run ubuntu inside a vmware virtual machine, I use the linux-virtual kernel instead of the linux-generic kernel. So for me the linux-headers-generic package is useless, and should be substituted with the linux-headers-virtual package.
I think ubuntu-desktop should recommend ONE among linux-headers-* packages (which could be for instance linux-headers-generic, linux-headers-virtual, linux-headers-server, linux-headers-xen and so on...)
In other words, installing either of these packages should satisfy the ubuntu-desktop recommendation.

Dimitrios Symeonidis (azimout) wrote :

sorry for the delayed response, lucatrv
marking as confirmed...

Changed in ubuntu-meta:
status: New → Confirmed
Dimitrios Symeonidis (azimout) wrote :

another solution would be to make ubuntu-desktop depend on linux-headers, the virtual package.

Package: linux-headers
State: not a real package
Provided by: linux-headers-2.6.27-3-rt, linux-headers-2.6.27-7,
             linux-headers-2.6.27-7-generic, linux-headers-2.6.27-7-server,
             linux-ports-headers-2.6.25-2

and linux-headers should probably be provided also by:
linux-headers-virtual linux-headers-server linux-headers-rt linux-headers-generic

maybe someone with more experience could give an opinion?

lucatrv (lucatrv) wrote :

Yes, that would be a good solution IMHO.

Dimitrios Symeonidis (azimout) wrote :

marking as triaged-wishlist
let's see what the developers think

Changed in ubuntu-meta:
importance: Undecided → Wishlist
status: Confirmed → Triaged
lucatrv (lucatrv) wrote :

I thought of another possibility. In my opinion the cleaner solution would be that ubuntu-desktop doesn't recommend any linux-headers-*, while each linux-* kernel package itself recommends the appropriate linux-headers-* (so for instance linux-generic recommends linux-headers-generic and so on). In fact, I think the linux-headers should be recommandable even in a system without a desktop installed...

Mathew Hodson (mathew-hodson) wrote :

ubuntu-desktop does not recommend linux-headers-generic since at least trusty.

Changed in ubuntu-meta (Ubuntu):
status: Triaged → Fix Released
lucatrv (lucatrv) wrote :

Ok, thanks for the notice, I confirm that the issue regarding the "linux-headers-*" packages is fixed.
The only glitch now is that "linux-image-*" packages are not required by other packages. In my opinion the metapackage "ubuntu-minimal" should depend on the virtual package "linux-image", ensuring that at least one of the "linux-image-*" packages is installed.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers