Icon themes don't work properly

Bug #219446 reported by Fabio on 2008-04-19
6
Affects Status Importance Assigned to Milestone
ubuntu-meta (Ubuntu)
Undecided
Unassigned

Bug Description

This was reported by others regarding the glass icon theme, but I noticed the problem is not exclusive to that theme but to several others I tried. When installing some icon themes, some icons get updated and other just reflect back to the default gnome theme. I first thought image type could have something to do, since the glass theme uses a different image type than other themes that worked (svg instead of png) but I found the some problems with other themes that use png too.

That is a bug with the individual icon theme, and should be filed against the theme.

When an icon theme isn't complete, it falls back to gnome to fill the missing icons. The theme can specify a different fall back and should probably use something closer to it's style.

morryis (morryis) wrote :

Actually, I don't think these many different icon themes are incomplete, because they all worked for me befor I upgraded to Hardy. So i guess, that something in Hardy must have changed. It has nothing to do with fall back!
Especially these icons related to folders, drives etc. are not working. Application icons and mime-type icons do work.
I installed 7 icon-sets from the official ubuntu repositories. Except 'gartoon', they are all not working properly, means the icons for folders and drives are not changed!

gnome-icon-theme-blankon (1.0-2)
gnome-icon-theme-dlg-neu (0.5-2)
gnome-icon-theme-gperfection2 (2.3-0ubuntu3)
gnome-icon-theme-nuovo (0.5-2)
gnome-icon-theme-suede (0.2.5-1)
gnome-icon-theme-yasis (0.4.2-1)

gnome-icon-theme-gartoon (0.5-4ubuntu2) (working!)

And there are many more not working from art.gnome or gnome-look

Should we file a bug-report against them all?

frog_pilot (mpilot) wrote :

I can confirm this behavior for many Icon-themes. Especially those with only one scalable-folder. Only these ones with the whole icon-set in all possible sizes as png-files are working properly. Seems that Hardy or gnome 2.22 isn't looking for all the icon-locations as the older versions

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers