USB storage fails to automount

Bug #216483 reported by Ryan Hamilton on 2008-04-12
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
GNOME media utilities
Invalid
Undecided
Unassigned
hal (Ubuntu)
Undecided
Unassigned
ubuntu-meta (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: hal

I can not get any kind of USB storage to automount anymore, and I don't know why. This seems to be a common problem, but one that the solutions suggested elsewhere have not worked. I have tried my three USB thumbdrives, in addition to my USB external hard drive all without success.

The drives show up properly in the File Browser, but double-clicking fails without any sort of indication, and right-click and then clicking Mount also fails silently. They show up in /dev/sd*, but do not make it any further. I can confirm that I can mount them manually by

sudo mkdir /media/usbthing
mount /dev/sdf1 /media/usbthing

but this mounts the drive as writable for sudo only, which is a big pain, and really annoying for a friend who I switched to Ubuntu who has the same issue (although on an x32 box, my home machine is x64). I have tried reinstalling HAL, have tried to remove (and then re-add) "usbfree" from the gconf-config volume settings, as well as checking the USB drives for errors in both Windows and Ubuntu, as well as making sure that the drive is properly removed from a Windows machine. Even rebooting with the drive plugged in doesn't work anymore, it still shows up in File Browser but it's the same as if I had just plugged it in.

Outputs requested:
id
uid=1000(rthamilt) gid=1000(rthamilt) groups=4(adm),20(dialout),24(cdrom),25(floppy),29(audio),30(dip),44(video),46(plugdev),104(scanner),108(lpadmin),110(admin),115(netdev),117(powerdev),1000(rthamilt)

id hal
id: hal: No such user

id haldaemon
uid=107(haldaemon) gid=116(haldaemon) groups=116(haldaemon),24(cdrom),25(floppy),46(plugdev),117(powerdev)

uname -a
Linux HomeBox 2.6.22-14-generic #1 SMP Tue Feb 12 02:46:46 UTC 2008 x86_64 GNU/Linux

Attached are the additional outputs from the RemovableStorage bug guide. Thanks for anyone's assistance!

Ryan Hamilton (rthamilt) wrote :
Ryan Hamilton (rthamilt) wrote :
Ryan Hamilton (rthamilt) wrote :
Ryan Hamilton (rthamilt) wrote :
Ryan Hamilton (rthamilt) wrote :
Ryan Hamilton (rthamilt) wrote :
Ryan Hamilton (rthamilt) wrote :
Ryan Hamilton (rthamilt) on 2008-04-13
description: updated
defishguy (mkfischer) wrote :

I can confirm this bug. I found a problem with fstab after a fresh install of HH 8.04. A CD Rom drive was being mapped in fstab to /dev/sdb1 inappropriately.

To check and see if this is happening to you type:

sudo gedit /etc/fstab

If you see the last two lines looking like this:

/dev/sdb1 /media/cdrom0 udf,iso9660 user,noauto,exec,utf8 0 0
/dev/scd0 /media/cdrom1 udf,iso9660 user,noauto,exec,utf8 0 0

The solution is to comment out the line that begins /dev/sdb1 and change the mount point like so

#/dev/sdb1 /media/cdrom0 udf,iso9660 user,noauto,exec,utf8 0 0
/dev/scd0 /media/cdrom0 udf,iso9660 user,noauto,exec,utf8 0 0

Save fstab and reboot your computer. I have tested this on my own machine and the CDRom still works and USB drives will mount normally after the changes.

Good luck and I hope this helps.

Ryan Hamilton (rthamilt) wrote :

That doesn't seem to be the problem with me, unfortunately. I checked /etc/fstab, and I do not have any duplicate entries like you mentioned.

mash (mash-econs) wrote :

I am having this problem as well since I upgraded to ubuntu 8.04.

I have several USB storage devices (LaCie 1.5TB external hard drives, several usb flash pen-drives) and they do not automount after the upgrade from 7.10 to 8.04. I can mount them from the command line with 'sudo mount ...' but it would be nice to have them automount when I connect the drives.

dmesg reports the connection and the drives are assigned devices, e.g., sg5, but no mount w/o a command-line 'mount'

Izzy (izzy-qumran) wrote :

@mash:
Did you check your /etc/fstab if it has corresponding entries? These should *not* have "noauto" in if you want the drives to mount automatically. I never tested this, but probably with proper fstab entries they should be handled as on boot when connected.

Well: That was much easier on Feisty - there they did this automatically when there have been no corresponding entries in /etc/fstab stating a different behavior. But I guess then users asked how to turn this OFF...

Ryan Hamilton (rthamilt) wrote :

That was one of the things I checked, but it never *got* to /etc/fstab or any the related ones. It was borking up somewhere way before that, and I don't think there was any consensus as to what was going on. I could have entered the /etc/fstab entry by hand, but honestly, what use is that? The whole point of thumb drives and the like for me is that I can plug them in, use them, and pull them out with a minimum amount of hassle. Anything else necessary to get them to work is just a pain and a problem.

As of now this particular problem is not present for me in Ubuntu 8.04, but it is a clean install and not an upgrade (sorry mash), since by that point the previous install had gotten to be such a terrible mess that I had to kill it all and start from scratch with a fresh install. I haven't had a successful upgrade yet (out of 4) actually, and even a catastrophic one (Xubuntu7.10 -> 8.04).

Izzy (izzy-qumran) wrote :

@mash and @Ryan: You might want to have a look at bug #224085 (this bug here in fact may be considered a duplicate of that). Probably the things suggested there will help you as well. For me (and some others) on KDE, it helped to just add

  <!-- modification in order to KDE users can mount -->
  <policy group="plugdev">
     <allow send_interface="org.freedesktop.Hal.Device.Volume"/>
     <allow send_interface="org.freedesktop.Hal.Device.Volume.Crypto"/>
  </policy>

to the end of /etc/dbus-1/system.d/hal.conf (right before the </busconfig>). Check the output of the "id" command to make sure you are member of the "plugdev" group (Ryan is according to his initial post).

Fabien (fabien-ubuntu) wrote :

Try that :
 sudo /var/lib/dpkg/info/dbus.postinst configure

then restart the computer

Dimitrios Symeonidis (azimout) wrote :

Ryan, is this still an issue for you?

Can you please attach /etc/fstab?
Also, the outputs of "sudo fdisk -l" and of "mount" with a usb stick plugged-in?

Thank you

Dimitrios Symeonidis (azimout) wrote :

probably hal-related, marking as invalid in ubuntu-meta

Changed in ubuntu-meta:
status: New → Invalid
Dimitrios Symeonidis (azimout) wrote :

nothing to do with gnome-media, marking as invalid

Changed in gnome-media:
status: New → Invalid
Dimitrios Symeonidis (azimout) wrote :

waiting for user's answer, marking as incomplete until then...

Changed in hal:
status: New → Incomplete
Ryan Hamilton (rthamilt) wrote :

It was never resolved in Ubuntu 7.10, but a complete reinstall of Ubuntu 8.04 "fixed" it for me. I don't have a 7.10 install anymore, so I can't reproduce this. I haven't had trouble since moving to 8.04, but I can't speak for mash above.

J C Nash (nashjc) wrote :

I'm using 8.04 and getting a mount failure when my USB scanner (a Canon LiDE 60) is plugged in. Goes away when it is not there. lsusb sees the flash devices, but doesn't mount them.

Seems like some sort of conflict. I've searched for messages about this, but seem to be finding only complaints about automount. Perhaps those are device conflicts too.

JN

Launchpad Janitor (janitor) wrote :

[Expired for hal (Ubuntu) because there has been no activity for 60 days.]

Changed in hal (Ubuntu):
status: Incomplete → Expired
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers