gnome-pilot shouldn't be a dependency of ubuntu-desktop

Bug #201676 reported by komputes on 2008-03-13
16
This bug affects 1 person
Affects Status Importance Assigned to Milestone
One Hundred Papercuts
Undecided
Unassigned
ubuntu-meta (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: gnome-pilot

gnome-pilot alows you to use your palm device on ubuntu.

ubuntu-desktop is used to carry out certain upgrade transitions (such as adding new packages to the system).

I try to remove gnome-pilot and ubuntu-desktop must be removed with it. I try reinstalling ubuntu-desktop, and gnome-pilot (and a list of unwanted software) wants to come back onto my desktop.

If ubuntu-desktop is needed in distro upgrades, why not make it exclusive/seperated from all these small applications/applets.

Jared (jared-vanvolkenburg) wrote :

I am also trying to remove the Palm Pilot support from my system. I am using 8.04. I am unable to do so using the Add / Remove Applications and using the Synaptic Package Manager to remove it, requires me to remove ubuntu-desktop, which warns you not to remove it.

1. The palm pilot support should not be dependent on the desktop. It should be an accessory add on, and easy to remove, or not installed by default.

2. If an application appears in the Add / Remove Applications the user should be able to remove it through there, without having to go into Synaptic Package Manger and searching to find the individual packages that may or may not be the correct packages to remove. This may seem easy for advanced users, but not for the common user. If Ubuntu is to be used by the 'everyman' and rolled out on Dell desktops, etc, adding and removing programs using the Add / Remove Application utility should be easier. (This may be a separate bug)

  • unnamed Edit (2.4 KiB, text/html; charset=iso-8859-1)

Why do you want to remove it? I think it 's part of the OS. If you don't want to use it just remove your Palm ID from pilot.
HLV

Jared <email address hidden> wrote: I am also trying to remove the Palm Pilot support from my system. I am
using 8.04. I am unable to do so using the Add / Remove Applications
and using the Synaptic Package Manager to remove it, requires me to
remove ubuntu-desktop, which warns you not to remove it.

1. The palm pilot support should not be dependent on the desktop. It
should be an accessory add on, and easy to remove, or not installed by
default.

2. If an application appears in the Add / Remove Applications the user
should be able to remove it through there, without having to go into
Synaptic Package Manger and searching to find the individual packages
that may or may not be the correct packages to remove. This may seem
easy for advanced users, but not for the common user. If Ubuntu is to
be used by the 'everyman' and rolled out on Dell desktops, etc, adding
and removing programs using the Add / Remove Application utility should
be easier. (This may be a separate bug)

--
gnome-pilot and ubuntu-desktop
https://bugs.launchpad.net/bugs/201676
You received this bug notification because you are a member of Ubuntu
PDA team, which is subscribed to gnome-pilot in ubuntu.

Status in Source Package "gnome-pilot" in Ubuntu: New

Bug description:
Binary package hint: gnome-pilot

gnome-pilot alows you to use your palm device on ubuntu.

ubuntu-desktop is used to carry out certain upgrade transitions (such as adding new packages to the system).

I try to remove gnome-pilot and ubuntu-desktop must be removed with it. I try reinstalling ubuntu-desktop, and gnome-pilot (and a list of unwanted software) wants to come back onto my desktop.

If ubuntu-desktop is needed in distro upgrades, why not make it exclusive/seperated from all these small applications/applets.

---------------------------------
Be a better friend, newshound, and know-it-all with Yahoo! Mobile. Try it now.

Yes I totally agree with you. It should be possible to remove / replace every application without the need to remove ubuntu-desktop. Or at least reduce the requirements of applications for ubuntu-desktop to a limit, like gnome (minimal-desktop + update-manager etc. without firefox/Evolution/ etc.) .

Would make a big difference for customization.

Changed in gnome-pilot:
status: New → Confirmed
Steve Langasek (vorlon) wrote :

It appears to me that dropping gnome-pilot from a Depends to a Recommends would be consistent with our handling of other hardware-specific packages, such as hplip, bluez-utils, and wvdial. Reassigning to the ubuntu-meta package, since that's where the change has to be made.

gnome-pilot isn't directly a dependency of ubuntu-desktop: ubuntu-desktop depends on gnome-pilot-conduits that, in turns, depends on gnome-pilot.

As of Intrepid, gnome-pilot-conduits was demoted from dependency to recomended dependency in ubuntu-desktop, but PalmOS Devices cannot be removed using gnome-app-install; Why?
Because PalmOS Devices (that is, an application in gnome-app-install) refers to gnome-pilot; but gnome-pilot is a dependency of gnome-pilot-conduits that, in turns, is a recomended dependency of ubuntu-desktop; so, software depends on PalmOS Devices and it cannot be removed (in gnome-app-install).

Some options to fix this:
1. replace the recomended dependency of gnome-pilot-conduits in ubuntu-desktop with gnome-pilot;
or
2. make the PalmOS Devices application refers to gnome-pilot-conduits instead of gnome-pilot.

I agree with previous comments - there is no reason why PalmOS Devices should be tied so closely to gnome-desktop. gnome-desktop is a core package and PalmOS is (should be) an optional one.

In fact, I firmly believe that PalmOS support should be completely optional and not installed by default - after all, how many Ubuntu users have a Palm device? Less than 10%?

PalmOS installed by default is bloat that most users could do without.

I've added this to one hundred papercuts project since it's trivial, impacts average user first-time experience and because solutions are already given.

summary: - gnome-pilot and ubuntu-desktop
+ gnome-pilot shouldn't be a dependency of ubuntu-desktop
Patrick (veinor) on 2009-10-03
Changed in hundredpapercuts:
status: New → Confirmed

As of ubuntu-desktop 1.172 (Karmic fully updated), nor gnome-pilot neither gnome-pilot-conduits are dependency of ubuntu-desktop.
Can this bug be marked as "Fix Released"?

komputes (komputes) wrote :

Once we check the Desktop CD and standard desktop install do not contain gnome-pilot, I think we can mark this as fixed.

Steve Langasek (vorlon) wrote :

No, this bug report was about whether gnome-pilot could be removed from the desktop, not about whether it was included by default. It is still included by default, but removing it doesn't remove ubuntu-desktop. So this bug is fixed.

Changed in ubuntu-meta (Ubuntu):
status: Confirmed → Fix Released
Steve Langasek (vorlon) wrote :

And marking the hundredpapercuts task as invalid. Papercuts bugs are defined as those that have a significant impact on the experience of most users and are trivial to fix. Most users don't care whether this software can be removed from their system.

Changed in hundredpapercuts:
status: Confirmed → Invalid

In my opinion that latter issue (should Palm Pilot support be included by default) is still a valid one.

After all, what percentage of Ubuntu users actually use a Palm Pilot? I would be willing to bet it's less than 5%. Should the other 95% have to manually uninstall the package, or does it infact make sense to remove this from the default package list and save a bit of disk space?

Don't get me wrong; if the package survey shows a large proportion of users actually _want_ this package, then, sure, it should be default, but I seriously doubt it will.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments