[hardy] hotkey-setup should be removed (obsoleted by hal)

Bug #185725 reported by Bogdan Butnaru on 2008-01-24
8
Affects Status Importance Assigned to Milestone
ubuntu-meta (Ubuntu)
Wishlist
Unassigned

Bug Description

Binary package hint: ubuntu-desktop

Package ubuntu-desktop depends on hotkey-setup. However, hotkey-setup should have been technically obsoleted by HAL.

If there's anything it does that /usr/share/hal/fdi/information/ doesn't do, the info should be migrated there. In any case, the dependency on it should be removed from ubuntu-desktop. This will at least allow us to notice if anything's missing from HAL. (Although it should be possible to check and migrate everything semi-automatically.)

This is important because we have such an impossibly large number of applications that mess with keyboard settings that it's next to impossible to track bugs when they appear. Everything that's obsolete should be removed from the dependencies, allowing us to debug the new ones.

Colin Watson (cjwatson) wrote :

Matthew, Paul: can you comment on whether this is feasible today? Any core developer can remove it from the platform.hardy seeds if they determine it's reasonable. I would like to ensure that an audit is in place so that we don't lose support by accident; testing is a long and laborious process when auditing the code will do.

Dimitrios Symeonidis (azimout) wrote :

there has not been activity on this bug for months... what are we going to do about it?

Changed in ubuntu-meta:
importance: Undecided → Wishlist

Marking as Incomplete because of question #2.

Changed in ubuntu-meta (Ubuntu):
status: New → Incomplete
Launchpad Janitor (janitor) wrote :

[Expired for ubuntu-meta (Ubuntu) because there has been no activity for 60 days.]

Changed in ubuntu-meta (Ubuntu):
status: Incomplete → Expired
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers