[FFE][SRU] Please add ubuntu-wsl binary package

Bug #1822341 reported by Balint Reczey on 2019-03-29
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
ubuntu-meta (Ubuntu)
Undecided
Unassigned
Xenial
Undecided
Unassigned
Bionic
Undecided
Unassigned
Cosmic
Undecided
Unassigned

Bug Description

[Impact]
* The newly added wsl seed includes the packages to be installed by default on Ubuntu running in the Windows Subsystem for Linux. In addition to the packages in ubuntu-minimal the added ubuntu-wsl metapackage depends on on utilities useful only in the WSL environment.

[Test Case]
* The package is a new metapackage, just try installing it

[Fix]
* The change add the new package and also adds the wsl seed to watch.

[Regression potential]
* Nothing, it is a new meta package, with no breaks, etc.

[Other Info]
* Please consider accepting this new binary package to Disco, because it needs to be SRU-d to all supported releases. The ubuntu-wsl metapackage will allow adding new packages for WSL installations only when more integration utilities become available.

Balint Reczey (rbalint) wrote :
Balint Reczey (rbalint) wrote :

The attached patch also include updates from the current seed, and was artificially crafted because until ubuntu-meta package does not exist in the archive germinate does not pick it from the seed, hence does not include the packages contained through the minimal seed.

Balint Reczey (rbalint) wrote :

Build log:
$ dpkg-buildpackage
dpkg-buildpackage: info: source package ubuntu-meta
dpkg-buildpackage: info: source version 1.431
dpkg-buildpackage: info: source distribution disco
dpkg-buildpackage: info: source changed by Balint Reczey <email address hidden>
dpkg-buildpackage: info: host architecture amd64
 dpkg-source --before-build .
 fakeroot debian/rules clean
dh clean --with germinate
   dh_germinate_clean
   dh_clean
 dpkg-source -b .
dpkg-source: info: using source format '3.0 (native)'
dpkg-source: info: building ubuntu-meta in ubuntu-meta_1.431.tar.xz
dpkg-source: info: building ubuntu-meta in ubuntu-meta_1.431.dsc
 debian/rules build
dh build --with germinate
   dh_update_autotools_config
   dh_autoreconf
   create-stamp debian/debhelper-build-stamp
 fakeroot debian/rules binary
dh binary --with germinate
   dh_testroot
   dh_prep
   dh_installdocs
   dh_installchangelogs
   dh_perl
   dh_link
   dh_strip_nondeterminism
   dh_compress
   dh_fixperms
   dh_missing
   dh_strip
   dh_makeshlibs
   dh_shlibdeps
   dh_germinate_metapackage
   dh_installdeb
   dh_gencontrol
   dh_md5sums
   dh_builddeb
dpkg-deb: building package 'ubuntu-minimal' in '../ubuntu-minimal_1.431_amd64.deb'.
dpkg-deb: building package 'ubuntu-server' in '../ubuntu-server_1.431_amd64.deb'.
dpkg-deb: building package 'ubuntu-desktop-minimal' in '../ubuntu-desktop-minimal_1.431_amd64.deb'.
dpkg-deb: building package 'ubuntu-standard' in '../ubuntu-standard_1.431_amd64.deb'.
dpkg-deb: building package 'ubuntu-wsl' in '../ubuntu-wsl_1.431_amd64.deb'.
dpkg-deb: building package 'ubuntu-desktop' in '../ubuntu-desktop_1.431_amd64.deb'.

Install log:
$ sudo apt install ../ubuntu-wsl_1.431_amd64.deb
Reading package lists... Done
Building dependency tree
Reading state information... Done
Note, selecting 'ubuntu-wsl' instead of '../ubuntu-wsl_1.431_amd64.deb'
The following additional packages will be installed:
  wslu
The following NEW packages will be installed:
  ubuntu-wsl wslu
0 upgraded, 2 newly installed, 0 to remove and 62 not upgraded.
Need to get 42.2 kB/87.1 kB of archives.
After this operation, 258 kB of additional disk space will be used.
Do you want to continue? [Y/n]
Get:1 /home/rbalint/ubuntu-wsl_1.431_amd64.deb ubuntu-wsl amd64 1.431 [44.9 kB]
Get:2 http://at.archive.ubuntu.com/ubuntu disco/main amd64 wslu all 2.0.0-0ubuntu2 [42.2 kB]
Fetched 42.2 kB in 0s (174 kB/s)
Selecting previously unselected package wslu.
(Reading database ... 242784 files and directories currently installed.)
Preparing to unpack .../wslu_2.0.0-0ubuntu2_all.deb ...
Unpacking wslu (2.0.0-0ubuntu2) ...
Selecting previously unselected package ubuntu-wsl.
Preparing to unpack .../ubuntu-wsl_1.431_amd64.deb ...
Unpacking ubuntu-wsl (1.431) ...
Setting up wslu (2.0.0-0ubuntu2) ...
Setting up ubuntu-wsl (1.431) ...
Processing triggers for man-db (2.8.5-2) ...

The binary package is new and does not break any other package.

Balint Reczey (rbalint) wrote :
summary: - [FFE] Please add ubuntu-wsl binary package
+ [FFE][SRU] Please add ubuntu-wsl binary package
Balint Reczey (rbalint) on 2019-03-29
description: updated
tags: added: id-5be3256b704279166ce21e99
Adam Conrad (adconrad) wrote :

This hand-crafted patch is wrong. The way the seeds are laid out, ubuntu-wsl should depend on exactly one package, not dozens. STRUCTURE is not an include hierarchy (if it was, all of minimal would be in desktop, for instance), it describes inheritance. "wsl: minimal" means "if it's in minimal, don't include it in wsl, so I don't have the same packages listed twice". wsl installs should install minimal (as *all* Ubuntu installations do) and ubuntu-wsl.

Balint Reczey (rbalint) wrote :

@adconrad Thank, I update the seed changes and the package accordingly.
Can the refresh and the ubuntu-wsl metapackage depending only on wslu get the ffe?

Balint Reczey (rbalint) wrote :

Fixed, still handcrafted patch.

Steve Langasek (vorlon) wrote :

FFe approved.

Changed in ubuntu-meta (Ubuntu):
status: New → Triaged
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubuntu-meta - 1.431

---------------
ubuntu-meta (1.431) disco; urgency=medium

  * Refreshed dependencies
  * Added multipath-tools to server
  * Added thunderbird to desktop-recommends [s390x]
  * Added thunderbird-gnome-support to desktop-recommends [s390x]
  * Added ubuntu-wsl binary package depending on wslu (LP: #1822341)

 -- Balint Reczey <email address hidden> Mon, 01 Apr 2019 12:38:30 +0200

Changed in ubuntu-meta (Ubuntu):
status: Triaged → Fix Released

Hello Balint, or anyone else affected,

Accepted ubuntu-meta into cosmic-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/ubuntu-meta/1.425.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-cosmic to verification-done-cosmic. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-cosmic. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

Changed in ubuntu-meta (Ubuntu Cosmic):
status: New → Fix Committed
tags: added: verification-needed verification-needed-cosmic
Changed in ubuntu-meta (Ubuntu Bionic):
status: New → Fix Committed
tags: added: verification-needed-bionic
Timo Aaltonen (tjaalton) wrote :

Hello Balint, or anyone else affected,

Accepted ubuntu-meta into bionic-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/ubuntu-meta/1.417.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-bionic to verification-done-bionic. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-bionic. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

Changed in ubuntu-meta (Ubuntu Xenial):
status: New → Fix Committed
tags: added: verification-needed-xenial
Timo Aaltonen (tjaalton) wrote :

Hello Balint, or anyone else affected,

Accepted ubuntu-meta into xenial-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/ubuntu-meta/1.361.3 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-xenial to verification-done-xenial. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-xenial. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

Balint Reczey (rbalint) wrote :

Tested ubuntu-wsl 1.425.1 on Cosmic.

root@c-wsl:~# apt install ubuntu-wsl
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following package was automatically installed and is no longer required:
  libfreetype6
Use 'apt autoremove' to remove it.
The following additional packages will be installed:
  wslu
Suggested packages:
  imagemagick
The following NEW packages will be installed:
  ubuntu-wsl wslu
0 upgraded, 2 newly installed, 0 to remove and 39 not upgraded.
Need to get 44.9 kB of archives.
After this operation, 257 kB of additional disk space will be used.
Do you want to continue? [Y/n]
Get:1 http://archive.ubuntu.com/ubuntu cosmic-updates/main amd64 wslu all 2.0.0-0ubuntu2~18.10.0 [42.3 kB]
Get:2 http://archive.ubuntu.com/ubuntu cosmic-proposed/main amd64 ubuntu-wsl amd64 1.425.1 [2620 B]
Fetched 44.9 kB in 0s (118 kB/s)
Selecting previously unselected package wslu.
(Reading database ... 28284 files and directories currently installed.)
Preparing to unpack .../wslu_2.0.0-0ubuntu2~18.10.0_all.deb ...
Unpacking wslu (2.0.0-0ubuntu2~18.10.0) ...
Selecting previously unselected package ubuntu-wsl.
Preparing to unpack .../ubuntu-wsl_1.425.1_amd64.deb ...
Unpacking ubuntu-wsl (1.425.1) ...
Setting up wslu (2.0.0-0ubuntu2~18.10.0) ...
update-alternatives: using /usr/bin/wslview to provide /usr/bin/x-www-browser (x-www-browser) in auto mode
Setting up ubuntu-wsl (1.425.1) ...
Processing triggers for man-db (2.8.4-2) ...
root@c-wsl:~#

Balint Reczey (rbalint) wrote :

Verified 1.417.1 on Bionic:

root@b-wsl:~# apt install ubuntu-wsl
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following package was automatically installed and is no longer required:
  libfreetype6
Use 'apt autoremove' to remove it.
The following additional packages will be installed:
  wslu
Suggested packages:
  imagemagick
The following NEW packages will be installed:
  ubuntu-wsl wslu
0 upgraded, 2 newly installed, 0 to remove and 3 not upgraded.
Need to get 44.8 kB of archives.
After this operation, 256 kB of additional disk space will be used.
Do you want to continue? [Y/n]
Get:1 http://archive.ubuntu.com/ubuntu bionic-updates/main amd64 wslu all 2.0.0-0ubuntu2~18.04.0 [42.3 kB]
Get:2 http://archive.ubuntu.com/ubuntu bionic-proposed/main amd64 ubuntu-wsl amd64 1.417.1 [2448 B]
Fetched 44.8 kB in 0s (207 kB/s)
Selecting previously unselected package wslu.
(Reading database ... 28631 files and directories currently installed.)
Preparing to unpack .../wslu_2.0.0-0ubuntu2~18.04.0_all.deb ...
Unpacking wslu (2.0.0-0ubuntu2~18.04.0) ...
Selecting previously unselected package ubuntu-wsl.
Preparing to unpack .../ubuntu-wsl_1.417.1_amd64.deb ...
Unpacking ubuntu-wsl (1.417.1) ...
Setting up wslu (2.0.0-0ubuntu2~18.04.0) ...
update-alternatives: using /usr/bin/wslview to provide /usr/bin/x-www-browser (x-www-browser) in auto mode
Setting up ubuntu-wsl (1.417.1) ...
Processing triggers for man-db (2.8.3-2ubuntu0.1) ...
root@b-wsl:~# apt-cache show ubuntu-wsl
Package: ubuntu-wsl
Architecture: amd64
Version: 1.417.1
Priority: optional
Section: metapackages
Source: ubuntu-meta
Origin: Ubuntu
Maintainer: Ubuntu Developers <email address hidden>
Bugs: https://bugs.launchpad.net/ubuntu/+filebug
Installed-Size: 47
Depends: wslu
Filename: pool/main/u/ubuntu-meta/ubuntu-wsl_1.417.1_amd64.deb
Size: 2448
MD5sum: 4e3c81855b806702a7cb99690c0999e5
SHA1: 23838fd8a2b268499baabb89bb8742a88fa00d35
SHA256: a4525f5fee12f9febdf9f71d10edb03ed8e749319f3cd411cb8e10536dbd2896
Description-en: Ubuntu on Windows tools - Windows Subsystem for Linux integration
 Utilities for integrating Ubuntu well into the WSL environment.
 .
 It is also used to help ensure proper upgrades, so it is recommended that
 it not be removed.
Description-md5: 31a2c9edbae1d8c6f5ec0d556efdb9e9

Balint Reczey (rbalint) wrote :

Verified 1.361.3 on Xenial:

root@x-wsl:~# apt install ubuntu-wsl
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following package was automatically installed and is no longer required:
  libfreetype6
Use 'apt autoremove' to remove it.
The following additional packages will be installed:
  bc wslu
Suggested packages:
  imagemagick
The following NEW packages will be installed:
  bc ubuntu-wsl wslu
0 upgraded, 3 newly installed, 0 to remove and 20 not upgraded.
Need to get 127 kB of archives.
After this operation, 500 kB of additional disk space will be used.
Do you want to continue? [Y/n]
Get:1 http://archive.ubuntu.com/ubuntu xenial/main amd64 bc amd64 1.06.95-9build1 [82.6 kB]
Get:2 http://archive.ubuntu.com/ubuntu xenial-updates/main amd64 wslu all 2.0.0-0ubuntu2~16.04.0 [42.4 kB]
Get:3 http://archive.ubuntu.com/ubuntu xenial-proposed/main amd64 ubuntu-wsl amd64 1.361.3 [2,402 B]
Fetched 127 kB in 0s (425 kB/s)
Selecting previously unselected package bc.
(Reading database ... 25734 files and directories currently installed.)
Preparing to unpack .../bc_1.06.95-9build1_amd64.deb ...
Unpacking bc (1.06.95-9build1) ...
Selecting previously unselected package wslu.
Preparing to unpack .../wslu_2.0.0-0ubuntu2~16.04.0_all.deb ...
Unpacking wslu (2.0.0-0ubuntu2~16.04.0) ...
Selecting previously unselected package ubuntu-wsl.
Preparing to unpack .../ubuntu-wsl_1.361.3_amd64.deb ...
Unpacking ubuntu-wsl (1.361.3) ...
Processing triggers for man-db (2.7.5-1) ...
Processing triggers for install-info (6.1.0.dfsg.1-5) ...
Setting up bc (1.06.95-9build1) ...
Setting up wslu (2.0.0-0ubuntu2~16.04.0) ...
update-alternatives: using /usr/bin/wslview to provide /usr/bin/x-www-browser (x-www-browser) in auto mode
Setting up ubuntu-wsl (1.361.3) ...
root@x-wsl:~# apt-cache show ubuntu-wsl
Package: ubuntu-wsl
Architecture: amd64
Version: 1.361.3
Priority: optional
Section: metapackages
Source: ubuntu-meta
Origin: Ubuntu
Maintainer: Ubuntu Developers <email address hidden>
Bugs: https://bugs.launchpad.net/ubuntu/+filebug
Installed-Size: 45
Depends: wslu
Filename: pool/main/u/ubuntu-meta/ubuntu-wsl_1.361.3_amd64.deb
Size: 2402
MD5sum: cf67ec318212d92abf78ed2588d862f5
SHA1: 17e46726f10b40f91f7237eb83b3c0584b307fa2
SHA256: 8102641a51eab7a712a752f868a8f4e96e0a55f07b901ce4448cb02315efd548
Description-en: Ubuntu on Windows tools - Windows Subsystem for Linux integration
 Utilities for integrating Ubuntu well into the WSL environment.
 .
 It is also used to help ensure proper upgrades, so it is recommended that
 it not be removed.
Description-md5: 31a2c9edbae1d8c6f5ec0d556efdb9e9

root@x-wsl:~#

tags: added: verification-done verification-done-bionic verification-done-cosmic verification-done-xenial
removed: verification-needed verification-needed-bionic verification-needed-cosmic verification-needed-xenial

The verification of the Stable Release Update for ubuntu-meta has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubuntu-meta - 1.425.1

---------------
ubuntu-meta (1.425.1) cosmic; urgency=medium

  * Added ubuntu-wsl metapackage from the wsl seed (LP: #1822341)
  * Added wslu to ubuntu-wsl

 -- Balint Reczey <email address hidden> Sat, 30 Mar 2019 15:59:08 +0100

Changed in ubuntu-meta (Ubuntu Cosmic):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubuntu-meta - 1.417.1

---------------
ubuntu-meta (1.417.1) bionic; urgency=medium

  * Added ubuntu-wsl metapackage from the wsl seed (LP: #1822341)
  * Added wslu to ubuntu-wsl

 -- Balint Reczey <email address hidden> Sat, 30 Mar 2019 15:59:08 +0100

Changed in ubuntu-meta (Ubuntu Bionic):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubuntu-meta - 1.361.3

---------------
ubuntu-meta (1.361.3) xenial; urgency=medium

  * Added ubuntu-wsl metapackage from the wsl seed (LP: #1822341)
  * Added wslu and ubuntu-minimal's dependencies and recommends to ubuntu-wsl

 -- Balint Reczey <email address hidden> Sat, 30 Mar 2019 15:59:08 +0100

Changed in ubuntu-meta (Ubuntu Xenial):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers