include fwupd packages in Server Seed

Bug #1749774 reported by Jeff Lane on 2018-02-15
14
This bug affects 2 people
Affects Status Importance Assigned to Milestone
ubuntu-meta (Ubuntu)
High
Canonical Server Team

Bug Description

fwupd is the closest we have to a standard mechanism currently for doing in-band firmware updates in a vendor agnostic way. As long as the vendors provide firmware blobs in an appropriately formatted package, fwupd (or fwupdate) can install those firmware blobs from within Ubuntu.

Because of this, we should include the related packages in the server seed. The main components all live in Main currently. As far as I can tell (verified on a Bionic install), nothing in the current server seed pulls in fwupd, fwupdate, or fwupdate-signed as a dependency.

ubuntu@xwing:~$ apt-cache policy fwup*

fwupdate:
  Installed: (none)
  Candidate: 10-2
  Version table:
     10-2 500
        500 http://archive.ubuntu.com/ubuntu bionic/main amd64 Packages
fwupd:
  Installed: (none)
  Candidate: 1.0.4-3build1
  Version table:
     1.0.4-3build1 500
        500 http://archive.ubuntu.com/ubuntu bionic/main amd64 Packages
fwupdate-signed:
  Installed: (none)
  Candidate: 1.17+10-2
  Version table:
     1.17+10-2 500
        500 http://archive.ubuntu.com/ubuntu bionic/main amd64 Packages

Related branches

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in ubuntu-meta (Ubuntu):
status: New → Confirmed
Steve Langasek (vorlon) on 2019-05-09
Changed in ubuntu-meta (Ubuntu):
assignee: nobody → Canonical Server Team (canonical-server)
tags: added: server-next server-triage-discuss

Thanks Steve for the ping for awareness!

It still all is in main, and I checked the old MIR bug 1536871 for any extra context that might have been mentioned there.

It already is in desktop-common (and due to that in all desktop tasks).
It is there as recommends which I appreciate for the rare case that someone really runs into issues due to the package.

It also is in system-image for ubuntu core.

And finally it also is in d-i-requirements for being on the disk image if needed by d-i.

---

I checked in a XLD container and a cloud image with only main enabled that we can install it and how much "extra" that would be on small server instances.

It is 13.9 MB extracted and 3742 kB of archives which seems ok space-wise.

The content will be:
- a bunch of libs (ok)
- a bunch of glib-* packages (still sort of ok)
- dconf-service and some related dbus things (dbus runs anyway, just one more endpoint)
- bolt (system daemon to manage thunderbolt 3 devices)
  That service seems well isolated and only runs if thunderbolt are found (udev)

---

Overall I agree that it makes sense to add this to the server meta task as well, but also as recommends for some flexibility where needed.

Since version 1.1.0 the requested fwupdate no more is important, but fwupd+fwupd-signed are.
So we use those as recommends.

I prepared a seed change and will propose it for a second Team pair of eyes to commit

Changed in ubuntu-meta (Ubuntu):
importance: Undecided → High
status: Confirmed → Triaged
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubuntu-meta - 1.434

---------------
ubuntu-meta (1.434) eoan; urgency=medium

  * Refreshed dependencies
  * Added fwupd to server-recommends (LP: #1749774)
  * Removed net-tools from server (LP: #1748956)

 -- Christian Ehrhardt <email address hidden> Mon, 13 May 2019 12:08:01 +0200

Changed in ubuntu-meta (Ubuntu):
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers