Drop fonts-symbola from platform?

Bug #1746310 reported by Jeremy Bicha
16
This bug affects 1 person
Affects Status Importance Assigned to Milestone
ubuntu-meta (Ubuntu)
Fix Released
Undecided
Unassigned

Bug Description

ttf-ancient-fonts-symbola is a recommends in platform.bionic desktop-common so it's installed for every Ubuntu desktop flavor (Kubuntu, Lubuntu, Ubuntu, etc.).

It's a transitional package now depending on fonts-symbola.

The package description is
"This package includes the Symbola font, which contains special symbols and emoji characters which are encoded in the Unicode Standard 9.0."

It was added to the seeds in LP: #1137630 explicitly for emoji support.

Ubuntu Desktop (and Ubuntu Budgie and Ubuntu MATE) now include fonts-noto-color-emoji for this instead.

GTK+ in Ubuntu 18.04 supports color emoji. Qt does not.

fonts-symbola has installed-size 3,178 kB according to apt
fonts-noto-color-emoji has installed-size 7,277 kB

Should we replace fonts-symbola with fonts-noto-color-emoji? Or should we drop it entirely?

The only other Color Emoji font I expect to be available in Ubuntu soon is EmojiTwo. EmojiTwo lags behind in supporting the latest emoji standards.

Screenshots of Noto Color Emoji and EmojiTwo are at
https://community.ubuntu.com/t/try-color-emoji-in-18-04/1492

ubuntu-release list proposal:
https://lists.ubuntu.com/archives/ubuntu-release/2018-February/004276.html

Tags: bionic
Jeremy Bicha (jbicha)
description: updated
tags: added: bionic
Revision history for this message
Gunnar Hjalmarsson (gunnarhj) wrote :

@Jeremy: I have no strong opinion on this in any direction, so I'm happy with whatever you decide.

Revision history for this message
Marco Trevisan (Treviño) (3v1n0) wrote :

I'm ok with replacing.

Jeremy Bicha (jbicha)
description: updated
Revision history for this message
Gunnar Hjalmarsson (gunnarhj) wrote :

If qt does not support fonts-noto-color-emoji, replacing would be a regression, especially for Kubuntu, and may not be a good idea. I understand that the packages don't conflict to each other. What's the drawback with keeping it as is for now, and install both packages in Ubuntu?

Revision history for this message
Simon Quigley (tsimonq2) wrote :

I agree with Gunnar, I'm -1 with both my Lubuntu and Kubuntu hats on if this means a regression for Qt-based desktops.

Revision history for this message
Jeremy Bicha (jbicha) wrote :

Gunnar, Kubuntu and Lubuntu Next are free to install fonts-symbola if they want. (But they should really talk to Qt about getting color emoji support working everywhere too!)

The benefit of installing Noto Color Emoji by default is so that color emoji will work out of the box with any GTK+ app (with a few exceptions like Chromium, Firefox and LibreOffice). Color Emoji is advertised as an Ubuntu 18.04 LTS feature.

The benefit of not installing Symbola by default is that it's unneeded.

Revision history for this message
Gunnar Hjalmarsson (gunnarhj) wrote :

Also Ubuntu users install qt apps, don't they? And FF and LO are important exceptions. The archive size of fonts-symbola is 1.2 MiB.

How about including both in desktop-common for now?

Revision history for this message
Jeremy Bicha (jbicha) wrote :

Gunnar, could you test the apps before saying we need Symbola?

Firefox, Chromium, and LibreOffice don't need Symbola. Firefox uses an embedded version of EmojiOne currently. Chromium will probably eventually support Noto.

See https://community.ubuntu.com/t/try-color-emoji-in-18-04/1492/23 and 24 for some relevant upstream bug report links.

Revision history for this message
Gunnar Hjalmarsson (gunnarhj) wrote :

I'm on a slippery slope here; should probably have kept quiet. But it was your mentioning of qt which triggered me to post a couple of comments, since people tend to use some qt apps also in Ubuntu.

Anyway, my view in comment #1 still stands. ;)

Revision history for this message
Simon Quigley (tsimonq2) wrote :

> Gunnar, Kubuntu and Lubuntu Next are free to install fonts-symbola if they want. (But they should really talk to Qt about getting color emoji support working everywhere too!)

I don't think that's the point; if we're talking about inclusion in desktop-common, support for Qt *and* GTK needs to be there. Favoring the package that works with GTK apps and not Qt apps, then saying that the Qt flavors can install fonts-symbola if they want, makes me want to say the same to the GTK flavors about fonts-noto-color-emoji.

> The benefit of installing Noto Color Emoji by default is so that color emoji will work out of the box with any GTK+ app (with a few exceptions like Chromium, Firefox and LibreOffice). Color Emoji is advertised as an Ubuntu 18.04 LTS feature.

What about desktops that don't install GTK apps by default (Lubuntu Next)? I echo my comment above that it should be all or nothing here.

> The benefit of not installing Symbola by default is that it's unneeded.

I thought it was needed for Qt apps?

Revision history for this message
Pasi Lallinaho (knome) wrote :

Xubuntu is OK with replacing.

Revision history for this message
Ross Gammon (rosco2) wrote :

Without checking, I don't think Ubuntu Studio have any objections.

Revision history for this message
Jeremy Bicha (jbicha) wrote :

There were a few responses on the ubuntu-release mailing list.

https://lists.ubuntu.com/archives/ubuntu-release/2018-February/004283.html

It looks like we're going to drop fonts-symbola from desktop-common. Flavors are free to install fonts-noto-color-emoji themselves if they like since Kubuntu objects to it being in desktop-common.

Revision history for this message
Jeremy Bicha (jbicha) wrote :
Changed in ubuntu-meta (Ubuntu):
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers