Missing fonts in list of languages

Bug #1719934 reported by Jean-Baptiste Lallement on 2017-09-27
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
ubuntu-meta (Ubuntu)
Medium
Jean-Baptiste Lallement

Bug Description

There is a font missing on the ISO and one of the language is shown as unicode characters (cf screenshot)

ProblemType: Bug
DistroRelease: Ubuntu 17.10
Package: ubiquity (not installed)
ProcVersionSignature: Ubuntu 4.13.0-11.12-generic 4.13.1
Uname: Linux 4.13.0-11-generic x86_64
ApportVersion: 2.20.7-0ubuntu1
Architecture: amd64
CurrentDesktop: ubuntu:GNOME
Date: Wed Sep 27 11:22:24 2017
InstallationDate: Installed on 2013-09-03 (1484 days ago)
InstallationMedia: Ubuntu 13.10 "Saucy Salamander" - Alpha amd64 (20130902)
ProcEnviron:
 TERM=screen-256color
 PATH=(custom, no user)
 XDG_RUNTIME_DIR=<set>
 LANG=fr_FR.UTF-8
 SHELL=/bin/bash
SourcePackage: ubiquity
UpgradeStatus: No upgrade log present (probably fresh install)

Jean-Baptiste Lallement (jibel) wrote :
Jean-Baptiste Lallement (jibel) wrote :

The following fonts are missing from the ISO:
fonts-knda
fonts-telu

Changed in ubiquity (Ubuntu):
importance: Undecided → Medium
status: New → Triaged
affects: ubiquity (Ubuntu) → ubuntu-meta (Ubuntu)
summary: - Missing font in list of languages
+ Missing fonts in list of languages
Will Cooke (willcooke) on 2017-09-27
Changed in ubuntu-meta (Ubuntu):
assignee: nobody → Jean-Baptiste Lallement (jibel)
Changed in ubuntu-meta (Ubuntu):
status: Triaged → In Progress
Jeremy Bicha (jbicha) wrote :

What do you think about moving fonts-indic from 'supported' to 'live'?

desktop-common in 14.04 had recommends for:

 * (ttf-indic-fonts-core)
 * (ttf-punjabi-fonts)

https://bazaar.launchpad.net/~ubuntu-core-dev/ubuntu-seeds/platform.trusty/view/head:/desktop-common#L89

But those were dropped before 16.04 LTS.

There's a description of ttf-indic-fonts-core in the changelog:
https://launchpad.net/ubuntu/+source/ttf-indic-fonts/1:0.5.14ubuntu1

Gunnar Hjalmarsson (gunnarhj) wrote :

@Jeremy: I remember that we talked about fonts-indic a few weeks ago. The accumulated size of the packages it pulls isn't huge - 5 MB disk space if I didn't make a mistake - and it sounds like a good idea. Or would it require a bunch of MIRs?

Maybe, though, replace fonts-knda and fonts-telu in the platform.artful branch with fonts-indic. (Why do we pull some fonts via desktop-common in platform.artful, and some via desktop in ubuntu.artful?)

Jeremy Bicha (jbicha) wrote :

On my computer, sudo apt install fonts-indic gives these numbers:

Need to get 3,315 kB of archives.
After this operation, 11.6 MB of additional disk space will be used.

The comment says there were "space reasons" to have some fonts listed in desktop instead of desktop-common but I believe that doesn't apply any more. (All the Desktop flavors appear to ship those fonts except Lubuntu doesn't include fonts-liberation but Lubuntu Next does so that seems a mistake to not include that font.)

https://bazaar.launchpad.net/~ubuntu-core-dev/ubuntu-seeds/ubuntu.artful/view/head:/desktop#L34

So to amend my previous question, why not move fonts-indic from 'supported' to 'desktop-common'?
And move those 3 fonts from 'desktop' to 'desktop-common'?

Gunnar Hjalmarsson (gunnarhj) wrote :

I'm sure your calculation is more proper than mine (I have probably installed some of the packages manually). Still think it's a good idea; those fonts represent languages spoken by a huge number of people.

On 2017-09-30 01:14, Jeremy Bicha wrote:
>
> https://bazaar.launchpad.net/~ubuntu-core-dev/ubuntu-seeds/ubuntu.artful/view/head:/desktop#L34
>
> So to amend my previous question, why not move fonts-indic from
> 'supported' to 'desktop-common'?
> And move those 3 fonts from 'desktop' to 'desktop-common'?

+1 from me (for what that is worth...)

Jeremy Bicha (jbicha) wrote :

On jibel's request, I split my issue to a separate bug, LP: #1720809

Changed in ubuntu-meta (Ubuntu):
status: In Progress → Fix Committed
Jean-Baptiste Lallement (jibel) wrote :

Fix verified in today's ISO

Changed in ubuntu-meta (Ubuntu):
status: Fix Committed → Fix Released
Jeremy Bicha (jbicha) wrote :

I used fix committed since we still have to do a new ubuntu-meta upload to update the metapackage to match the seed. I'm planning on doing that this weekend for LP: #1720809 anyway.

Changed in ubuntu-meta (Ubuntu):
status: Fix Released → Fix Committed
Jeremy Bicha (jbicha) wrote :

Fixed in https://launchpad.net/ubuntu/+source/ubuntu-meta/1.403

(This ended up being a duplicate of LP: #1720809 )

Changed in ubuntu-meta (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers