UIFe: Drop xterm and xdiagnose from default install

Bug #1717946 reported by Jeremy Bicha on 2017-09-18
16
This bug affects 3 people
Affects Status Importance Assigned to Milestone
ubuntu-meta (Ubuntu)
Undecided
Unassigned

Bug Description

Impact
======
I'm proposing to drop 3 apps from the default Ubuntu 17.10 install:
XTerm
UXTerm
xdiagnose

These are visible in the Show Applications view of the Activities Overview so this could impact screenshots.

Justification
=============
These were only in the default install because of the FailsafeX feature.
Timo Aaltonen (tjaalton), maintainer of Ubuntu's X stack and co-maintainer in Debian, has said that feature isn't important any more, considering the transition to Wayland.

xdiagnose also provided some apport hooks for diagnosing display problems but that was moved to xorg itself earlier this release cycle.

xdiagnose currently doesn't run in the Ubuntu session on Wayland.

https://irclogs.ubuntu.com/2017/09/18/%23ubuntu-desktop.html#t14:18

Discussed earlier in the cycle:
https://lists.ubuntu.com/archives/ubuntu-desktop/2017-June/004980.html
https://lists.ubuntu.com/archives/ubuntu-desktop/2017-July/005059.html

List Notifications
==================
https://lists.ubuntu.com/archives/ubuntu-doc/2017-September/020534.html
https://lists.ubuntu.com/archives/ubuntu-translators/2017-September/007403.html

Jeremy Bicha (jbicha) on 2017-09-18
description: updated
Jeremy Bicha (jbicha) on 2017-09-18
description: updated
Gunnar Hjalmarsson (gunnarhj) wrote :

Not a problem from a docs POV.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in ubuntu-meta (Ubuntu):
status: New → Confirmed
amano (jyaku) wrote :

To add to the things above:

Xterm and UXterm have dated icons that stick out in gnome-shell like a sore thumb. Much more than in the Unity dash.

Xdiagnose shows up in Ubuntu Software. A newbie that tries to remove it (“I don't get for why it is useful, it looks broken“) will remove the entire ubuntu-desktop metapackage which is not desireful.

Iain Lane (laney) wrote :

If it's correct that they were only included for Failsafe X, and Timo thinks they should be removed, then please go for it.

Changed in ubuntu-meta (Ubuntu):
status: Confirmed → Triaged
Jeremy Bicha (jbicha) on 2017-09-28
Changed in ubuntu-meta (Ubuntu):
status: Triaged → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubuntu-meta - 1.402

---------------
ubuntu-meta (1.402) artful; urgency=medium

  * Refreshed dependencies
  * Removed xdiagnose from desktop (LP: #1717946)
  * Removed xterm from desktop-recommends (LP: #1717946)

 -- Jeremy Bicha <email address hidden> Thu, 28 Sep 2017 13:09:49 -0400

Changed in ubuntu-meta (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers