FFE: switch system init to systemd [not touch] in 15.04

Bug #1427654 reported by Martin Pitt on 2015-03-03
50
This bug affects 6 people
Affects Status Importance Assigned to Milestone
init-system-helpers (Ubuntu)
Undecided
Martin Pitt
Vivid
Undecided
Martin Pitt
ubuntu-meta (Ubuntu)
Undecided
Martin Pitt
Vivid
Undecided
Martin Pitt

Bug Description

As per https://blueprints.launchpad.net/ubuntu/+spec/core-1411-systemd-migration we aimed for switching the system (not session) init from upstart to systemd this cycle. As this was by and large a 1.2 man show, this took a little longer. One of the remaining blockers for switching the default was to fix NFS (bug 1312976) which is now ready to be uploaded. There is also juju (bug 1409639, landed upstream now) and maas (bug 1423613, scheduled), but for those we can work around missing systemd support by installing upstart on instances.

We are a few days past feature freeze now, bug Steve and I discussed last week, and we still want to aim for switching the default in vivid. To be clear, this will affect Ubuntu desktop/server/cloud and the flavours like Kubuntu, but *NOT* ubuntu-touch. Migration to systemd is blocked on touch (too old kernels, some unported jobs), and was not scheduled for vivid. For that we need to ensure to keep upstart on Touch (there is a work item on the spec).

I know from at least Kubuntu and Ubuntu GNOME that they are pushing for switching to systemd. We should get an ack from the others (Lubuntu/Xubuntu/MATE) before doing the switch; but quite a lot of vivid users are running systemd already, and I believe we shook out the worst bugs now.

So if/once the release team generally agrees, these are the things which need to happen before switching:

  * Signoff/test from remaining flavours (MATE, Xubuntu, Lubuntu) - DONE
  * Land NFS (bug 1312976) - DONE
  * Ensure Touch keeps upstart (bug 1428026) - DONE

Operationally, the switch is merely to change s/upstart/systemd-sysv/ in the seeds, i. e. flip the dependency in ubuntu-minimal. I did that in https://launchpad.net/~pitti/+archive/ubuntu/systemd, fixed ureadahead, and verified that upgrades from trusty and utopic cleanly upgrade to vivid+PPA with removing upstart and installing systemd-sysv.

Around that time I will send a mail to ubuntu-devel-announce@ to warn about the impending switch, and give some pointers how to boot with upstart (from grub menu or reinstalling upstart), how to debug boot/shutdown issues, etc.

Contingency plan: This will trigger wider testing, and most certainly uncover more integration issues. I'll try to keep up with them, but if we get to a point where we find that there are too many/too serious regressions, we can flip the seed back to upstart and get back to the situation today.

Martin Pitt (pitti) on 2015-03-03
summary: - FFE: switch system init to systemd [not touch]
+ FFE: switch system init to systemd [not touch] in 15.04
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in ubuntu-meta (Ubuntu):
status: New → Confirmed
Martin Pitt (pitti) wrote :

I got confirmation from Xubuntu (Unit193) and MATE (Martin Wimpress) that switching to systemd works fine and is OK for them. I mailed Julien for Lubuntu.

Martin Pitt (pitti) on 2015-03-04
description: updated
Martin Pitt (pitti) on 2015-03-04
description: updated
Martin Pitt (pitti) wrote :

I just downloaded today's lubuntu desktop, did an ubiquity install under it (boot the live system with init=/bin/systemd), and also tested the installed system under systemd. No problems encountered.

description: updated
Martin Pitt (pitti) on 2015-03-05
description: updated
Martin Pitt (pitti) on 2015-03-05
Changed in ubuntu-meta (Ubuntu Vivid):
milestone: none → ubuntu-15.03
Adam Conrad (adconrad) wrote :

Pursuant to many conversations on the topic, this is a formal approval of the FFe, with an assumption that it will land early in the week of March 9th.

Martin Pitt (pitti) on 2015-03-05
Changed in ubuntu-meta (Ubuntu Vivid):
status: Confirmed → In Progress
assignee: nobody → Martin Pitt (pitti)
Changed in init-system-helpers (Ubuntu Vivid):
status: New → In Progress
assignee: nobody → Martin Pitt (pitti)
milestone: none → ubuntu-15.03
Timo Aaltonen (tjaalton) wrote :

Filed a bug on apache2 where "stop; start" on systemd fails: https://bugs.launchpad.net/ubuntu/+source/apache2/+bug/1428796

Martin Pitt (pitti) on 2015-03-09
Changed in init-system-helpers (Ubuntu Vivid):
status: In Progress → Fix Committed
Martin Pitt (pitti) on 2015-03-09
Changed in ubuntu-meta (Ubuntu Vivid):
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubuntu-meta - 1.332

---------------
ubuntu-meta (1.332) vivid; urgency=medium

  * Refreshed dependencies
  * Added systemd-sysv to standard (LP: #1427654)
 -- Martin Pitt <email address hidden> Mon, 09 Mar 2015 06:20:44 +0100

Changed in ubuntu-meta (Ubuntu Vivid):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package init-system-helpers - 1.22ubuntu4

---------------
init-system-helpers (1.22ubuntu4) vivid; urgency=medium

  * init: Switch preferred alternative to systemd, and update package
    description to make sense for Ubuntu. (LP: #1427654)
 -- Martin Pitt <email address hidden> Sun, 08 Mar 2015 12:26:24 +0100

Changed in init-system-helpers (Ubuntu Vivid):
status: Fix Committed → Fix Released
Jason Gerard DeRose (jderose) wrote :

Being able to run a script like this over SSH:

apt-get -y remove openssh-server
shutdown -h now

Can be extremely useful in automation tooling, but the switch to systemd breaks this:

https://bugs.launchpad.net/ubuntu/+source/openssh/+bug/1429938

Rolf Leggewie (r0lf) wrote :

would it be possible to have ubuntu-standard depend on "systemd|upstart" instead of systemd only? I'd like to avoid systemd while having ubuntu-standard installed for a fully supported system.

Rolf Leggewie (r0lf) wrote :

See also bug 1399766. I guess the question is whether having a non-systemd installation is going to be supported and I hope the answer will be yes.

Didier Roche (didrocks) wrote :

As stated on the mailing list few months ago (https://lists.ubuntu.com/archives/ubuntu-devel-discuss/2014-December/015154.html), Ubuntu never offered a choice of init system, and won't start doing that. systemd is mandatory to be the supported ubuntu path. That's the reason why ubuntu-standard won't depend on systemd|upstart.

Note that for some kernel reasons, the Touch image is still using upstart, but that will change in the future.

gravy45 (gravy45) wrote :

Switching to systemd for Ubuntu MATE 15.04 (Beta 2) seems to have resulted in extended boot time in a Virtualbox guest (approximately 45 seconds longer).

gravy45 (gravy45) wrote :

The previous post is where it sits for about 30 seconds or so. Here is another screenshot.

Martin Pitt (pitti) wrote :

gravy45, this sounds like bug 953875 (or similar). Please file a new bug, this is unrelated to this FFE and doesn't affect all installations (i. e. it's specific to your system).

god (humper) wrote :

Is there some detailed notes on why upstart is still used for user sessions instead of systemd? Is it just lack of time or there are some technical reasons not to switch to systemd here as well?

god [2015-05-02 23:19 -0000]:
> Is there some detailed notes on why upstart is still used for user
> sessions instead of systemd? Is it just lack of time or there are some
> technical reasons not to switch to systemd here as well?

Mostly just lack of time/engineers, and not changing too many
intrusive things at once.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers