ubuntu-desktop should depend on ibus-gtk

Bug #1377370 reported by Michael Blennerhassett on 2014-10-04
80
This bug affects 40 people
Affects Status Importance Assigned to Milestone
One Hundred Papercuts
High
Unassigned
ubuntu-meta (Ubuntu)
High
Nobuto Murata
Nominated for Trusty by Aron Xu
Nominated for Utopic by Nobuto Murata
Nominated for Vivid by Aron Xu

Bug Description

Note that ubuntu-desktop depends on ibus-gtk3 already.

Looking at /usr/share/im-config/data/21-ibus.rc
GTK_IM_MODULE is only set to ibus if both gtk-2.0 and gtk-3.0 ibus modules are present. Otherwise it's set to xim.

If GTK_IM_MODULE=xim and ibus is running, then various bugs happen like LP: #1374721 and LP: #1375742.

Installing ibus-gtk makes those problems go away.

ProblemType: Bug
DistroRelease: Ubuntu 14.10
Package: ubuntu-desktop 1.327
ProcVersionSignature: Ubuntu 3.16.0-20.27-generic 3.16.3
Uname: Linux 3.16.0-20-generic x86_64
ApportVersion: 2.14.7-0ubuntu2
Architecture: amd64
CurrentDesktop: Unity
Date: Sat Oct 4 13:49:55 2014
InstallationDate: Installed on 2014-09-03 (30 days ago)
InstallationMedia: Ubuntu 14.10 "Utopic Unicorn" - Alpha amd64 (20140902)
SourcePackage: ubuntu-meta
UpgradeStatus: No upgrade log present (probably fresh install)

tags: added: vivid
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in ubuntu-meta (Ubuntu):
status: New → Confirmed
Ludo6431 (lacoste) wrote :

It does fix the problem!
Thanks

Changed in ubuntu-meta (Ubuntu):
importance: Undecided → High
Changed in hundredpapercuts:
importance: Undecided → High
status: New → Confirmed
Nobuto Murata (nobuto) on 2015-02-14
Changed in ubuntu-meta (Ubuntu):
assignee: nobody → Nobuto Murata (nobuto)
Nobuto Murata (nobuto) wrote :

related: bug #1164252

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubuntu-meta - 1.329

---------------
ubuntu-meta (1.329) vivid; urgency=medium

  * Refreshed dependencies
  * Added ibus-gtk to desktop-recommends (LP: #1377370)
 -- Daniel Holbach <email address hidden> Thu, 19 Feb 2015 14:49:48 +0100

Changed in ubuntu-meta (Ubuntu):
status: Confirmed → Fix Released
Aron Xu (happyaron) on 2015-02-19
Changed in hundredpapercuts:
status: Confirmed → Fix Committed
Nobuto Murata (nobuto) wrote :

It's better to be backported to utopic as well, but I'm not sure if ubuntu-meta can be SRUed.

Aron Xu (happyaron) wrote :

@nobuto, I think seeding ibus-gtk3 would only make sense for trusty, because that change only become effective when new images are generated.

Changed in hundredpapercuts:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers