Metapackages difficult to find

Bug #13664 reported by Jan on 2005-03-08
12
Affects Status Importance Assigned to Milestone
ubuntu-meta (Ubuntu)
Wishlist
Rolf Leggewie

Bug Description

I suggest placing all meta-packages (or copies of meta-packages) into one section
of sources.list to aid the user selection of necessary packages. Plain reading
of the whole list is unrealistic owing to the size of the archive hence novice
users
are often helpless in the effort to find packages they need. The number of
meta-packages
is much smaller and they provide a reasonable degree of granularity of the
system install state.

Alternatively Dselect, Aptitude and Synaptic could be modified to list
meta-packages
separately.

Alternatively now almost obsolete Tasksel could be resurrected by presenting
meta-packages
say in a tree view denoting dependencies.

It's sad to see aptitude listing virtual packages as separate section (totally
irrelevant for
an ordinary user) while letting meta-packages to be scattered around the archive.

Dennis Kaarsemaker (dennis) wrote :

A summary of available metapackages has been started on
wiki.ubuntu.com/MetaPackages - it still needs some love, it includes only the
most important ones. It's not doable for apt to show these packages separately
since they are not special (unlike virtual packages).

Sebastian Heinlein (glatzor) wrote :

There is no special state for meta packages. They are normal packages.

Changed in synaptic:
status: Unconfirmed → Confirmed
Jan (debian-gepro) wrote :

I would not say they are "normal", they do not install any system relevant files, which contradicts the very nature of a "package". Their sole purpose is to have dependencies as a means of convenience for easy installation of related package sets.

Very simple heuristics can be used to separate them from the bulk of the archive to allow the user to browse their list easily. For example:

1. Most containt the word "meta" in the name and description.
2. Most do not install anything outside /usr/share/doc
3. Most do not reverze depend on anything else then other matapackes.

The only metapackage not passing properly would probably be "pseudometapackage" xfce

Colin Watson (cjwatson) wrote :

Metapackages are now in the 'metapackages' section and should be displayed separately by frontends such as dselect. Does that resolve this bug for you?

Rolf Leggewie (r0lf) wrote :

Jan, IYO is there anything left to be done before this bug can be closed?

Changed in ubuntu-meta (Ubuntu):
assignee: nobody → Rolf Leggewie (r0lf)
status: Confirmed → Incomplete
Rolf Leggewie (r0lf) wrote :

closing as fixed

Changed in ubuntu-meta (Ubuntu):
status: Incomplete → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.