Ubuntu

Replace gnome-cups-manager by system-config-printer

Reported by Till Kamppeter on 2007-08-07
8
Affects Status Importance Assigned to Milestone
system-config-printer (Ubuntu)
High
Unassigned
ubuntu-meta (Ubuntu)
High
Sur5

Bug Description

Binary package hint: gnome-cups-manager

When the user chooses "System"/"Administration"/"Printing" a tool which is unmaintained for more than a year (gnome-cups-manager) shows up, whereas under Fedora Linux an actively maintained tool appears (system-config-printer).

Upstream maintainer of system-config-printer is Tim Waugh, printing guru from Red Hat and he is not only actively developing this tool but he also supports the tool being adopted by other distributions, for example he monitors the bug reports on system-config-printer here on the Launchpad. He has accepted most of my patches and has given me write access to the upstream SVN repository.

system-config-printer was difficult to use for newbies at some places and it was only be usable when run as root, but I have done several improvements on it and except that existing print queues are not shown as icons the principal usability problems should be solved now. Now it is even easier and more correct than gnome-cups-manager in some points.

Here some important features (which are improvements against gnome-cups-manager):
- Auto-setup of print queues when plugging a printer (together with hal-cups-utils), fixes https://blueprints.launchpad.net/ubuntu/+spec/automatic-printer-conf
- If the tool is run by a user in the lpadmin group printer option settings are saved system-wide (in /etc/cups/printers.conf and /etc/cups/ppd/*.ppd) and not in the personal configuration file ~/.cups/lpoptions). This was a problem of gnome-cups-manager which has led to a lot of bug reports.
- If the add-printer wizard detects a printer and it is supported by HPLIP, only the entries for HPLIP-enabled setup appear in the list of auto-detected printers.
- HPLIP support is also checked for manually entered network printers.
- Improved auto-selection of PPDs. PostScript printers get assigned the manufacturer supplied PostScript PPDs now (gnome-cups-manager did not always default to the right PPD).

Also important is that with system-config-printer bugs get more easily fixed due to the upstream maintainership. Having a tool with bugs is also a usability problem.

Till Kamppeter (till-kamppeter) wrote :

gnome-cups-manager should be completely removed from Ubuntu as it is not maintained upstream any more (or at least degraded to Universe). system-config-printer should be added to the appropriate seeds to get onto the CDs.

Changed in gnome-cups-manager:
importance: Undecided → High
status: New → Confirmed
Changed in system-config-printer:
importance: Undecided → High
status: New → Confirmed
Patrice Vetsel (vetsel-patrice) wrote :

It's a great improvement for printing under Ubuntu. S-c-p is also coded in python+glade, allowing to easily hacking it. Tim seems to be very present and accepting patches and suggestions.

Patrice Vetsel (vetsel-patrice) wrote :

Can we quickly hack ubuntu meta package to have g-c-m removed and s-c-p installed with hal-cups-utils too ?
Before Tribe5 ? Like this we can begin testing daily-iso, and i can not find any reason to wait for tribe5. We should do this now.

Martin Pitt (pitti) wrote :

This seed change was done recently, and uploaded in ubuntu-meta 1.61.

Changed in gnome-cups-manager:
assignee: nobody → pitti
status: Confirmed → Fix Released
Changed in ubuntu-meta:
status: Fix Released → Invalid
Martin Pitt (pitti) wrote :

Bah, LP suddenly reversed the sort order, sorry.

Changed in ubuntu-meta:
status: Invalid → Fix Released
Changed in system-config-printer:
status: Confirmed → Invalid
Mattias Eriksson (snaggen) wrote :

Hmm... I realize your reasoning for doing this, but I must say I found gnome-cups-manager had a much clearer gui. Anyway, I guess this is the right thing to do and then maybe fix the usability issues later.
However one anoying thing about it is the printing icon that appears in my trayicon. It doesn't go away when the job is done. It wasn't there before the job started so I expect it to go away if everyting goes ok, but now it still is there but it is greyed out. It doesn't have any use but to waste some space... if you fix that I'll be a happy user :)

//Mattias

Tim Waugh (twaugh) wrote :

You can right-click and select 'Hide' from the context menu.

Sur5 (sleightflow) on 2010-01-17
Changed in ubuntu-meta (Ubuntu):
assignee: Martin Pitt (pitti) → Sur5 (sleightflow)
status: Fix Released → Fix Committed
Gary M (garym) wrote :

(undid strange status change from @Sur5)

Changed in ubuntu-meta (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers