unity-settings-deamon is not installed after latest trusty upgrade

Bug #1281168 reported by Franck on 2014-02-17
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
One Hundred Papercuts
High
Unassigned
ubuntu-meta (Ubuntu)
High
Unassigned

Bug Description

After latest upgrade, settings cannot be saved anymorem nor are they applied (eg. keymap is not set properly).

Trying to save settings results in:

GDBus.Error:org.freedesktop.DBus.Error.ServiceUnknown: The name org.gnome.SettingsDaemon was not provided by any .service files

Installing unity-settings-daemon solves the problem, but this package is not a dependancy of ubunutu-destop (or maybe another more fine-grained package).

ProblemType: Bug
DistroRelease: Ubuntu 14.04
Package: ubuntu-desktop 1.318
ProcVersionSignature: Ubuntu 3.13.0-8.28-generic 3.13.2
Uname: Linux 3.13.0-8-generic x86_64
ApportVersion: 2.13.2-0ubuntu4
Architecture: amd64
CurrentDesktop: Unity
Date: Mon Feb 17 17:12:23 2014
InstallationDate: Installed on 2013-02-16 (365 days ago)
InstallationMedia: Ubuntu 13.04 "Raring Ringtail" - Alpha amd64 (20130216)
SourcePackage: ubuntu-meta
UpgradeStatus: Upgraded to trusty on 2014-01-22 (25 days ago)

Franck (alci) wrote :
description: updated
description: updated
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in ubuntu-meta (Ubuntu):
status: New → Confirmed

It's estimated to have a moderate impact on a large portion of Ubuntu users.

Changed in ubuntu-meta (Ubuntu):
importance: Undecided → High
Changed in hundredpapercuts:
status: New → Confirmed
importance: Undecided → High
Mathew Hodson (mathew-hodson) wrote :

This bug was fixed in the package ubuntu-meta 1.321

---------------
ubuntu-meta (1.321) trusty; urgency=medium

  * Refreshed dependencies
  * Added unity-settings-daemon to desktop
  * Removed gnome-settings-daemon from desktop
 -- Robert Ancell <email address hidden> Thu, 20 Feb 2014 20:30:26 +1300

Changed in ubuntu-meta (Ubuntu):
status: Confirmed → Fix Released
Changed in hundredpapercuts:
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers