ubuntu-desktop should not depend on xsane or espeak

Bug #122039 reported by Bogdan Butnaru on 2007-06-24
20
Affects Status Importance Assigned to Milestone
ubuntu-meta (Ubuntu)
Undecided
Unassigned

Bug Description

*** Please do not add new package names to this bug when you think ubuntu-desktop shouldn't depend on them. File a new bug instead. This has been a public service announcement. ***

Hello! This is an "exploratory" bug report. It is based on Gutsy, which I'm using right now, but probably applies to the older versions too.

I've just noticed ubuntu-desktop depends on the xsane and espeak packages. These two are packages I have never, ever used, and I suspect this is true for the vast majority of users.

I understand out-of-the-box compatibility with scanners and screen-readers are desirable qualities for Ubuntu, but isn't there another way? Perhaps putting them as "Recommends" dependencies would work; espeak could be part of an "ubuntu-accessibility" package, installed by default, and xsane could maybe be automatically-installed when a scanner is detected.

The problem is that unnecessary packages not only occupy space, but can cause problems too (I've recently have trouble with the GIMP, which I use only on digital-camera pictures, not starting up, and xsane is the suspect; yes, I know it's a development release, and I can handle it, but still). And removing them is a problem, too, because (useful) additions to ubuntu-desktop will not be noticed.

They should be recommended by ubuntu-desktop. Serpentine, sound-juicer, tsclient, rss-glx are some more programs that I think should be recommends instead of dependencies.

Prosthetic Head (propanone) wrote :

I believe there are many packages that should be recommends, not dependencies..
There is a forum thread on this topic here:
http://ubuntuforums.org/showthread.php?t=518683

I've also noticed xterm and uxterm in my menu. Good candidates for removal since I have Terminal and don't need more CLIs.

They were installed by default and try to remove ubuntu-desktop if I try to uninstall them.

Colin Watson (cjwatson) wrote :

espeak was already a Recommends by the time I got to this, and I've dropped xsane to Recommends too:

revno: 1039
committer: Colin Watson <email address hidden>
branch nick: ubuntu.gutsy
timestamp: Wed 2007-08-08 10:32:23 +0100
message:
  drop xsane to Recommends (LP: #122039)

xterm is a dependency because it's used (hardcoded) by gdm as a fallback in case the main X session fails.

Changed in ubuntu-meta:
assignee: nobody → kamion
status: New → Fix Released

And what about the others I mentioned above: Serpentine, sound-juicer, tsclient and rss-glx?

Changed in ubuntu-meta:
status: Fix Released → Confirmed
Bogdan Butnaru (bogdanb) wrote :

Other items for the list:

cd-paranoia, dvd+rw-tools, nautilus-cd-burner, wodim --- someone without a CD drive can be desktop user.
fortune-mod --- not really critical
gnome-pilot-conduits --- I don't have a PDA

almost all printer-related packages (foomatic-*, pnm2ppa, cupsys-*) which are not critical for users without a printer.

Luke Yelavich (themuso) wrote :

Actually, espeak doesn't even need to be installed by default, as the espeak library is pulled in anyway, which satisfies the screen reader requirements. espeak could be either in ship, or supported.

Prosthetic Head (propanone) wrote :

Serpentine, sound-juicer, anything cd/dvd R/RW related. anything printer or scanner related. Firewire stuff, palm synch stuff, bluetooth. In fact, anything which isn't REQUIRED for a usable graphical environment. Don't want them removed from the defaullt install, just want to be able to remove them if I have no use for them.
ie, i have no bluetooth, no firewire device no cd/dvd writer and no scanner or printer, but i'm stuck with all this gumph i can and will never use on this system..

FrankyT (theroarenator) wrote :

well, Gimp for one. I also probably won't need OpenOffice or Evolution on this box. as close as I can tell, the only reason that these are listed as required, is that adminsitration interfaces have been included in the ubuntu-desktop. that implies that they didn't want to mandate checking for package install before running the admin tool, so the dealt with the problem by attaching the dependency.

perhaps not the most user friendly option available. I have seen references online to ways to break these dependency links manually, but I have to look into it further.

Markus Majer (mpathy) wrote :

Oh yes, Evolution, this unstable email client.. ;)

I could add much much more, who should be recommends rather than depending.

This is a bigger issue, I think, and I hope that could be solved in the next releases.

Because without that, we cannot install here, the desktops we want, without harming the stability or usabiltiy of our systems caused by the automatic removing of the ubuntu-desktop.

The problem also causing a many of the (relatively few) bad reviews for Ubuntu:
https://lists.ubuntu.com/archives/sounder/2006-June/007465.html

So it is more important than this bug report reads.

FrankyT (theroarenator) wrote :

Actually I'm thinking it's almost a non-issue, having gotten around to doing some testing. I do have a few recommendations however.

I had seen earlier in the thread, and elsewhere, that removing the ubuntu-desktop package by itself does nothing, because it is a meta-package. I had trouble getting a confirmation on that however so I tried it on a box i was rebuilding (bye bye vista!).

Removing one piece of Ubuntu-desktop prereq software (lets say xsane) does remove xsane and the ubuntu-desktop meta-package (since you no longer have all the sub-components), but DOES NOT remove any other packages referred to by Ubuntu-desktop. this is the behavior I was unclear on. Like others I was concerned that this action would remove gnome and everything else GUI oriented.

so my recommendation is to make that information more easily available. perhaps a message box or some other form of user notification that this action is not inadvertently harmful to the rest of your desktop environment.

I can see that others on the thread are complaining of bloat in the default package. I can understand that, coming from a windows background, but being a bit of a n00b, if a competent one, I do appreciate at least some of the bundling. besides, it you install ubuntu server, it's really easy to install the gui with apt-get, since you only need to call the one package

I agree with others above who have requested an install-time software/services selection tool. that way we could check/uncheck boxes to install optional packages. the one thing synaptic is bad at is suggesting a n00b what they want and need. canonical handles this by bundling common supported software, to make sure that whatever we need, it is ready to go.

so to sum up:
1) notify the user that removing xsane and ubuntu-desktop will not remove gnome or any other dependent packages.

2) give better control to advanced users over what software is installed, before it is installed, so that they can pick and choose the packages that are right for them.

Happy new years folks

my problem is that if ubuntu-desktop is removed it will mean that new
features added between releases as recommends of ubuntu-desktop will not be
pulled in. I don't mind some bundling, but there is no reason that anything
non-essential is marked as a dependency, it should be a recommended package
instead. For example, if i don't have and will never have a printer attached
or a scanner or a CD/DVD drive why can't I remove all the related packages
without damaging the upgrade-ability of my system?

On Dec 30, 2007 7:36 PM, FrankyT <email address hidden> wrote:

>
> Actually I'm thinking it's almost a non-issue, having gotten around to
> doing some testing. I do have a few recommendations however.
>
> I had seen earlier in the thread, and elsewhere, that removing the
> ubuntu-desktop package by itself does nothing, because it is a meta-
> package. I had trouble getting a confirmation on that however so I tried
> it on a box i was rebuilding (bye bye vista!).
>
> Removing one piece of Ubuntu-desktop prereq software (lets say xsane)
> does remove xsane and the ubuntu-desktop meta-package (since you no
> longer have all the sub-components), but DOES NOT remove any other
> packages referred to by Ubuntu-desktop. this is the behavior I was
> unclear on. Like others I was concerned that this action would remove
> gnome and everything else GUI oriented.
>
> so my recommendation is to make that information more easily available.
> perhaps a message box or some other form of user notification that this
> action is not inadvertently harmful to the rest of your desktop
> environment.
>
> I can see that others on the thread are complaining of bloat in the
> default package. I can understand that, coming from a windows
> background, but being a bit of a n00b, if a competent one, I do
> appreciate at least some of the bundling. besides, it you install ubuntu
> server, it's really easy to install the gui with apt-get, since you only
> need to call the one package
>
> I agree with others above who have requested an install-time
> software/services selection tool. that way we could check/uncheck boxes
> to install optional packages. the one thing synaptic is bad at is
> suggesting a n00b what they want and need. canonical handles this by
> bundling common supported software, to make sure that whatever we need,
> it is ready to go.
>
> so to sum up:
> 1) notify the user that removing xsane and ubuntu-desktop will not remove
> gnome or any other dependent packages.
>
> 2) give better control to advanced users over what software is
> installed, before it is installed, so that they can pick and choose the
> packages that are right for them.
>
> Happy new years folks
>
> --
> [Gutsy] unnecessary packages in ubuntu-desktop dependencies?
> https://bugs.launchpad.net/bugs/122039
> You received this bug notification because you are a direct subscriber
> of the bug.
>

+1 to the answer of "Prosthetic Head" - I couldnt answer better.

@FrankyT: I personally did know that if the ubuntu-desktop is removed, all the other packages attached to it won't be removed also. First, because I am working with Debian and Ubuntu together almost 10 years know, I believe - and I think also, that a clever newbie will also don't think that, because it just would make no sense! That is not the point. (But it could be solved very easily, I could solve it, with my average packaging knowledge..)

It is just the point, the user above pointed out!

It was not only for fun, that I added the following link like above:
https://lists.ubuntu.com/archives/sounder/2006-June/007465.html

Read it, and also the link included in there, so you find out, what the real problem is, and what problems a user might get, without knowing that it has its origin in removing a package that removes ubuntu-desktop which ends in a not properly upgraded system.

FrankyT (theroarenator) wrote :

@Markus/Head

so I should reinstall ubuntu-desktop before upgrading huh? that works. glad I found out now. so I guess there is no answer to the bloat issue after all.

oh well,
thanks folks!

Philipp Meier (meier-philipp) wrote :

I think this bug is still one that needs to be fixed. But the improvement is definitely remarkable.

I totally agree with the point, that everything is a recommendation (which is possible) instead of an requirement. I would prefer a ubuntu system where everything (except the software to manage the system and a desktop environment -> e.g something like gnome-minimal) is optional, but set up after a fresh install.

Colin Watson (cjwatson) on 2008-08-19
Changed in ubuntu-meta:
assignee: kamion → nobody
Colin Watson (cjwatson) wrote :

The more people keep tacking on additional package names to this bug, the less likely it is that it will ever be fixed because it's a pain to trawl through for information.

Please file a *new* bug for each package whose status you feel should be changed.

(I just dropped tsclient and gnome-pilot-conduits to Recommends.)

description: updated

Colin it would probably better if one of the developers just had a critical look at the current dependencies and made them recommends where appropiate.

Agreed. just changing linking on the few packages mentioned here would not
really help the issue. someone needs to look at it as a whole and adjust
accordingly.

On Mon, Sep 1, 2008 at 4:52 PM, Wouter Stomp <email address hidden> wrote:

> Colin it would probably better if one of the developers just had a
> critical look at the current dependencies and made them recommends where
> appropiate.
>
> ** Summary changed:
>
> - [Gutsy] unnecessary packages in ubuntu-desktop dependencies?
> + Unnecessary packages in ubuntu-desktop dependencies?
>
> --
> Unnecessary packages in ubuntu-desktop dependencies?
> https://bugs.launchpad.net/bugs/122039
> You received this bug notification because you are a direct subscriber
> of the bug.
>

--
Thank You,
Jeremy Rohrer
<email address hidden>

Mathew Hodson (mathew-hodson) wrote :

None of the packages mentioned in this bug are dependencies of ubuntu-desktop since at least trusty.

summary: - Unnecessary packages in ubuntu-desktop dependencies?
+ ubuntu-desktop should not depend on xsane or espeak
Changed in ubuntu-meta (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers