Hoary ubuntu-desktop still depends on python 2.3

Bug #11367 reported by David Wynn on 2004-12-22
4
Affects Status Importance Assigned to Milestone
ubuntu-meta (Ubuntu)
Medium
Colin Watson

Bug Description

Hoary ubuntu is supposed to have upgraded to python 2.4, but the current ubuntu-desktop still depends on a number of Python 2.3
packages:
python2.3-dbus
python2.3-dictclient
python2.3-librdf
python2.3-pycurl
python2.3-samba

Colin Watson (cjwatson) wrote :

We're working on cleaning up the last couple of pieces of this migration.

Colin Watson (cjwatson) wrote :

ubuntu-meta (0.11) hoary; urgency=low

  * Sort package names in output of update script.

  * Refreshed from seed lists and package archive
  * Removed libxml2-python2.3 from desktop-i386
  * Added libxml2-python2.4 to desktop-i386
  * Removed libxslt1-python2.3 from desktop-i386
  * Added libxslt1-python2.4 to desktop-i386
  * Removed python2.3-dbus from desktop-i386
  * Removed python2.3-dictclient from desktop-i386
  * Removed python2.3-librdf from desktop-i386
  * Removed python2.3-pycurl from desktop-i386
  * Removed python2.3-samba from desktop-i386
  * Added python2.4-dbus to desktop-i386
  * Added python2.4-dictclient to desktop-i386
  * Added python2.4-librdf to desktop-i386
  * Added python2.4-pycurl to desktop-i386
  * Added python2.4-samba to desktop-i386
  * Removed libxml2-python2.3 from desktop-amd64
  * Added libxml2-python2.4 to desktop-amd64
  * Removed libxslt1-python2.3 from desktop-amd64
  * Added libxslt1-python2.4 to desktop-amd64
  * Removed python2.3-dbus from desktop-amd64
  * Removed python2.3-dictclient from desktop-amd64
  * Removed python2.3-librdf from desktop-amd64
  * Removed python2.3-pycurl from desktop-amd64
  * Removed python2.3-samba from desktop-amd64
  * Added python2.4-dbus to desktop-amd64
  * Added python2.4-dictclient to desktop-amd64
  * Added python2.4-librdf to desktop-amd64
  * Added python2.4-pycurl to desktop-amd64
  * Added python2.4-samba to desktop-amd64
  * Removed libxml2-python2.3 from desktop-powerpc
  * Added libxml2-python2.4 to desktop-powerpc
  * Removed libxslt1-python2.3 from desktop-powerpc
  * Added libxslt1-python2.4 to desktop-powerpc
  * Removed python2.3-dbus from desktop-powerpc
  * Removed python2.3-dictclient from desktop-powerpc
  * Removed python2.3-librdf from desktop-powerpc
  * Removed python2.3-pycurl from desktop-powerpc
  * Removed python2.3-samba from desktop-powerpc
  * Added python2.4-dbus to desktop-powerpc
  * Added python2.4-dictclient to desktop-powerpc
  * Added python2.4-librdf to desktop-powerpc
  * Added python2.4-pycurl to desktop-powerpc
  * Added python2.4-samba to desktop-powerpc

 -- Colin Watson <email address hidden> Wed, 22 Dec 2004 14:14:49 +0000

Not quite finished, though, as a few dependencies of ubuntu-desktop still depend
on python2.3. I'll leave this bug open until that's complete.

Colin Watson (cjwatson) wrote :

This should be the last of it:

gnome-doc-utils (0.1-0ubuntu2) hoary; urgency=low

  * debian/control.in:
    - Build-depend on python2.4.
    - Depend on libxml2-python2.4 rather than libxml2-python2.3, plus
      ${python:Depends}.
  * debian/rules:
    - Force PYTHON=python2.4, since there's no default-python-version
      package for libxml2-python.
    - Call dh_python in order to get proper python dependencies.

 -- Colin Watson <email address hidden> Wed, 22 Dec 2004 16:12:40 +0000

Colin Watson (cjwatson) wrote :

I've verified that installing ubuntu-desktop on a clean Hoary base system no
longer causes python2.3 to be selected for installation, so this bug is fixed.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.