xterm and gnome-terminal should not be dependencies

Bug #1116791 reported by Nafallo Bjälevik on 2013-02-06
14
This bug affects 2 people
Affects Status Importance Assigned to Milestone
ubuntu-meta (Ubuntu)
Medium
Oliver Grawert
xinit (Ubuntu)
Wishlist
Unassigned
xorg (Ubuntu)
Wishlist
Unassigned

Bug Description

 Hi,

ubuntu-desktop depends on xterm and gnome-terminal. xorg is a dependency as well, and in turn depends on xterm | x-terminal-emulator. Something is wrong here. I'd say either removing the depends on the terminal emulators from ubuntu-desktop or, in case of xorg getting replaced at some point, depend on xterm | x-terminal-emulator here too...

Best wishes, Nafallo

ProblemType: Bug
DistroRelease: Ubuntu 13.04
Package: ubuntu-desktop 1.293
ProcVersionSignature: Ubuntu 3.8.0-4.8-generic 3.8.0-rc6
Uname: Linux 3.8.0-4-generic i686
NonfreeKernelModules: wl
ApportVersion: 2.8-0ubuntu4
Architecture: i386
Date: Tue Feb 5 23:58:17 2013
EcryptfsInUse: Yes
InstallationDate: Installed on 2011-10-09 (485 days ago)
InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Beta i386 (20111007.1)
MarkForUpload: True
SourcePackage: ubuntu-meta
UpgradeStatus: Upgraded to raring on 2012-12-07 (60 days ago)

Nafallo Bjälevik (nafallo) wrote :
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in ubuntu-meta (Ubuntu):
status: New → Confirmed
Adolfo Jayme (fitojb) wrote :

Why is wrong to have a terminal? AFAIK, it doesn't bite...

Changed in ubuntu-meta (Ubuntu):
status: Confirmed → Incomplete
Ma Hsiao-chun (mahsiaochun) wrote :

Have you read the origin report?

ubuntu-desktop depends on xorg and xorg depends on a terminal emulator, good enough.

But now ubuntu-desktop depends on xterm and gnome-terminal directly.
http://packages.ubuntu.com/raring/ubuntu-desktop

Changed in ubuntu-meta (Ubuntu):
status: Incomplete → Confirmed
Oliver Grawert (ogra) wrote :

will demote them to recommends as soon as the beta image is released (hopefully later today)

Changed in ubuntu-meta (Ubuntu):
assignee: nobody → Oliver Grawert (ogra)
importance: Undecided → Medium
Oliver Grawert (ogra) wrote :

added tasks for xorg and xinit, they both have hard deps on xterm, the xorg team needs to inspect if it is safe to demote it there as well

Changed in xinit (Ubuntu):
importance: Undecided → Medium
Changed in xorg (Ubuntu):
importance: Undecided → Medium
Bryce Harrington (bryce) wrote :

For the xorg source package it looks like the dependency was added long ago just as a convenience to ensure a terminal program was included. Possibly there might be a debian failsafe session that pops it up, but I'm not spotting evidence of such; in any case that wouldn't be important to us.

For the xinit package, xterm is the default program run if no window manager is used, so it's a more legitimate dependency there. However, we use lightdm rather than xinit in our boot process (e.g. creating a ~/.xinitrc that echos to a file and rebooting doesn't generate the file; and I don't see xinit listed in a raring bootchart). xinit is used if you start x using the `startx` command, but that's not really a use case for us. There might be other use cases where xinit is important, but for a regular desktop session I think it may be just vestigial.

Oliver Grawert (ogra) wrote :

i guess at least using x-terminal-emulator as the dep would help so it is enough to have only one terminal installed

Oliver Grawert (ogra) wrote :

oh, and i wonder if instead of breaking xinit for the users that use it by dropping the dep or demoting xterm to x-terminal-emulator if we could probably just get away with not shipping it at all on the desktop (indeed that gets us in debugging hell where users are asked to run startx to produce a log etc, but we could just document that you have to install xinit in such cases)

Oliver Grawert (ogra) on 2013-04-10
Changed in ubuntu-meta (Ubuntu):
status: Confirmed → Fix Released
Bryce Harrington (bryce) wrote :

Perhaps that's a good thing to experiment with in S? I'm reticent to drop it from raring given how late in the game we are, since we don't know exactly what that'd break...

Changed in xorg (Ubuntu):
status: New → Triaged
importance: Medium → Wishlist
Changed in xinit (Ubuntu):
importance: Medium → Wishlist
status: New → Triaged
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers