Ubuntu

FFE: network-manager-pptp isn't installed by default

Reported by BaBL on 2007-04-19
580
This bug affects 125 people
Affects Status Importance Assigned to Milestone
One Hundred Papercuts
Undecided
Unassigned
ubuntu-meta (Ubuntu)
Wishlist
Martin Pitt
Declined for Dapper by Martin Pitt
Declined for Hardy by Martin Pitt
Declined for Intrepid by Martin Pitt
Declined for Jaunty by Martin Pitt
Declined for Karmic by Martin Pitt
Lucid
Wishlist
Martin Pitt

Bug Description

Binary package hint: network-manager-pptp

Most of Russia's ISPs provide Internet access through VPN!
How can I use the Internet if nm-vpn-properties doesn't work without network-manager-pptp!
I can't download this package, because I need Internet access, but I don't have this packet so I can enter the Internet!
Please, put this package into CD and DVD! And release 7.04.1 with this important package!

Steven Harms (sharms) wrote :

Can confirm this package exists in universe. Probably needs to be moved to wishlist. As feisty 7.04.1 will probably not be released, or atleast not for sometime, the workaround is to download the packages onto a CD from somewhere. Check out: http://aptoncd.sourceforge.net/

Changed in network-manager-pptp:
status: Unconfirmed → Confirmed
BaBL (babl1986) wrote :

Oh... Yes! Ubuntu is very userfriendly distribution! Download DVD disk and install windows to download packets, that needed for Internet connection in userfriendly Ubuntu =) Grats!

Steven Harms (sharms) wrote :

We are sorry for your frustration, but as you were not involved in development at any point, and pptp required by default install is a fringe case (< 1%) I don't know how we would have figured that out. This bug is a great start to getting this included for Gutsy, so you are on the right track.

gharz (canonbjc-210s) wrote :

hi, guys.

since 6.10, i am not able to connect through pptp (i was using pptpconfig)... i was expecting feisty would fix this issue... unfortunately, it did not.

i've installed network-manager network-manager-gnome and network-manager-pptp.

i run nm-applet... and everything seemed fine because i was able to create a vpn profile and the profile is selectable... but when i check the connection (sudo tail -f /var/log/syslog) it showed the following...

sudo tail -f /var/log/syslog
Apr 20 12:50:14 Ubuntu dhclient: DHCPDISCOVER on eth0 to 255.255.255.255 port 67 interval 11
Apr 20 12:50:25 Ubuntu dhclient: DHCPDISCOVER on eth0 to 255.255.255.255 port 67 interval 13
Apr 20 12:50:38 Ubuntu dhclient: No DHCPOFFERS received.
Apr 20 12:50:38 Ubuntu dhclient: No working leases in persistent database - sleeping.
Apr 20 12:50:46 Ubuntu gconfd (root-32353): GConf server is not in use, shutting down.
Apr 20 12:50:46 Ubuntu gconfd (root-32353): Exiting
Apr 20 12:51:10 Ubuntu NetworkManager: <information>^IUpdating allowed wireless network lists.
Apr 20 12:51:10 Ubuntu NetworkManager: <information>^IUpdating VPN Connections...
Apr 20 12:51:21 Ubuntu NetworkManager: <information>^IWill activate VPN connection 'VPN Secure', service 'org.freedesktop.NetworkManager.ppp_starter', user_name 'user', vpn_data 'ppp-connection-type / pptp / pptp-remote / 135.82.1.2 / usepeerdns / yes / encrypt-mppe / yes / encrypt-mppe-128 / no / compress-mppc / no / compress-deflate / no / compress-bsd / no / ppp-lock / yes / ppp-auth-peer / no / ppp-refuse-eap / yes / ppp-refuse-chap / no / ppp-refuse-mschap / no / mtu / 1416 / mru / 1416 / lcp-echo-failure / 10 / lcp-echo-interval / 10 / ppp-extra / / ppp-debug / no / usepeerdns-overtunnel / yes / routes / / use-routes / no', route ''.
Apr 20 12:51:21 Ubuntu NetworkManager: <WARNING>^I nm_vpn_manager_activate_vpn_connection (): nm_vpn_manager_activate_vpn_connection(): no currently active network device, won't activate VPN.

by the way, i'm using my wireless connection to connect to the internet and my wifi interface is eth1 not eth0.

please help

Oded Ben Ozer (odead) wrote :

Same problem here.
Most of Israel cable users(cable -as opposed to ADSL) use VPN to connect ,would be nice if i wouldn't have to download it before every install.

Andrey Larionov (anlarionov) wrote :

+1
I Have same issue. I donloaded distr in release day but not install yet because i know what pptp not avaliable without internet.

xoco (arthur.ivanov) wrote :

+1 Same issue ;(

very very bad ;(
i install ubuntu and can't get online ;( because PPTP not included by default.
anyway, after i get pptp and network manger i get same issue

Andrey Larionov (anlarionov) wrote :

I install fiesty and instal additional packages, such as pptp-linux and network-manager-pptp but have same issue as reported in https://bugs.launchpad.net/ubuntu/+source/network-manager-pptp/+bug/107738/comments/4

xoco (arthur.ivanov) wrote :

to gharz

this issue apper when Network Manager does not see active connection ...
try comman - "nm-tool"

i have same problem ... i have 2 nic eth0 eth1 configured staticaly .. and network manager does not detect it ;( and do not try connect... ;(
...
work around for me : set up eth1 at dhcp ... and nm-tool show this interface ... and pptp client success start.

Andrey Larionov (anlarionov) wrote :

I do some trick. Set eth0 interface in a roaming mode, then manual assign ip addresses (ifconfig), and connection via network manager was established but without routing table updates. It make this tool (NetworkManager) unuseful for me instead of pptpdconfig.

As pointed out by xoco and Andrey, if NetworkManager doesn't manage your connection (if it described in /etc/network/interfaces), then VPN plugins will not work.

I wouldn't suggest that this package be included in a default install until it was much more polished. I am not the original author, just the person tidying it up for Ubuntu; if someone wants to put in a bit of effort here, please get in touch.

rubinstein (rubinstein) wrote :

In Austria almost every DSL connection is PPTP, so here it is not the fringe case but the vast majority has PPTP. It therefore is absolutely required to include this package by default.

Fabián Rodríguez (magicfab) wrote :

@Steven Harms: there are no plans for any interim releases except for LTS releases. As such, there won' t be any other 7.04 releases. If this package is included in a future version of Ubuntu Live CDs, it would be Gutsy (7.10) or later.

The LiveCD is built from " seeds". To learn more about seeds managements, see:
https://wiki.ubuntu.com/SeedManagement

" * The installation CD contains the software in the Installer, Minimal, Standard, Desktop, and Ship seeds (and their dependencies)
    *The installation/live DVD contains the software in the Installer, Casper, Minimal, Standard, Desktop, Ship, Live, and Supported seeds (and their dependencies)
    * The live CD contains the software in the Casper, Minimal, Standard, Desktop, and Live seeds (and their dependencies)"

I would suggest proposing the package for inclusion in the Desktop seed.

Proposals for adding new packages to the seeds must follow this process:
https://wiki.ubuntu.com/MainInclusionProcess

Please prepare a report as described on that page and send the proposal and a link to the report to the ubuntu-devel mailing list at https://lists.ubuntu.com/mailman/listinfo/ubuntu-devel

GSMD (gsmdib) wrote :

The way this should get fixed:
- network-manager-pptp installed by default.
- VPN connections available even in case no interface is in roaming mode

Both issues are crucial.

Pirx (tkruemmer) wrote :

I live in a totalitarian country and for me being able to use PPTP or VPN is indispensible. As Microsoft has impressively demonstrated, security is one of the top issues whe it comes to computer operating systems and network connectivity, and it would be very hard to understand if such issues would not enjoy priority at Ubuntu.

My NM VPN and PPTP plugins worked flawlessly under 7.04, and now in 7.10 they are broken. As long as they do not work, I have to go back to Mac OS X.

I'm in Gutsy and there is no way to running the VPN connection. It configures nicely, but the option to connect doesn't appears. I have tried with roaming and no roaming, with DHCP and static, but neither works. (I'm sad because it worked perfect in Feisty).

gharz (canonbjc-210s) wrote :

same problem experiencing by manuel salvador... VPN connection that i have set up with 7.04 before upgrading to 7.10 doesn't work now. kinda disappointing though.

Dave roi (daveroi) wrote :

I highly request this as well.
In my country, the only way to NOT use some kind of dialer (PPTP or L2TP) is to buy a router.
You can't expect people to buy a router just so they can use Linux.

Dave.

Pirx (tkruemmer) wrote :

A question to the experts: If I un-install the current version of network-manager and compile an old version of network-manager under Gutsy, can I have the old VPN/PPTP functionality back or will it fail on the dependencies?

Hi again. Now it works fine, maybe some update fix it... Thanks!

Pirx (tkruemmer) wrote :

Martin, what configuration? With fixed IP? In roaming mode? Wireless or wired?

I have only tried wired and wireless both in roaming mode, and works ok.

roaming mode works ok... try using static ip address and with WPA-PSK TKIP. it doesn't work on my part.

----- Original Message ----
From: Manuel Martín Salvador <email address hidden>
To: <email address hidden>
Sent: Friday, November 2, 2007 7:53:37 PM
Subject: [Bug 107738] Re: network-manager-pptp isn't installed by default

I have only tried wired and wireless both in roaming mode, and works ok.

--
network-manager-pptp isn't installed by default
https://bugs.launchpad.net/bugs/107738
You received this bug notification because you are a direct subscriber
of the bug.

__________________________________________________
Do You Yahoo!?
Tired of spam? Yahoo! Mail has the best spam protection around
http://mail.yahoo.com

Ralph Janke (txwikinger) on 2008-03-04
Changed in network-manager-pptp:
importance: Undecided → Wishlist
Dave roi (daveroi) on 2008-04-13
description: updated

> pptp required by default install is a fringe case (< 1%)
Wrong.Actually this point of view is more than just an error.
For example, here in Russia LOTS of Ethernet-based ISPs and they are using VPN mostly for authentication purposes.
Actually, in my city, ISP "Corbina Telecom" is some Ethernet-based ISP which holds slightly over 13% total user base, this is well over 100 000 peoples in total and uses PPTP (or L2TP at your option) VPN to grant users Internet access.Other Ethernet-based ISPs are doing same.So actually situation is MUCH WORSE.Actually, PPTP VPN is one of major internet access methods in Russia.All recent Windows version allow easy creation of PPTP connection with default OS install.So Windows users are NEVER encounter this problem.Not a case with Ubuntu though.

Furthermore, due to this sad fact lots of users are getting poor experience that "Linux is crap and never works fine out of the box".Since when you need to download package to be able to access the Internet this is not so funny.Do you remember "pkunzip.zip" joke? :)

P.S.: even small Linux-based routers are including pptp client configurable via web face.Amazing that fully-weighted desktop system still fails to do very basic thing.Priority of this bug is strongly underestimated, at least for Russia this one is "Critical" - without network Ubuntu has no chances to outperform Windows.

Dave roi (daveroi) wrote :

Hi,

ALL!!! the ISPs in Israel require a PPTP dialer.
The only way to not use a PPTP dialer is to buy a router which does the dialing for you.

This bug is a critical one in Israel as well.

David.

P.S I have created an Ubuntu brainstorm request for this. Everyone affected, please vote and be heard!
http://brainstorm.ubuntu.com/idea/6961/

Thanks.

tonnzor (tonn81) wrote :

+1

Please, add this small but show-stopper package to ubuntu CD and DVD. Maybe only 5% will use it, but it would solve a lot of problems for them.

By the way, I think CD/DVD must contain support for all protocols used by ISPs. I'm sure it would take less than a few megabytes.

liorda (liorda) wrote :

+1

How can anyone say Ubuntu is working out-of-box when fundamental feature as *internet connection* is missing?!

Ansus (neptunia) wrote :

This is not a fring case, but a case of 80% of internet users in Russia and Ukraine.

Ansus (neptunia) wrote :

Winth network-manager-pptp package all worked well to me. If you have some problems with routes and roaming, consider opening a new bugreport.

Ansus (neptunia) wrote :

This bug on Ubuntu brainstorm: http://brainstorm.ubuntu.com/idea/9895/

Lex Ross (lross) wrote :

Network-Manager-PPTP is now included with Intrepid thank you very much. However, pptp-linux located on desktop CD is not installed by default. As a result, no VPN connection can be configured. There is no way to add VPN connection using Live Session even when pptp-linux is being manually installed, since then system restart is required.

Ansus (neptunia) wrote :

It seems it has not been included in Intrepid. People still report problems and use Windows to download this package.

wiz (wiz) wrote :

Still not included on jaunty dvd a5.

bb (i-filter-your-spam) wrote :

My School (Austria) requires a PPTP VPN as well.

bb (i-filter-your-spam) wrote :

This bug is perfect for the One Hundred Paper Cuts Project!!!

Ansus (neptunia) wrote :

It seems it's the distribution's policy not to include the packag. Otherwise it would be included long ago.

Martin Albisetti (beuno) wrote :

Thank you for bringing this bug to our attention. Unfortunately a paper cut should be a small usability issue that affects many people and is quick and easy to fix. I'm afraid this bug can't be addressed as part of this project.
A paper cut is a minor usability annoyance that an average user would encounter on his/her first day of using a new installation of Ubuntu 9.10.

Changed in hundredpapercuts:
status: New → Invalid
Ansus (neptunia) wrote :

This is namely usability annoyance that average user encounter in the very first day as he/she cannet connect Internet. And this is quick and easy to fix.

Changed in hundredpapercuts:
status: Invalid → New
status: New → Confirmed
Vish (vish) wrote :

@Ansus: If a new package needs to added it is *not* a papercut.
For further info about papercuts criteria , pls read > https://wiki.ubuntu.com/PaperCut

Don't worry though, This bug has been marked as "invalid" ONLY in the papercuts project.

Changed in hundredpapercuts:
status: Confirmed → Invalid
Ansus (neptunia) wrote :

This package already ADDED to the rtepository. Only one thing is needed - to add it to the default install.

Ansus (neptunia) wrote :

This bug still in Karmic: the both packages are not included into intallation CD.

xoco (arthur.ivanov) wrote :

yep. allmost anyone in russia who install Ubuntu can't turn on internet.

funny situation:
you can't be online be cause you don't have network-manager-pptp
if you want install network-manager-pptp - you must be online.

VeGeek (vegeek) wrote :

As I understand, Ubuntu developers are absolutely inadequate:
https://bugs.launchpad.net/ubuntu/+source/ubuntu-meta/+bug/417715/comments/3
Why not include this fucking package on this fucking CD?

Alexander Sack (asac) wrote :

> yep. allmost anyone in russia who install Ubuntu can't turn on internet.

i was not aware that thats the case. why is that so? what percentage of russian internet users must use pptp to get online?

ojab (ojab) wrote :

oh shi~~

It should be 100 papercuts fixed, but not trivial bug affecting _many_ users since 2007.

Strange policy, yeah.

Great amount of russian users... I'm from Russian Federation, so believe me.
If you don't want to believe, so you can visit some ISP's sites and
find network configuration manuals.
Most of them give you a choise:
1) Use authorisation utility (it means "USE WINDOWS!!!")
2) Use VPN (unfortunately it means the same for many new Ubuntu users)

P.S. not everyone can buy or use routers. I can say more... not every
one know about them.
So it's very very very actual problem.

2009/10/7 Alexander Sack <email address hidden>:
>> yep. allmost anyone in russia who install Ubuntu can't turn on
> internet.
>
> i was not aware that thats the case. why is that so? what percentage of
> russian internet users must use pptp to get online?
>
> --
> network-manager-pptp isn't installed by default
> https://bugs.launchpad.net/bugs/107738
> You received this bug notification because you are a direct subscriber
> of the bug.
>
> Status in One Hundred Paper Cuts: Invalid
> Status in "network-manager-pptp" package in Ubuntu: Confirmed
>
> Bug description:
> Binary package hint: network-manager-pptp
>
> Most of Russia's ISPs provide Internet access through VPN!
> How can I use the Internet if nm-vpn-properties doesn't work without network-manager-pptp!
> I can't download this package, because I need Internet access, but I don't have this packet so I can enter the Internet!
> Please, put this package into CD and DVD! And release 7.04.1 with this important package!
>

--
С наилучшими пожеланиями!
Олег АндреичЪ

In Israel most of the clients of the cable company use pptp/l2tp ,I estimate its at least 30% of all the Internet users.
so we need pptp too ...

xoco (arthur.ivanov) wrote :

just for example,
in moscow (more than 13million peoples) 80% ISP uses PPTP/L2TP over Ethernet, 20% uses PPoE over DSL

Fabián Rodríguez (magicfab) wrote :

I am changing this to high, following guidelines at https://wiki.ubuntu.com/Bugs/Importance
High: A bug which fulfills one of the following criteria:
* Has a severe impact on a small portion of Ubuntu users (estimated)
* Makes a default Ubuntu installation generally unusable for some users

Unfortunately voting on Brainstorm seems like a dead end, as several similar issues have been opened and this specific problem has been marked as duplicate/merged into other more general ones.

Instead of posting "me too" type of comments please click on the "Does this bug affect you" link.

On a default Karmic install installing this package would require the following dependencies:
network-manager-pptp pptp-linux

Downloading those two manually would presumably be a (suboptimal, I know) workaround.

Changed in network-manager-pptp (Ubuntu):
importance: Wishlist → High
userplayer123 (fritzz) wrote :

This bug affects me too

Alexander Sack (asac) wrote :

> in moscow (more than 13million peoples) 80% ISP uses PPTP/L2TP over Ethernet, 20% uses PPoE over DSL

the odd thing is that this package is about a VPN ... not about a PPTP for dialing up a network connection. Are you sure that this package actually helps? or are you saying you just want pptp-linux by default and hope that will happen if we install network-manager-pptp (the VPN solution) by default.

Artem Popov (artfwo) wrote :

pptp-linux is already included on the Ubuntu CD (as an extra package in dists/pool). It will be enough for all PPTP/VPN-based ISPs to include network-manager-pptp package on the CDs as well. Our local LUG actually distributes Ubuntu CDs remastered in such a way (with an extra nm-pptp package) - it satisfies most of the users.

Installing pptp stack by default may be an overkill, but a network-manager-pptp.deb package is a must have in the ISO...

Ansus (neptunia) wrote :

> Are you sure that this package actually helps?

Yes.

pptp-linux technically allows to establish Internet coinnection but requires editing config files by hands which is unintuitive and also requires internet to search the appropriate cofiguration in forums.

network-manager-pptp allows to do this by simply clicking with mouse. (although currently it does not automatically reestablish the connecthion after reboot and requires manually entering password each time)

Артём Попов is right that some Russian ISPs went so far as releasing their own Ubuntu remixes with network-manager-pptp installed by default. So does Russian Runtu remix.

I disagree with Artem on that this is not necessary for default install: how a newbie Linux user would know which package he has to install to enter the Internet? Only if he knows from previous experience what packages he needs, he can connet the Internet without trouble. In Windows and MacOS all tools needed to establish PPTP connection already included in the default installation. User only needs enter their password to connect to the Internet.

Alatarr (alatarr) wrote :

Good day! Lack pptp-linux network-manager-pptp from release to release brings the problem to me. Virtually all providers of Ukraine for home and corporate access is provided through a connection vpn pptp.
That is, after the installation of the majority of users in Ukraine have again put Windows, or download these packages through a PC with friends or the Internet club. For the first time before putting 8,10 for several days I was looking for these packages. Include them in the release, please!

Ansus (neptunia) wrote :

I've used network-manager-pptp for about a year, but now I use a text config file I found on the forum of my Internet provider, because it is boring to enter your password each time after reboot. But using text configs should not be recommended to non-professional users.

Another problem is that after connection to Internet with network-manager-pptp, I used to loose the routes to the local LAN. If I wanted simultanious access to LAN and Internet, I had to run a special script with routes. Now I wrote all routes into a text config file. Note that under Windows all routes obtained automatically via DHCP so no need to inscribe them specially.

Anyway, to set up a NM-free configuration I had to consult the Internet which would be impossible without NM-pptp.

Alexander Sack (asac) wrote :

ok thanks for the explanation. i was not really aware that any provider needs the VPN plugin to get connected. sorry for that. unfortunately its too late for karmic to get anything additional on the CD, so Lucid it will be. Thanks again!

Changed in network-manager-pptp (Ubuntu):
assignee: nobody → Alexander Sack (asac)
milestone: none → later
status: Confirmed → Triaged
importance: High → Wishlist
Alexander Sack (asac) wrote :

Ansus, the "need to reenter password after each bott" is a separate bug you should file agains this package.

Ivanov1965 (post-2) wrote :

This problem affect me too.

I think if there have been any doubts, if or not to include network-
manager-pptp by default, should have vanished.

Thomas

[cel] +86 1381-669-2688
[eml] <email address hidden>
[pgp] <https://keyserver2.pgp.com/vkd/DownloadKey.event?
keyid=0x07826DD61741D917>

Ivanov1965 <email address hidden> wrote on Saturday, October 10, 2009 at 6:25 AM
+0000 GST

>This problem affect me too.
>
>--
>network-manager-pptp isn't installed by default
>https://bugs.launchpad.net/bugs/107738
>You received this bug notification because you are a direct subscriber
>of the bug.
>
>

Vish (vish) on 2009-10-10
affects: hundredpapercuts → null

> Installing pptp stack by default may be an overkill, but a network-manager-pptp.deb package is a must have in the ISO...

Or maybe not. Full PPTP support is only 200k (compressed) and:
1) Manually installing a deb is not as user-friendly as having support just there when you need it.
2) I usually don't know all the networks I'll want my netbook to connect to at install time (and I don't carry round the ISO round with my netbook).

Alexander Sack (asac) on 2009-10-12
Changed in network-manager-pptp (Ubuntu):
status: Triaged → In Progress
PowerUser (i-am-sergey) wrote :

I filed bugs about this crappy PPTP situation THREE YEARS AGO! Because of importance of this problem. And yet nothing changed... Can I hope to see PPTP at least in 9.10 Ubuntu and Kubuntu releases finally working? So it could be finally used by Russian (and other ex-USSR countries) users, etc. Without PPTP many people (MILLIONS of users!) would lack access to Internet due to ISPs specifics. And once you have no internet, you're obviously out of luck with Ubuntu at all. And thanks to triagers for sabotaging this issue so long and failing to recognize it's importance.

Importance = Wishlist <- Are you guys KIDDING or TRIAGING BUGS after all? If issue of this scale is a "wish list", you can also set bug #1 priority to something like this as well. So here we are, sucking with 97% of Windows market share. That's your fault as well. I tried my best to bring this to triagers attention within THREE YEARS. However that failed so far. Right now there is GUI to configure PPTP but no PPTP package itself so that's looking like a bad joke for users. Come on, guys, do not let Windows to take whole market in one face!

Matthew Paul Thomas (mpt) wrote :

Neither of those are true for Ubuntu. This bug is #40 on the list, not #1, and none of the other bugs in the first 75 are related to network-manager-pptp. <https://bugs.launchpad.net/ubuntu/+bugs?orderby=-users_affected_count>

Hans Bakker (hansmbakker) wrote :

It is very intuitive that when you add a VPN-connection with network-manager-kde (the vpn tab is there), you can't connect to it. Most people will not think of installing this plugin as a solution for their problem.

PowerUser (i-am-sergey) wrote :

> This bug is #40 on the list, not #1
Launchpad design seems to have a major flaw: when duplicate bug being filed, it's votes not seems to get summed up to original bug. At least, when I created bug and it become duplicate. I was listed as "affected" on my bug but was not listed as affected in bug which is original for my duplicate. Now guess how many people would bother themselves to come here and vote for original bug as well after their bug marked as duplicate. I bet almost nobody does, so I'm afraid your counters could be screwed up because PPTP bug had MANY duplicates.

And this bug quite grave on some areas. For exampe in Russia most of ISPs are using PPTP to provide access to Internet. Without Internet Ubuntu is virtually useless. Ancient WinXP allows to create PPTP connection out of the box. But Ubuntu does not AND that's what prevents a MILLIONS of ISP subscribers from giving it a try.

Ansus (neptunia) wrote :

Not only WinXP but any Windows version starting from Win95 and also MacOS.

Subsanek (subsanek) wrote :

Some problem!

On Sun, Nov 08, 2009 at 12:03:23PM -0000, Hans Bakker wrote:
> It is very intuitive that when you add a VPN-connection with network-
> manager-kde (the vpn tab is there), you can't connect to it. Most people
> will not think of installing this plugin as a solution for their
> problem.

thats a separate problem which is knetworkmanager specific. please file a
separate bug against that package for this.

 - Alexander

Is network-manager-pptp package already included in Ubuntu 10.04 Lucid Lynx Alpha-2 LiveCD?

Edik (ed-skm) on 2010-01-19
Changed in network-manager-pptp (Ubuntu):
status: In Progress → Confirmed
status: Confirmed → Fix Committed
status: Fix Committed → New
status: New → Fix Released
status: Fix Released → In Progress
Alexey Osipov (lion-simba) wrote :

Checked Lucid Lynx Alpha 2 Desktop CD. It still not contain network-manager-pptp package. :(

Any help needed? What people ping required to push things in right way? :)

Artyom Smirnov (smirnoffjr) wrote :

Three years of moaning to include little package which provide base functionality to distributive and still no movements...

Shahar Or (mightyiam) wrote :

Size: 148140

Common. Perhaps address the Ubuntu Desktop Team.

Alexey Osipov (lion-simba) wrote :

As I figured out, only officially supported packages can be added to the CD.
So, we need to wait for network-manager-pptp complete MIR procedure: https://bugs.launchpad.net/ubuntu/+source/network-manager-pptp/+bug/524573

Vish (vish) wrote :

@Shahar Or : Kindly read comments #38 and #40.

Adding new package is not a papercut task .Such decisions regarding adding new packages need to be discussed in the desktop mailing list.
Kindly bring up this discussion in the mailing list. > http://lists.ubuntu.com/mailman/listinfo/ubuntu-desktop

Changed in hundredpapercuts:
status: New → Invalid
Ansus (neptunia) wrote :

> Adding new package is not a papercut task

This is not about adding new package to Ubuntu.

Changed in hundredpapercuts:
status: Invalid → New
Ansus (neptunia) wrote :

How PPTP VPN connection is supported in other operating systems?

- Windows: Supported from Windows 95

- MacOS: Supported from MacOS X 10.2

- OpenSUSE: Supported in Yast long ago (at least from OpenSuse 10.1), additionally recently added Networ Manager to the default install, so there are 2 ways to choose

- Fedora: Network Manager added to default install

- eComStation: eCSCoNet - included in default shipping

Vish (vish) wrote :

Will people kindly stop re-opening the papercuts task , without reading what the project is about!

- the nm-pptp package is not a package in the default install. Including this pacage by default is not a papercut task.

Papercuts are a design task for identifying and fixing design bugs/flaws in softwares.

Including the package needs to be dealt with in the nm task. There is _no_ use in simply re-opening the papercut task. It will not fix the problem here.

For further information about papercuts criteria, please read https://wiki.ubuntu.com/PaperCut.

Don't worry though, this bug has been marked as "Invalid" only in the papercuts project.

Changed in hundredpapercuts:
status: New → Invalid
flint2000 (sergey-sidore) wrote :

This bug affects me too

suslikk (suslikkreal) wrote :

I hope it's will in 10.04 :) Waiting...

Martin Pitt (pitti) wrote :

I just approved the MIR in bug 524573. With 0.8, -pptp has become a first-class citizen plugin upstream, so support should get much better from their side.

I subscribed ubuntu-release for approving the FFE.

summary: - network-manager-pptp isn't installed by default
+ FFE: network-manager-pptp isn't installed by default
affects: network-manager-pptp (Ubuntu Lucid) → ubuntu-meta (Ubuntu Lucid)
Changed in ubuntu-meta (Ubuntu Lucid):
milestone: later → ubuntu-10.04-beta-1
Steve Langasek (vorlon) wrote :

I think this barely requires an FFe. Approved, in any case.

(Should this really be directly seeded, or should network-manager Recommend: it?)

Shahar Or (mightyiam) wrote :

The latter.

Subsanek (subsanek) wrote :

In Kubuntu some problem

Steve,

My take on it is that while network-manager could Recommend network-manager-pptp, in the case of the ubuntu seeds, the network-manager-pptp-gnome package would have to be seeded (otherwise PPTP is pretty much useless). For the kubuntu seeds, network-manager-pptp is sufficient (and seeding -pptp-gnome would bring in unnecessary gnome dependencies).

Martin Pitt (pitti) wrote :

I think for beta-1 we'll just seed both; eventually n-m should grow a Recommends: -pptp.

Changed in ubuntu-meta (Ubuntu Lucid):
assignee: Alexander Sack (asac) → Martin Pitt (pitti)
Martin Pitt (pitti) wrote :

I seeded -pptp and -pptp-gnome, and uploaded a new ubuntu-meta for this.

I installed both packages, rebooted, and verified that this makes PPTP available in NetworkManager's VPN connection editor, and does not otherwise cause problems.

Changed in ubuntu-meta (Ubuntu Lucid):
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubuntu-meta - 1.190

---------------
ubuntu-meta (1.190) lucid; urgency=low

  * Refreshed dependencies
  * Added network-manager-pptp to desktop-recommends (LP: #107738)
  * Added network-manager-pptp-gnome to desktop-recommends
 -- Martin Pitt <email address hidden> Mon, 15 Mar 2010 07:51:48 +0100

Changed in ubuntu-meta (Ubuntu Lucid):
status: Fix Committed → Fix Released

On Sat, Mar 13, 2010 at 12:43:27PM -0000, Mathieu Trudel wrote:
> Steve,
>
> My take on it is that while network-manager could Recommend network-
> manager-pptp, in the case of the ubuntu seeds, the network-manager-pptp-
> gnome package would have to be seeded (otherwise PPTP is pretty much
> useless). For the kubuntu seeds, network-manager-pptp is sufficient (and
> seeding -pptp-gnome would bring in unnecessary gnome dependencies).

we could recommend -pptp | knetworkmanager ....

anyway, would not be the first time we couldnt recommend what we wanted
because of kubuntu. so seeding is fine too imo.

 - Alexander

Alexander,

I'm already working on it, and will recommend on network-manager-pptp | network-manager-kde, much as it is already done to recommend the UI to install.

/ Matt

Curtis Hovey (sinzui) on 2011-11-11
no longer affects: null
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers