Ubuntu

ubuntu-server install takes up too much space

Reported by Paul Larson on 2012-09-21
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
ubuntu-docs (Ubuntu)
High
James Page
Quantal
High
James Page
ubuntu-meta (Ubuntu)
Low
James Page

Bug Description

Installing a recent iso of ubuntu-server, I observed that a base install (no tasks selected) took up approximately 1G on amd64, and 800M on i386.

According to the recommendations on precise at https://help.ubuntu.com/12.04/serverguide/preparing-to-install.html
1G should be plenty for all tasks selected, and 500M for no tasks selected.

Either these minimums should be reevaluated and rasised, or we need to concerve some space somewhere.

James Page (james-page) wrote :

Default Ubuntu Server amd64 install - no tasks - 938MB
After 'sudo apt-get clean' to remove any updated packages from the cache: 869MB

Colin Watson (cjwatson) wrote :

That's curious, because pkgsel runs 'apt-get clean'. I suspect the rest is grub-installer and suchlike.

However, this probably doesn't matter in practice because the high-water mark is surely before the apt-get clean.

Changed in ubuntu-meta (Ubuntu Quantal):
importance: Undecided → High
status: New → Confirmed
tags: removed: rls-q-incoming
James Page (james-page) wrote :

Agreed - I'm really just info collecting at this point in time

Interestingly the 'Minimal Install' option (not 'Minimal Virtual Install') resulted in an install of the same size.

James Page (james-page) wrote :

Actually scrub that - my ISO is way old.

James Page (james-page) on 2012-09-21
Changed in ubuntu-meta (Ubuntu Quantal):
status: Confirmed → Incomplete
James Page (james-page) wrote :

OK - so to summarize amd64 'default' install + options pre/post apt-get clean:

Standard Install - No Tasks: 928MB/875MB
Minimal Install - No Tasks: 876MB/806MB
Minimal Virtual Install - No Tasks: 644MB/575MB

Changed in ubuntu-meta (Ubuntu Quantal):
status: Incomplete → Confirmed
Paul Larson (pwlars) wrote :

I had set some installs running last night before going to sleep to get some more numbers, but you beat me to it. Here's one more:
i386, all tasks selected from the install screen (except manual package selection of course): 1517M/1475M

James Page (james-page) on 2012-10-09
Changed in ubuntu-meta (Ubuntu Quantal):
importance: High → Low
Changed in ubuntu-docs (Ubuntu Quantal):
assignee: nobody → James Page (james-page)
importance: Undecided → High
milestone: none → ubuntu-12.10
James Page (james-page) on 2012-10-10
no longer affects: ubuntu-meta (Ubuntu Quantal)
James Page (james-page) on 2012-10-10
Changed in ubuntu-docs (Ubuntu Quantal):
status: New → In Progress
James Page (james-page) on 2012-10-10
Changed in ubuntu-meta (Ubuntu):
status: Confirmed → Triaged
James Page (james-page) on 2012-10-12
Changed in ubuntu-meta (Ubuntu):
status: Triaged → Won't Fix
James Page (james-page) on 2012-10-16
Changed in ubuntu-docs (Ubuntu Quantal):
status: In Progress → Fix Committed
Paul Larson (pwlars) wrote :

This is a bit of a moving target, but looking at the branch that was recently proposed for this, it looks like the new minimums set for minimal requirements are:
default (no additional tasks selected): 700 MB (N.B. if doing an install on a system with the minimal memory config also, this could be too low because swapspace will be needed)
All tasks selected: 1.4G

Currently, with the 20121015.2 image, I'm seeing the following on amd64:
No extra tasks selected (default): 1.1G
 - After apt-get clean: 986M
All tasks selected: 1.7G
 - After apt-get clean: 1.6G

So I think our numbers here are still on the low side unless I misread (I lack context in the patch to tell for sure so I'm just comparing against text of current serverguide)

James Page (james-page) wrote :

Paul

The figures where based on amd64 figures as follows:

Standard Install - No Tasks: 928MB/875MB
Minimal Virtual Install - No Tasks: 644MB/575MB

To use the lower set of requirements you must select 'Minimal Virtual' install from the first ISO menu that appears.

Paul Larson (pwlars) wrote :

I see, so I tried minimal virtual on amd64 and got:
759M / 691M

Not trying to be overly picky about this, but I had a test I was trying to make to watch and make sure that we don't start growing way bigger than we say our minimum requirements are without getting noticed. So I'm trying to sort out where I should really set that mark.

Jeremy Bicha (jbicha) wrote :

I believe this is fixed for the serverguide for 12.10: https://help.ubuntu.com/12.10/serverguide/preparing-to-install.html

Changed in ubuntu-docs (Ubuntu):
status: Fix Committed → Fix Released
Changed in ubuntu-docs (Ubuntu Quantal):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers