I/O Error after clicking "reboot now" - Ubuntu font missing from casper shutdown

Bug #1760598 reported by Jacob Kim on 2018-04-02
54
This bug affects 10 people
Affects Status Importance Assigned to Milestone
ubuntu-mate
Undecided
Unassigned
casper (Ubuntu)
Undecided
Unassigned
systemd (Ubuntu)
Undecided
Unassigned
ubiquity (Ubuntu)
Undecided
Unassigned
ubuntu-mate-welcome (Ubuntu)
Undecided
Unassigned

Bug Description

ubuntu Plymouth theme now correctly uses Ubuntu font, meaning it needs to be cached for display of the shutdown message.

We really should be using shutdown initramfs on the livecd....

--

Tested in Virtualbox VM.
Ubuntu MATE works after force-reboot, but after I click on "restart now" after completing the installation, the screen shows me this:

req_error: I/O error, dev sr0, sector 1488792

And the above message loops a couple times, and wont turn off the computer to restart.

No error happens after force reboot, and the OS boots properly, but I'm curious as to what's causing this.

Jacob Kim (coolpolygons) wrote :
Jacob Kim (coolpolygons) on 2018-04-02
description: updated
Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/1760598

tags: added: iso-testing
Luke Horwell (lah7) on 2018-04-02
Changed in ubuntu-mate-welcome (Ubuntu):
status: New → Invalid

Just seen that with a Beta2 candidate install. https://i.imgur.com/wkGEGLF.png

Changed in ubiquity (Ubuntu):
status: New → Confirmed
tags: added: rls-bb-incoming
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in systemd (Ubuntu):
status: New → Confirmed
Marco Parillo (marco-parillo) wrote :

Also affects Kubuntu.

summary: - I/O Error after clicking "reboot now"
+ I/O Error after clicking "reboot now" - Ubuntu font missing from casper
+ shutdown
Changed in systemd (Ubuntu):
status: Confirmed → Invalid
Changed in casper (Ubuntu):
status: New → Confirmed
description: updated
Changed in casper (Ubuntu):
status: Confirmed → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package casper - 1.393

---------------
casper (1.393) bionic; urgency=medium

  * Cache Ubuntu fonts for plymouth on shutdown. LP: #1760598

 -- Dimitri John Ledkov <email address hidden> Wed, 04 Apr 2018 11:55:32 +0100

Changed in casper (Ubuntu):
status: Fix Committed → Fix Released
Changed in ubuntu-mate:
status: New → Invalid
Dimitri John Ledkov (xnox) wrote :

Keeping ubiquity task open; until after we respin, and test that this issue is gone. It is cosmetic, and the only side effect that one does not see the final message "please remove installation media and hit enter". I'm hoping the first daily after beta will be fixed.

Harald Sitter (apachelogger) wrote :

As explained in Bug #1761478 that would still leave timing issues. With --ping not blocking anymore casper-stop can shoot right past the prompt code on account of --ping coming back !0 (if plymouth isn't quick enough to start anyway). Meaning the user doesn't get told to remove the installation medium.

e.g. this is what I get in a VM now http://people.ubuntu.com/~apachelogger/screencasts/vokoscreen-2018-04-06_13-40-13.mkv

Steve Langasek (vorlon) on 2018-04-13
Changed in ubiquity (Ubuntu):
status: Confirmed → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers