Ubuntu MATE Welcome "freezes" during opening animation

Bug #1658996 reported by Utz
22
This bug affects 4 people
Affects Status Importance Assigned to Milestone
ubuntu-mate-welcome (Ubuntu)
High
Unassigned
unity-gtk-module (Ubuntu)
High
Martin Wimpress 

Bug Description

The window content was still visible while installing from the iso image.
Ubuntu Zesty Zapus (development branch) 17.04
ubuntu-mate-welcome version 17.04.01

I tried to set the font size (see message "[Welcome] DPI below 50. Out of range.."), but it only removes the message, window stays empty

Revision history for this message
Utz (utz-recke) wrote :
tags: added: zesty
Revision history for this message
Luke Horwell (lah7) wrote :

Which architecture? What graphics card and drivers do you have installed?

It's a known issue under PowerPC for this to happen. It's likely caused by external factors if on a i386 or amd64 PC.

Revision history for this message
Utz (utz-recke) wrote : Re: welcome stays empty

uname -m
x86_64

lspci | grep "VGA"
00:02.0 VGA compatible controller: InnoTek Systemberatung GmbH VirtualBox Graphics Adapter

lsmod | grep "vid"
vboxvideo 49152 2
ttm 98304 1 vboxvideo
drm_kms_helper 151552 1 vboxvideo
drm 339968 5 vboxvideo,ttm,drm_kms_helper
vboxguest 294912 7 vboxsf,vboxvideo
syscopyarea 16384 2 vboxvideo,drm_kms_helper
sysfillrect 16384 2 vboxvideo,drm_kms_helper
sysimgblt 16384 2 vboxvideo,drm_kms_helper
video 40960 0

VBox version on windows host: 5.1.14 r112924 (Qt5.6.2)

Revision history for this message
Martin Wimpress  (flexiondotorg) wrote :

I randomly encountered this, once, while testing last night. I saw the same "[Welcome] DPI below 50. Out of range..") message and Welcome rendered only a white window.

Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in ubuntu-mate-welcome (Ubuntu):
status: New → Confirmed
Revision history for this message
Luke Horwell (lah7) wrote :

This is most likely an issue with WebKit2, the library used for rendering HTML.

Please could you check the last few lines of dmesg when this happens again? It could be possible a process named "WebKitWebView" produces a segfault, but the application will continue running.

Revision history for this message
Utz (utz-recke) wrote :

Hi Luke, thank you for your comment.

I can't find any evidence of an error in WebKit...
dmesg | grep -i 'web' ... stays empty

Last Message in dmesg is:
[23577.089643] traps: mate-maximus[2208] trap int3 ip:7f1c9b478db1 sp:7fffcda6e4f0 error:0
[23577.089647] in libglib-2.0.so.0.5104.0[7f1c9b429000+111000]

Not sure if it is related.

Revision history for this message
Utz (utz-recke) wrote :

I think this could shade some more light onto it:
[Debug] Running in debugging mode.
[Welcome] Using /usr/share/ubuntu-mate-welcome/ path.
[i18n] Locale Not Available: null (using en_US instead)
[i18n] Locale Not Available: null (using en_US instead)
[i18n] All translated i18n pages found.
[i18n] Using locale for gettext: null
[i18n] Using path for gettext: /usr/share/ubuntu-mate-welcome/locale/
[i18n] Translation found for gettext.
[Queue] Preferences loaded from file.
[Specs] Detecting graphics vendor...
[Network Test] Establishing a connection test to "http://archive.ubuntu.com/"
[Welcome] Font DPI is: 0
[Welcome] DPI below 50. Out of range..
[Specs] Detected: InnoTek Systemberatung GmbH VirtualBox Graphics Adapter
[Welcome] Setting zoom level to: 1.0
[Welcome] Successfully pinged: http://archive.ubuntu.com/
[Apps] Reading index...
[Apps] Successfully loaded index.
[Config] Read "hide_non_free" => "False"
[Welcome] Version: 17.04.10
[Pre-Install] System is running Ubuntu 17.04 (zesty)
[Welcome] Application Ready.

(gst-plugin-scanner:9298): GStreamer-WARNING **: Failed to load plugin '/usr/lib/x86_64-linux-gnu/gstreamer-1.0/libgstmirsink.so': /usr/lib/x86_64-linux-gnu/gstreamer-1.0/libgstmirsink.so: undefined symbol: glFramebufferTexture2D
[Welcome] Page: splash.html
      file:///usr/share/ubuntu-mate-welcome/splash.html
utz@URMate64:~$ [Welcome] Page: index.html
      file:///usr/share/ubuntu-mate-welcome/index.html

Revision history for this message
Luke Horwell (lah7) wrote :

Unfortunately, there isn't much on Welcome's end that can be done to "fix" this.

This strange (and difficult to diagnose) issue is caused by external libraries failing leading to a segfault/error with the WebKitWebView process, which is responsible for rendering the window.

On some other software I maintain, another user had a blank screen issue like this, but it was caused by a library named "libc". Bizarrely, the issue went away after their system (16.04) was updated.

The "DPI out of range" is just a warning, this isn't the problem.

As this is affecting a development build (17.04), please could you try again on a fresh install of 17.04?

Revision history for this message
Utz (utz-recke) wrote :

Before I did see the last comment I did some more tests. I upgraded vbox (from 5.1.16 to 5.1.18) together with the guest additions. This removed the library loading problem. Next I did set the font-dpi=96 so this warning goes away too (it anyway defaults to 96 ...)

Here is the current output:
[Debug] Overriding font DPI to 96.
[Debug] Verbose mode enabled.
[Welcome] Using /usr/share/ubuntu-mate-welcome/ path.
[i18n] Locale Not Available: en_US (using en_US instead)
[i18n] Locale Not Available: en (using en_US instead)
[i18n] All translated i18n pages found.
[i18n] Using locale for gettext: en
[i18n] Using path for gettext: /usr/share/ubuntu-mate-welcome/locale/
[i18n] Translation found for gettext.
[Queue] Preferences loaded from file.
[Network Test] Establishing a connection test to "http://archive.ubuntu.com/"
[Specs] Detecting graphics vendor...
[Specs] Detected: InnoTek Systemberatung GmbH VirtualBox Graphics Adapter
[Welcome] Setting zoom level to: 1.0
[Welcome] Successfully pinged: http://archive.ubuntu.com/
[Apps] Reading index...
[Apps] Successfully loaded index.
[Welcome] Version: 17.04.10
[Pre-Install] System is running Ubuntu 17.04 (zesty)
[Welcome] Application Ready.
[Welcome] Application Closed

I will try with a fresh install eventually if I do find the time. BTW I installed - on the same day - a physical machine with the same 17.04 dev build and never faced that problem. Seams it is a combination of vboxvideo and WebKitWebView.

Revision history for this message
Andres S. Vasile (andyvasile) wrote :

I'm running Ubuntu MATE in an Odroid XU4 and had the same problem after an update (can't really say which). The solution I've found is to remove the Mate package and install it back again:

sudo apt-get remove ubuntu-mate-welcome
sudo apt-get install ubuntu-mate-welcome

After installing ubuntu-mate-welcome, the screen is no longer rendering in Blank, plus the DPI warning is still showing up when running it via terminal despite the app running normally.

Hope it works for you guys.

Revision history for this message
Utz (utz-recke) wrote :

Hi Andres, I did this unisnstall and install already (and tried again a few minutes ago. However I have still the sam result.

Revision history for this message
Marc (zagnut) wrote :

I have the same issue of a blank all white Welcome screen when installing Ubuntu Mate 17.04 on VirtualBox 5.1.20 on both my laptop and desktop. The Welcome screen is visible at first but as soon as I install the guest additions that let me use full screen mode the Welcome screen and Software Boutique stop working and are just all white windows.

The laptop is a 2.8GHz core i5, 8 GB of RAM, 1920 x 1080 15" monitor, intel HD Graphics 4600 & Nvidia GTX 860M. The desktop is a 3.4GHZ core i7, 16 GB RAM, 1920 x 1080 monitor, Radeon HD 6970 graphics card.

I had no luck trying
sudo apt-get remove ubuntu-mate-welcome
sudo apt-get install ubuntu-mate-welcome

Trying Ubuntu Mate 16.10 in Virtualbox on the laptop results in the same issue once the guest additions are installed to allow full screen mode.

Revision history for this message
Adam Esmail (adamesmail) wrote :

Hi everyone. I had this same issue of blank Welcome/Software Boutique with Ubuntu MATE 17.04 on VirtualBox 5.1.22 with the guest additions installed. However, I managed to fix it by disabling 3D acceleration (and disabling the VBOX graphics adapter beforehand).

However, the Welcome screen and the Software Boutique do work with 3D acceleration with Ubuntu MATE 16.04 LTS. Does anyone think the move from GTK2 to GTK3 might be part of the issue or is that just a coincidence?

Revision history for this message
Luke Horwell (lah7) wrote :

> Does anyone think the move from GTK2 to GTK3 might be part of the issue or is that just a coincidence?

Likely just coincidence - this "white screen" problem has happened to 16.04 users too, and I've known it to happen to another WebKit2-based application too. The problem bizarrely just goes away with general system updates.

However, this is a tough one to fix, as it isn't a fault of Welcome but rather the WebKit2 library it depends on. Please check dmesg for errors or stack traces, which will help determine a bug report for the WebKitGTK developers.

Revision history for this message
Martin Wimpress  (flexiondotorg) wrote :

@lah7 on a fresh install of a fully updated Ubuntu MATE 17.10 daily image I see that Welcome is "freezing" when loading via the auto start. However, if launched from a terminal it works reliably. Can you have a poke about please :-)

Changed in ubuntu-mate-welcome (Ubuntu):
importance: Undecided → High
Changed in ubuntu-mate-welcome (Ubuntu):
status: Confirmed → Triaged
Changed in unity-gtk-module (Ubuntu):
status: New → Triaged
importance: Undecided → High
assignee: nobody → Martin Wimpress (flexiondotorg)
Changed in ubuntu-mate-welcome (Ubuntu):
status: Triaged → Invalid
summary: - welcome stays empty
+ Ubuntu MATE Welcome "freezes" during opening animation
Changed in unity-gtk-module (Ubuntu):
status: Triaged → In Progress
Changed in unity-gtk-module (Ubuntu):
status: In Progress → Fix Committed
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity-gtk-module - 0.0.0+17.10.20170817-0ubuntu1

---------------
unity-gtk-module (0.0.0+17.10.20170817-0ubuntu1) artful; urgency=medium

  * Properly limit the workaround to DnD windows only to complete the
    intended implementation for LP: #1710999. Thanks to Konstantin
    Putin. (LP: #1658996)

 -- Martin Wimpress <email address hidden> Thu, 17 Aug 2017 11:46:19 +0000

Changed in unity-gtk-module (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments