Option (Ctrl-C) not shown to disable ISO verification

Bug #1870018 reported by Bill (franksmcb) on 2020-04-01
14
This bug affects 3 people
Affects Status Importance Assigned to Milestone
budgie-artwork (Ubuntu)
Undecided
Unassigned
Focal
Undecided
Unassigned
casper (Ubuntu)
Undecided
Dimitri John Ledkov
Focal
Undecided
Dimitri John Ledkov
kubuntu-settings (Ubuntu)
Undecided
Unassigned
Focal
Undecided
Unassigned
lubuntu-artwork (Ubuntu)
Undecided
Unassigned
Focal
Undecided
Unassigned
ubuntu-gnome-default-settings (Ubuntu)
Undecided
Unassigned
Focal
Undecided
Unassigned
ubuntu-mate-artwork (Ubuntu)
Undecided
Unassigned
Focal
Undecided
Unassigned
xubuntu-artwork (Ubuntu)
Undecided
Unassigned
Focal
Undecided
Unassigned

Bug Description

Ubuntu MATE Beta 20.04 03312020

No option shown to disable ISO verification as seen in pervious build.
.
S key does not stop ISO verification check.

Tested in Thinkpad T430 and in QEMU virtual machine.

Expected outcome:
Text is displayed telling user to press S key to cancel ISO verification test
Pressing S key has no effect.

Actual outcome:
No text telling user to press S to stop ISO disk checking
S key does not stop disk checking

ProblemType: Bug
DistroRelease: Ubuntu 20.04
Package: casper 1.442
ProcVersionSignature: Ubuntu 5.4.0-21.25-generic 5.4.27
Uname: Linux 5.4.0-21-generic x86_64
NonfreeKernelModules: zfs zunicode zavl icp zcommon znvpair
ApportVersion: 2.20.11-0ubuntu21
Architecture: amd64
CasperVersion: 1.442
CurrentDesktop: MATE
Date: Wed Apr 1 04:47:45 2020
LiveMediaBuild: Ubuntu-MATE 20.04 LTS "Focal Fossa" - Beta amd64 (20200331)
ProcEnviron:
 PATH=(custom, no user)
 XDG_RUNTIME_DIR=<set>
 LANG=C.UTF-8
 SHELL=/bin/bash
SourcePackage: casper
UpgradeStatus: No upgrade log present (probably fresh install)
mtime.conffile..etc.casper.conf: 2020-04-01T04:46:08.801695

Bill (franksmcb) (franksmcb) wrote :
summary: - Not option show to disable ISO verification S key not working
+ Not option shown to disable ISO verification S key not working

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/1870018

tags: added: iso-testing
summary: - Not option shown to disable ISO verification S key not working
+ No option shown to disable ISO verification S key not working

I've noted the same using today's Lubuntu 20.04 daily.
There was no message to skip was the big 'new' difference I saw.

I have only achieved the 'skip' once using Lubuntu's daily since it was introduced, but I've tried multiple times with today's daily and I 'waited' for it at least 3 times today.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in casper (Ubuntu):
status: New → Confirmed
Leó Kolbeinsson (leok) wrote :

I also noticed this today testing Lubuntu 20.04 daily but assumed it was by design and not a bug.(as the S skip option was not displayed)

Sebastien Bacher (seb128) wrote :

The keybinding was recently changed to ctrl-C
https://launchpad.net/ubuntu/+source/casper/1.442

Also it changed slightly the protocol to be fsckd compatible but maybe those flavor themes don't handle that well? (the message is showing the ubuntu iso with spinner)

Paul White (paulw2u) wrote :

Using Xubuntu (20200331) I also don't see the option to skip but Ctrl-C does work as it should. However, the space in which I would expect to see the skip prompt is taken up by the file check messages which are displayed on five lines. That is, previous messages are not being over-written correctly. New messages are being displayed below the previous one.

Sebastien Bacher (seb128) wrote :

Could you add a screenshot of the issue?

It looks like maybe the xubuntu plymouth theme needs some fixing...

Dimitri John Ledkov (xnox) wrote :

I think this is a casper regression with old themes compat.

summary: - No option shown to disable ISO verification S key not working
+ Option (Ctrl-C) not shown to disable ISO verification
Iain Lane (laney) on 2020-04-01
Changed in casper (Ubuntu):
milestone: none → ubuntu-20.04
tags: added: rls-ff-incoming
Paul White (paulw2u) wrote :

Screenshot of Xubuntu 20.04 file check

Dimitri John Ledkov (xnox) wrote :

There is a bug in the ubuntu-logo theme script which eats the Ctrl+C message. Meaning, it was never shown correctly during on-boot fsck with systemd-fckd.

And also it was copied across into all the derivatives of the plymouth theme.

I could send an "old" style keys: message that should work in casper, but that needs some kind of a detection if the theme supports new messages or not.

It would be nice to fix all the themes properly though.

Changed in casper (Ubuntu):
assignee: nobody → Dimitri John Ledkov (xnox)
fossfreedom (fossfreedom) wrote :

Any hints about what should be changed to resolve this please? Any sort of example code would be most appreciated.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package casper - 1.443

---------------
casper (1.443) focal; urgency=medium

  * Make fsckd under spinner/logo themes produce consistent output
  * Make plymouth-less progress output less bad
  * Use theme-specific keys: or fsckd-cancel-msg: for Ctrl+C message LP:
    #1870018
  * Add fsck.mode=skip sensitivity to casper-md5check
  * ubuntu-server: skip mounting swap (as hacked by livecd-rootfs currently)
  * Leave fsck result as a json /run/casper-md5check.json file.
  * ubuntu-server: adapt runtime netplan into cloud-config cloud.cfg
  * Fix cmdline parsing, it was always broken

 -- Dimitri John Ledkov <email address hidden> Fri, 03 Apr 2020 13:04:38 +0100

Changed in casper (Ubuntu Focal):
status: Confirmed → Fix Released
Changed in plymouth (Ubuntu Focal):
status: New → Invalid
Mathew Hodson (mhodson) on 2020-04-24
no longer affects: plymouth (Ubuntu Focal)
no longer affects: plymouth (Ubuntu)
tags: removed: rls-ff-incoming
Mathew Hodson (mhodson) on 2020-10-03
Changed in casper (Ubuntu):
milestone: ubuntu-20.04 → none
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers