Firefox search and location boxes have black borders when unselected

Bug #1624738 reported by APolihron on 2016-09-17
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
ubuntu-mate-artwork (Ubuntu)
Low
Martin Wimpress
ubuntu-themes (Ubuntu)
Low
Martin Wimpress

Bug Description

[Impact]

As seen in the attached screen shot the borders around Firefox location and search entry boxes are black when unselected, but they should be grey.

The black borders are inconsistent with the rest of the Ubuntu theming and it looks jarring.

The issue is resolved by styling the 'frame' selector, which Firefox uses to style the Search and Location entry boxes. Some overrides are then applied to prevent frames incorrectly rendering borders in other applications.

[Test Case]

To observe the issue simply open Firefox and look at the Search or Location entry boxes while they are unselected, the borders will be black.

After installing the patched theme doing to same will result in the borders being rendered using an appropriate shade of grey.

[Regression Potential]

It is possible that some GTK3+ applications may now render frames with a border where they previously did not. That said, the default applications in Ubuntu have been checked for this regression and the appropriate overrides have been added.

The default installed applications in Ubuntu have been tested to ensure they do not regress in the manner described above.

[Other Info]

Should Firefox style the Search and Location entry boxes with a discrete selector in the future then the styling added to work around the black border could be removed/updated.

APolihron (apolitech) wrote :
APolihron (apolitech) wrote :
description: updated
Martin Wimpress (flexiondotorg) wrote :

Looks fine to me, what are you reporting exactly?

Changed in ubuntu-mate:
status: New → Incomplete
APolihron (apolitech) wrote :

The search box(the line its black) diferent from the left one that have green lines and there its a black line under the top header of the app ( under the search box, www box and so on) see the second pic to make the difference between them)

Changed in ubuntu-mate:
status: Incomplete → Triaged
importance: Undecided → Low
Changed in ubuntu-mate-artwork (Ubuntu):
status: New → Triaged
importance: Undecided → Low
no longer affects: ubuntu-mate
summary: - Ubuntu mate 16.10 Firefox theme bug
+ Firefox search and location boxes have black borders when unselected
Martin Wimpress (flexiondotorg) wrote :

The bg of the Firefox entry is styled by this selector, which feel like this might possibly be a Firefox bug:

https://github.com/flexiondotorg/ubuntu-mate-themes/blob/master/usr/share/themes/Ambiant-MATE/gtk-3.0/gtk-widgets.css#L824

tags: added: yakkety
description: updated
Changed in ubuntu-themes (Ubuntu):
status: New → Triaged
Changed in ubuntu-mate-artwork (Ubuntu):
assignee: nobody → Martin Wimpress (flexiondotorg)
Changed in ubuntu-themes (Ubuntu):
assignee: nobody → Martin Wimpress (flexiondotorg)
importance: Undecided → Low
Martin Wimpress (flexiondotorg) wrote :

The border colour can be set with:

frame {
    border-width: 1px;
    border-style: solid;
    border-color: shade (@bg_color, 0.82);
}

But 'frame' is used widely in many applications which results in borders being rendered where you really don't want them. The following will style Firefox and then override that styling where it is not required. I've tested most default applications in Ubuntu and the following appears to work well, more testing would be good.

/* Style frame for firefox to set the search/location entry box borders*/
frame {
    border-width: 1px;
    border-style: solid;
    border-color: shade (@bg_color, 0.82);
}

/* Override frame styling set for firefox to prevent erroneous frames being rendered */
box > frame, /* common in settings panels */
statusbar > frame, /* common in application status bars, etc. */
statusbar > widget > frame, /* common in application status bars, etc. */
GvcMixerDialog frame { /* some audio mixers */
    border-width: 0px;
    border-style: none;
}

Changed in ubuntu-mate-artwork (Ubuntu):
status: Triaged → Fix Committed
Changed in ubuntu-themes (Ubuntu):
status: Triaged → In Progress
description: updated
Martin Wimpress (flexiondotorg) wrote :

The following merge proposal has been filed for ubuntu-themes:

  * https://code.launchpad.net/~flexiondotorg/ubuntu-themes/lp1624738/+merge/308032

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubuntu-mate-artwork - 16.10.9

---------------
ubuntu-mate-artwork (16.10.9) yakkety; urgency=medium

  * Fix Firefox download progress bars. (LP: #1630224)
  * Fix Unlock button for Time and Date Settings. (LP: #1630910)
  * Fix Back/Forward navigation buttons in Yelp. (LP: #1624574)
  * Fix Firefox Search/Location entry box borders. (LP: #1624738)
  * Fix Firefox menu items.

 -- Martin Wimpress <email address hidden> Sun, 09 Oct 2016 20:42:40 +0100

Changed in ubuntu-mate-artwork (Ubuntu):
status: Fix Committed → Fix Released
eyelash (eyelash) wrote :

this seems to be a Firefox bug that should be fixed in Firefox 50:
https://bugzilla.mozilla.org/show_bug.cgi?id=1266914

Ophir LOJKINE (pere-jobs) wrote :

I just upgraded and I am affected by this bug. What should I do ?

Changed in ubuntu-themes (Ubuntu):
status: In Progress → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.