/etc/apt/trusted.gpg is 0600 (should be 644)

Bug #651880 reported by Michael Vogt
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
ubuntu-keyring (Ubuntu)
Fix Released
High
Unassigned
Maverick
Fix Released
High
Unassigned

Bug Description

Binary package hint: apt

On the current live-cd /etc/apt/trusted.gpg is mode 0600. This breaks tools like "update-manager" on release upgrade time that use this file in order to verify the downloaded upgrader. It should be either 0644 or root.admin 0640

Michael Vogt (mvo)
Changed in apt (Ubuntu):
status: New → Confirmed
importance: Undecided → High
milestone: none → ubuntu-10.10
Revision history for this message
Michael Vogt (mvo) wrote :

It appears this is caused by ubuntu-keyring being configured before apt in the livecd build. So apt-key update is called and the default gpg permissions are 600 for the pub keyring file.

Michael Vogt (mvo)
Changed in apt (Ubuntu Maverick):
status: Confirmed → In Progress
assignee: nobody → Michael Vogt (mvo)
affects: apt (Ubuntu Maverick) → ubuntu-keyring (Ubuntu Maverick)
Changed in ubuntu-keyring (Ubuntu Maverick):
assignee: Michael Vogt (mvo) → nobody
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubuntu-keyring - 2010.+09.30

---------------
ubuntu-keyring (2010.+09.30) maverick; urgency=low

  * debian/postinst:
    - set default public keyring to 0644 if there is none yet
      (LP: #651880)
    - fixup maverick installs with 0600 public keyrings permissins
      to avoid problems with the release upgrade later (LP: #651880)
 -- Michael Vogt <email address hidden> Thu, 30 Sep 2010 15:36:26 +0200

Changed in ubuntu-keyring (Ubuntu Maverick):
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers