[osk] An entire emoji quick-jump icon shouldn't be spent on clocks

Bug #1603194 reported by Michael Terry on 2016-07-14
14
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Canonical System Image
Medium
Bill Filler
ubuntu-keyboard (Ubuntu)
Medium
Michael Sheldon

Bug Description

What is the story with the clock category on the current emoji OSK layout?

We have only six quick-jump buttons. Clocks would seem like a very low priority to me.

I don't have a suggestion as to what should replace it. But, like, not clocks.

(Is there any science behind the current layout of emojis / which sections the buttons jump to? I doubt it, because any layout based on the most-used or most-relevant would certainly include the poop emoji more prominently.) :P

Related branches

We have a new branch that'll be finished fairly soon that reworks the categories to be based on those used by the emojione font

Changed in ubuntu-keyboard (Ubuntu):
status: New → Confirmed
assignee: nobody → Michael Sheldon (michael-sheldon)
Michael Terry (mterry) wrote :

Looks like clocks still get their own category there? (Just reading the source.) But it is improved... Instead of "wasting" 1 out of 6 categories, it's only 1 out of 9 categories.

Although it looks like clocks have been moved up to be first category listed, in front of face emojis!

Maybe I don't understand how people use emojis, and there is wide spread clamoring for clocks. But in my eyes, the attached branch does not fix this bug.

In the new branch that's no longer going to be a link to the clock category, instead it's a page of recently used emoji (I think the reason the clocks ended up with their own category in the first place is that we looked at a similar category list on another platform and saw a clock category without realising it was being used for recently used emoji there)

Michael Terry (mterry) wrote :

Ah OK that makes sense. :)

I couldn't figure out why clocks were so favored. :P

Bill Filler (bfiller) on 2016-08-02
Changed in ubuntu-keyboard (Ubuntu):
importance: Undecided → Medium
Changed in canonical-devices-system-image:
milestone: none → 13
assignee: nobody → Bill Filler (bfiller)
importance: Undecided → Medium
status: New → In Progress
Changed in ubuntu-keyboard (Ubuntu):
status: Confirmed → In Progress
Changed in canonical-devices-system-image:
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubuntu-keyboard - 0.100+16.10.20160808.1-0ubuntu1

---------------
ubuntu-keyboard (0.100+16.10.20160808.1-0ubuntu1) yakkety; urgency=medium

  [ Chero Jeong, chero jeong ]
  * Add Korean layout

  [ Florian Boucault ]
  * Fixes for crossbuilding.

  [ Lukáš Tinkl ]
  * Fix uppercase variant of "ů" -> "Ů" in the Czech layout

  [ Michael Sheldon ]
  * Switch to scrollable GridView for Emoji layout (LP: #1441337,
    #1539554, #1603194, #1607672)
  * Fix building against Qt 5.6.1

 -- Michael Sheldon <email address hidden> Mon, 08 Aug 2016 16:58:30 +0000

Changed in ubuntu-keyboard (Ubuntu):
status: In Progress → Fix Released
Changed in canonical-devices-system-image:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers