Emoji keyboard layout shows very few emoji at a time

Bug #1539554 reported by Matthew Paul Thomas on 2016-01-29
22
This bug affects 4 people
Affects Status Importance Assigned to Milestone
Canonical System Image
Medium
Bill Filler
ubuntu-keyboard (Ubuntu)
Medium
Michael Sheldon

Bug Description

Ubuntu 15.04 r224, BQ Aquaris E4.5

1. Switch to the Emoji keyboard.

What you see: Only 18 emoji are shown at a time.
What you should see: Many more than that.

In contrast, the Emoji keyboard on:
* a Nexus 5 shows 21 emoji at once
* an iPhone 5/6 shows 40 emoji at once — more than twice as many, in less space.

There seem to be four reasons for this inefficiency. In order of importance:

A. The spacing between and around the rows is enough, in total, to fit an entire extra row of buttons. (Part of the spacing is because the keys have curved borders, apparently imitating some hardware Emoji keyboard that doesn't exist.)

B. Most of the bottom row is taken up by a space bar, which is seldom relevant when people are typing emoji.

C. Scrolling does not use the standard flick gesture. Instead it uses two dedicated buttons that, as well as being inconsistent with the rest of the OS, take up space on the keyboard.

D. The keyboard has a “?123” button that is redundant with the button for switching layouts.

Related branches

Matthew Paul Thomas (mpt) wrote :
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in ubuntu-keyboard (Ubuntu):
status: New → Confirmed
Changed in ubuntu-keyboard (Ubuntu):
assignee: nobody → Jons Ryan (gameoverlol82)
Bill Filler (bfiller) on 2016-08-02
Changed in ubuntu-keyboard (Ubuntu):
assignee: Jons Ryan (gameoverlol82) → Michael Sheldon (michael-sheldon)
Changed in canonical-devices-system-image:
assignee: nobody → Bill Filler (bfiller)
milestone: none → 13
Changed in ubuntu-keyboard (Ubuntu):
importance: Undecided → Medium
Changed in canonical-devices-system-image:
importance: Undecided → Medium
Changed in ubuntu-keyboard (Ubuntu):
status: Confirmed → In Progress
Changed in canonical-devices-system-image:
status: New → In Progress
Changed in canonical-devices-system-image:
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubuntu-keyboard - 0.100+16.10.20160808.1-0ubuntu1

---------------
ubuntu-keyboard (0.100+16.10.20160808.1-0ubuntu1) yakkety; urgency=medium

  [ Chero Jeong, chero jeong ]
  * Add Korean layout

  [ Florian Boucault ]
  * Fixes for crossbuilding.

  [ Lukáš Tinkl ]
  * Fix uppercase variant of "ů" -> "Ů" in the Czech layout

  [ Michael Sheldon ]
  * Switch to scrollable GridView for Emoji layout (LP: #1441337,
    #1539554, #1603194, #1607672)
  * Fix building against Qt 5.6.1

 -- Michael Sheldon <email address hidden> Mon, 08 Aug 2016 16:58:30 +0000

Changed in ubuntu-keyboard (Ubuntu):
status: In Progress → Fix Released
Changed in canonical-devices-system-image:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers