The letter is missing from the "h" key

Bug #1421812 reported by Pat McGowan on 2015-02-13
52
This bug affects 8 people
Affects Status Importance Assigned to Milestone
Canonical System Image
High
Bill Filler
ubuntu-keyboard (Ubuntu)
High
Michael Sheldon

Bug Description

Use the keyboard anywhere in the system
The key for lowercase "h" is blank.
This is on vivid

Related branches

Gustavo Pichorim Boiko (boiko) wrote :

After some restarts here, it switched from "h" to uppercase "E" being missing.
Tried many different layouts and most of them reproduce the issue.

The problem only happens when maliit-server is started using upstart. If I stop maliit-server and start it manually, the problem does not happen.

Possibly something up with the font rendering on arale, it's not currently reproducible on other devices. It also doesn't occur on arale if maliit is started directly from the terminal, only when starting through its upstart job.

It'd be handy if someone with an arale device could add "env" to their maliit upstart job "/usr/share/upstart/sessions/maliit-server.conf" and list the output.

description: updated
Pat McGowan (pat-mcgowan) wrote :

I flashed 106 earlier today, and I have all the letters including "h"

Changed in ubuntu-keyboard (Ubuntu):
status: Confirmed → Incomplete
Pat McGowan (pat-mcgowan) wrote :

putting back to confirmed due to recent dupes

Changed in ubuntu-keyboard (Ubuntu):
assignee: nobody → Michael Sheldon (michael-sheldon)
status: Incomplete → Confirmed
Pat McGowan (pat-mcgowan) wrote :

This has been cited more in recent days, also on mako

Changed in canonical-devices-system-image:
assignee: nobody → Bill Filler (bfiller)
importance: Undecided → High
milestone: none → ww13-2015
status: New → Confirmed
description: updated
Bill Filler (bfiller) wrote :

According to mfrey, it's quite easy to reproduce on Arale.
It happens when switching from uppercase H (which is visible) to lowercase then it disappears. Or you can see it all the time in webbrowser app, where the key is lowercase by default.

Bill Filler (bfiller) wrote :

Did some debugging with Elleo.

I found two ways that seem to make the h key reliably work, both by modifying:
/usr/share/maliit/plugins/com/ubuntu/keys/key_constants.js

and then "restart maliit-server"

1) change fontFamily from "Ubuntu Medium"; to "Ubuntu"
2) change fontSize from "2.5" to "2.4"

interestingly, increasing the font size, I tried 3.0 and 4.0 the h key still works, so the problem does not seem to be that the font won't fit. Seems only fontSize at 2.5 with Ubuntu Medium font family causes it. Changing either makes it work.

I don't notice any difference visually when changing the fontFamily to "Ubuntu" - looks the exact same to me. So unless we have a more scientific way to fix this, I'd vote for making that change.

Bill Filler (bfiller) wrote :

forgot to metion that changing fontBold from false to true also makes the problem go away reliably

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubuntu-keyboard - 0.99.trunk.phablet2+15.04.20150326-0ubuntu1

---------------
ubuntu-keyboard (0.99.trunk.phablet2+15.04.20150326-0ubuntu1) vivid; urgency=medium

  [ Bill Filler ]
  * change fontFamily to Ubuntu to work around disappearing "h" key (LP:
    #1421812)

  [ CI Train Bot ]
  * New rebuild forced.

  [ Michael Sheldon ]
  * Avoid reporting false visibility signal during startup (LP:
    #1436076, #1419814)
 -- CI Train Bot <email address hidden> Thu, 26 Mar 2015 21:40:49 +0000

Changed in ubuntu-keyboard (Ubuntu):
status: Confirmed → Fix Released
Bill Filler (bfiller) on 2015-04-09
Changed in canonical-devices-system-image:
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers